summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-19 07:29:43 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-19 07:29:43 +0000
commit4c80681a85b749c32f471ec4b13be50aebbbfc85 (patch)
tree69892d0ff70d1e5a245c09502b58e44a0592616d
parentVersion bump with bug fixes. (diff)
downloadgentoo-2-4c80681a85b749c32f471ec4b13be50aebbbfc85.tar.gz
gentoo-2-4c80681a85b749c32f471ec4b13be50aebbbfc85.tar.bz2
gentoo-2-4c80681a85b749c32f471ec4b13be50aebbbfc85.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--dev-ruby/httparty/ChangeLog7
-rw-r--r--dev-ruby/httparty/httparty-0.6.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index e96f7579925d..7aa8ed278237 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.16 2010/06/25 20:23:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.17 2010/07/19 07:29:43 graaff Exp $
+
+*httparty-0.6.1 (19 Jul 2010)
+
+ 19 Jul 2010; Hans de Graaff <graaff@gentoo.org> +httparty-0.6.1.ebuild:
+ Version bump.
*httparty-0.6.0 (25 Jun 2010)
diff --git a/dev-ruby/httparty/httparty-0.6.1.ebuild b/dev-ruby/httparty/httparty-0.6.1.ebuild
new file mode 100644
index 000000000000..53df9a1d0215
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.6.1.ebuild,v 1.1 2010/07/19 07:29:43 graaff Exp $
+
+EAPI=2
+
+# ruby19 → testsuite fails (might be crack's bug)
+# jruby → testsuite fails (seems like a testuite bug)
+USE_RUBY="ruby18"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
+HOMEPAGE="http://httparty.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Code should most likely be patched, but for now…
+ruby_add_rdepend '~dev-ruby/crack-0.1.8'
+
+ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
+
+all_ruby_prepare() {
+ # as often, Rakefile depends on Jeweler's presence
+ sed -i \
+ -e '/check_dependencies/s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby18)
+ # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
+ ${RUBY} -S rake spec features || die "cucumber tests failed"
+ ;;
+ *)
+ ${RUBY} -S rake spec || die "cucumber tests failed"
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}