summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-12 18:16:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-12 18:16:57 +0000
commit4dc357142eb133ef33623b205c852adf00717e11 (patch)
treec54fb71ec2bd9095b53330da0338706c7ef58695
parentportaudio cxx useflag (diff)
downloadgentoo-2-4dc357142eb133ef33623b205c852adf00717e11.tar.gz
gentoo-2-4dc357142eb133ef33623b205c852adf00717e11.tar.bz2
gentoo-2-4dc357142eb133ef33623b205c852adf00717e11.zip
bump a new snapshot from upstream
(Portage version: 2.1.4)
-rw-r--r--media-libs/portaudio/ChangeLog10
-rw-r--r--media-libs/portaudio/files/digest-portaudio-19_pre200712073
-rw-r--r--media-libs/portaudio/portaudio-19_pre20071207.ebuild44
3 files changed, 55 insertions, 2 deletions
diff --git a/media-libs/portaudio/ChangeLog b/media-libs/portaudio/ChangeLog
index 52bb2a6a05ce..744d352280c1 100644
--- a/media-libs/portaudio/ChangeLog
+++ b/media-libs/portaudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/portaudio
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.48 2007/10/15 14:36:45 corsair Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/ChangeLog,v 1.49 2008/01/12 18:16:56 aballier Exp $
+
+*portaudio-19_pre20071207 (12 Jan 2008)
+
+ 12 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +portaudio-19_pre20071207.ebuild:
+ bump a new snapshot from upstream
15 Oct 2007; Markus Rothe <corsair@gentoo.org> portaudio-18.1-r6.ebuild:
Stable on ppc64
diff --git a/media-libs/portaudio/files/digest-portaudio-19_pre20071207 b/media-libs/portaudio/files/digest-portaudio-19_pre20071207
new file mode 100644
index 000000000000..54c970af8836
--- /dev/null
+++ b/media-libs/portaudio/files/digest-portaudio-19_pre20071207
@@ -0,0 +1,3 @@
+MD5 d2943e4469834b25afe62cc51adc025f pa_stable_v19_20071207.tar.gz 1113282
+RMD160 5185bd85bd4bc75dddb3fa56f172a346bdeea0c7 pa_stable_v19_20071207.tar.gz 1113282
+SHA256 06a17727d56d382a69036de2ed9aee9a15cac0329b995b8cfcd69b357f47bf2b pa_stable_v19_20071207.tar.gz 1113282
diff --git a/media-libs/portaudio/portaudio-19_pre20071207.ebuild b/media-libs/portaudio/portaudio-19_pre20071207.ebuild
new file mode 100644
index 000000000000..d124376418bb
--- /dev/null
+++ b/media-libs/portaudio/portaudio-19_pre20071207.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/portaudio/portaudio-19_pre20071207.ebuild,v 1.1 2008/01/12 18:16:56 aballier Exp $
+
+EAPI="1"
+
+MY_PN=pa_stable_v
+MY_PV=${PV/pre/}
+MY_P=${MY_PN}${MY_PV}
+
+DESCRIPTION="An open-source cross platform audio API."
+HOMEPAGE="http://www.portaudio.com"
+SRC_URI="http://www.portaudio.com/archives/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="18"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa +cxx debug oss"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # Jack is disabled, it seems to have runtime issues
+ # Moreover it fails to compile on some arches (like amd64)
+ # And this could cause cyclic dependencies with jack portaudio support
+ econf $(use_with alsa)\
+ --without-jack \
+ $(use_with oss)\
+ $(use_with debug debug-output)\
+ $(use_enable cxx) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install faied"
+ dodoc V19-devel-readme.txt
+ dohtml index.html
+}