summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-03-18 00:41:58 +0000
committerMarien Zwart <marienz@gentoo.org>2007-03-18 00:41:58 +0000
commit4ee229e6365077fbf1bf9af677860447d83f45bc (patch)
tree0e410e8c141e3df8f75cc4a2c57a0ae13b62c820
parentVersion bumped. (diff)
downloadgentoo-2-4ee229e6365077fbf1bf9af677860447d83f45bc.tar.gz
gentoo-2-4ee229e6365077fbf1bf9af677860447d83f45bc.tar.bz2
gentoo-2-4ee229e6365077fbf1bf9af677860447d83f45bc.zip
Skip the tests instead of ignoring their failure.
(Portage version: 2.1.2.2)
-rw-r--r--dev-python/pygtk/ChangeLog7
-rw-r--r--dev-python/pygtk/pygtk-2.10.3.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-2.10.4.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-2.6.1.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-2.6.2.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-2.8.6.ebuild9
6 files changed, 32 insertions, 12 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 36f073f4c4a9..c476b0f7136a 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.145 2007/02/16 10:08:17 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.146 2007/03/18 00:41:57 marienz Exp $
+
+ 18 Mar 2007; Marien Zwart <marienz@gentoo.org> pygtk-2.6.1.ebuild,
+ pygtk-2.6.2.ebuild, pygtk-2.8.6.ebuild, pygtk-2.10.3.ebuild,
+ pygtk-2.10.4.ebuild:
+ Skip the tests instead of ignoring their failure.
16 Feb 2007; Roy Marples <uberlord@gentoo.org> pygtk-2.10.4.ebuild:
Added ~x86-fbsd keyword.
diff --git a/dev-python/pygtk/pygtk-2.10.3.ebuild b/dev-python/pygtk/pygtk-2.10.3.ebuild
index c553e34bc9dc..3a9290e5d6a0 100644
--- a/dev-python/pygtk/pygtk-2.10.3.ebuild
+++ b/dev-python/pygtk/pygtk-2.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.10.3.ebuild,v 1.11 2007/01/20 02:39:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.10.3.ebuild,v 1.12 2007/03/18 00:41:57 marienz Exp $
inherit gnome.org python flag-o-matic
@@ -34,6 +34,9 @@ DEPEND="${RDEPEND}
doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
>=dev-util/pkgconfig-0.9"
+# Tests fail (missing display)
+RESTRICT="test"
+
src_unpack() {
unpack ${A}
if use doc; then
@@ -65,7 +68,7 @@ src_install() {
src_test() {
cd tests
- make check-local
+ make check-local || die "tests failed"
}
pkg_postinst() {
diff --git a/dev-python/pygtk/pygtk-2.10.4.ebuild b/dev-python/pygtk/pygtk-2.10.4.ebuild
index 8b330bf16995..3d9eb3fea47c 100644
--- a/dev-python/pygtk/pygtk-2.10.4.ebuild
+++ b/dev-python/pygtk/pygtk-2.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.10.4.ebuild,v 1.2 2007/02/16 10:08:17 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.10.4.ebuild,v 1.3 2007/03/18 00:41:58 marienz Exp $
NEED_PYTHON=2.3.5
@@ -35,6 +35,9 @@ DEPEND="${RDEPEND}
doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
>=dev-util/pkgconfig-0.9"
+# Tests fail (missing display)
+RESTRICT="test"
+
src_unpack() {
unpack ${A}
use doc || sed -e 's/\(SUBDIRS =.*\) docs$/\1/' -i "${S}"/Makefile.am
@@ -70,7 +73,7 @@ src_install() {
src_test() {
cd tests
- make check-local
+ make check-local || die "tests failed"
}
pkg_postinst() {
diff --git a/dev-python/pygtk/pygtk-2.6.1.ebuild b/dev-python/pygtk/pygtk-2.6.1.ebuild
index 563c96f73be3..4d3aaef1abf2 100644
--- a/dev-python/pygtk/pygtk-2.6.1.ebuild
+++ b/dev-python/pygtk/pygtk-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.1.ebuild,v 1.16 2007/01/06 12:32:19 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.1.ebuild,v 1.17 2007/03/18 00:41:57 marienz Exp $
inherit gnome.org python flag-o-matic
@@ -25,6 +25,9 @@ RDEPEND=">=dev-lang/python-2.3
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+# Tests fail (missing display)
+RESTRICT="test"
+
src_unpack() {
unpack ${A}
if use doc; then
@@ -62,7 +65,7 @@ src_install() {
src_test() {
cd tests
- make check-local
+ make check-local || die "tests failed"
}
pkg_postinst() {
diff --git a/dev-python/pygtk/pygtk-2.6.2.ebuild b/dev-python/pygtk/pygtk-2.6.2.ebuild
index 6eecad733da2..dae1ec9f0a8c 100644
--- a/dev-python/pygtk/pygtk-2.6.2.ebuild
+++ b/dev-python/pygtk/pygtk-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.2.ebuild,v 1.4 2007/01/06 12:32:19 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.6.2.ebuild,v 1.5 2007/03/18 00:41:57 marienz Exp $
inherit gnome.org python flag-o-matic
@@ -25,6 +25,9 @@ RDEPEND=">=dev-lang/python-2.3
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+# Tests fail (missing display)
+RESTRICT="test"
+
src_unpack() {
unpack ${A}
if use doc; then
@@ -62,7 +65,7 @@ src_install() {
src_test() {
cd tests
- make check-local
+ make check-local || die "tests failed"
}
pkg_postinst() {
diff --git a/dev-python/pygtk/pygtk-2.8.6.ebuild b/dev-python/pygtk/pygtk-2.8.6.ebuild
index 23ee4628c944..3385ccd811a6 100644
--- a/dev-python/pygtk/pygtk-2.8.6.ebuild
+++ b/dev-python/pygtk/pygtk-2.8.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.8.6.ebuild,v 1.13 2006/09/26 20:04:36 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.8.6.ebuild,v 1.14 2007/03/18 00:41:58 marienz Exp $
inherit gnome.org python flag-o-matic
@@ -28,6 +28,9 @@ RDEPEND=">=dev-lang/python-2.3.5
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+# Tests fail (missing display)
+RESTRICT="test"
+
src_unpack() {
unpack ${A}
if use doc; then
@@ -66,7 +69,7 @@ src_install() {
src_test() {
cd tests
- make check-local
+ make check-local || die "tests failed"
}
pkg_postinst() {