summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-03-04 14:44:59 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-03-04 14:44:59 +0000
commit4f2cb316be0bf3f1bd1104b5aea7f7c15c518f24 (patch)
tree315d18b79d4c48723ce6b33c8506e6b45aa85277
parentTrivial gcc-4.4 fix, bug 257643. Thanks to Mike Mullen <mike@e-junky.net>. (diff)
downloadgentoo-2-4f2cb316be0bf3f1bd1104b5aea7f7c15c518f24.tar.gz
gentoo-2-4f2cb316be0bf3f1bd1104b5aea7f7c15c518f24.tar.bz2
gentoo-2-4f2cb316be0bf3f1bd1104b5aea7f7c15c518f24.zip
Trivial gcc-4.4 fix, bug 257627. Thanks to Mike Mullen <mike@e-junky.net>.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--net-libs/libtorrent/ChangeLog6
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.4-gcc44.patch49
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.4.ebuild4
3 files changed, 57 insertions, 2 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 4d816a1da433..dcf85551fd08 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.135 2009/02/15 15:04:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.136 2009/03/04 14:44:59 loki_val Exp $
+
+ 04 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libtorrent-0.12.4-gcc44.patch, libtorrent-0.12.4.ebuild:
+ Trivial gcc-4.4 fix, bug 257627. Thanks to Mike Mullen <mike@e-junky.net>.
15 Feb 2009; Brent Baude <ranger@gentoo.org> libtorrent-0.12.4.ebuild:
Marking libtorrent-0.12.4 ppc for bug 255756
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.4-gcc44.patch b/net-libs/libtorrent/files/libtorrent-0.12.4-gcc44.patch
new file mode 100644
index 000000000000..150e1b1f7ab4
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.4-gcc44.patch
@@ -0,0 +1,49 @@
+diff -Nurp libtorrent-0.12.4.old/src/torrent/poll_epoll.cc libtorrent-0.12.4/src/torrent/poll_epoll.cc
+--- libtorrent-0.12.4.old/src/torrent/poll_epoll.cc 2008-10-28 06:49:47.000000000 -0500
++++ libtorrent-0.12.4/src/torrent/poll_epoll.cc 2009-02-04 09:45:22.000000000 -0600
+@@ -37,6 +37,7 @@
+ #include "config.h"
+
+ #include <cerrno>
++#include <cstdio>
+ #include <cstring>
+
+ #include <unistd.h>
+
+
+diff -Nurp libtorrent-0.12.4.old/src/protocol/extensions.cc libtorrent-0.12.4/src/protocol/extensions.cc
+--- libtorrent-0.12.4.old/src/protocol/extensions.cc 2008-08-26 15:15:15.000000000 -0500
++++ libtorrent-0.12.4/src/protocol/extensions.cc 2009-02-04 09:47:07.000000000 -0600
+@@ -36,6 +36,7 @@
+
+ #include "config.h"
+
++#include <cstdio>
+ #include <limits>
+ #include <sstream>
+
+diff -Nurp libtorrent-0.12.4.old/src/tracker/tracker_dht.cc libtorrent-0.12.4/src/tracker/tracker_dht.cc
+--- libtorrent-0.12.4.old/src/tracker/tracker_dht.cc 2008-08-26 15:18:34.000000000 -0500
++++ libtorrent-0.12.4/src/tracker/tracker_dht.cc 2009-02-04 09:48:49.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <sstream>
+
+ #include "dht/dht_router.h"
+
+diff -Nurp libtorrent-0.12.4.old/src/tracker/tracker_udp.cc libtorrent-0.12.4/src/tracker/tracker_udp.cc
+--- libtorrent-0.12.4.old/src/tracker/tracker_udp.cc 2008-05-07 07:19:13.000000000 -0500
++++ libtorrent-0.12.4/src/tracker/tracker_udp.cc 2009-02-04 09:49:24.000000000 -0600
+@@ -36,6 +36,8 @@
+
+ #include "config.h"
+
++#include <cstdio>
++
+ #include <sigc++/adaptors/bind.h>
+ #include <torrent/connection_manager.h>
+
diff --git a/net-libs/libtorrent/libtorrent-0.12.4.ebuild b/net-libs/libtorrent/libtorrent-0.12.4.ebuild
index a89364483821..779c0cc54c68 100644
--- a/net-libs/libtorrent/libtorrent-0.12.4.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.12.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.4.ebuild,v 1.4 2009/02/15 15:04:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.4.ebuild,v 1.5 2009/03/04 14:44:59 loki_val Exp $
inherit base eutils toolchain-funcs flag-o-matic libtool
@@ -17,6 +17,8 @@ RDEPEND=">=dev-libs/libsigc++-2.2.2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-gcc44.patch" )
+
src_unpack() {
base_src_unpack
cd "${S}"