summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-04-04 16:18:50 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-04-04 16:18:50 +0000
commit4f7f2547ae4763e9b920d9158df560a5dbe3393a (patch)
tree54e98bca7a98206be422a4984f1baaaa70cce8d5
parentDrop unnecessary usage of autotools-utils and add support for (diff)
downloadgentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.tar.gz
gentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.tar.bz2
gentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.zip
Security bump. Bug 463884.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
-rw-r--r--dev-db/postgresql-docs/ChangeLog13
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild (renamed from dev-db/postgresql-docs/postgresql-docs-8.3.23.ebuild)10
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.0.13.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.1.9.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.2.4.ebuild59
5 files changed, 175 insertions, 9 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 2ce2c356f67f..d50bdac864ee 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.198 2013/02/26 19:13:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.199 2013/04/04 16:18:50 titanofold Exp $
+
+*postgresql-docs-9.2.4 (04 Apr 2013)
+*postgresql-docs-9.1.9 (04 Apr 2013)
+*postgresql-docs-9.0.13 (04 Apr 2013)
+*postgresql-docs-8.4.17 (04 Apr 2013)
+
+ 04 Apr 2013; Aaron W. Swenson <titanofold@gentoo.org>
+ -postgresql-docs-8.3.23.ebuild, +postgresql-docs-8.4.17.ebuild,
+ +postgresql-docs-9.0.13.ebuild, +postgresql-docs-9.1.9.ebuild,
+ +postgresql-docs-9.2.4.ebuild:
+ Security bump. Bug 463884.
26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> -postgresql-docs-8.3.20.ebuild,
-postgresql-docs-8.3.21.ebuild, -postgresql-docs-8.3.22-r1.ebuild,
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.3.23.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild
index cd47bd07dfdb..4eb2452ccbb7 100644
--- a/dev-db/postgresql-docs/postgresql-docs-8.3.23.ebuild
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.3.23.ebuild,v 1.12 2013/02/26 18:50:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild,v 1.1 2013/04/04 16:18:49 titanofold Exp $
EAPI="4"
inherit versionator
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
RESTRICT="test"
@@ -37,18 +37,12 @@ src_install() {
dodir ${mypath}/html
tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
- insinto ${mypath}/FAQ_html
- doins src/FAQ/*
-
insinto ${mypath}/sgml
doins src/sgml/*.{sgml,dsl}
insinto ${mypath}/sgml/ref
doins src/sgml/ref/*.sgml
- insinto ${mypath}/TODO.detail
- doins TODO.detail/*
-
fowners root:0 -R ${mypath}
dodir /etc/eselect/postgresql/slots/${SLOT}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.0.13.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.0.13.ebuild
new file mode 100644
index 000000000000..741e1a352fef
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.0.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.0.13.ebuild,v 1.1 2013/04/04 16:18:50 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.1.9.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.1.9.ebuild
new file mode 100644
index 000000000000..102eb3454279
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.1.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.1.9.ebuild,v 1.1 2013/04/04 16:18:50 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+SLOT="$(get_version_component_range 1-2)"
+S="${WORKDIR}/postgresql-${PV}"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.2.4.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.2.4.ebuild
new file mode 100644
index 000000000000..b3626209f68c
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.2.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.2.4.ebuild,v 1.1 2013/04/04 16:18:50 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}