summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-01-04 16:02:12 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-01-04 16:02:12 +0000
commit5084df17be3ed775b753a1d8e35d53e13e21b835 (patch)
treebd65d6844944b2281b766c103744463818e78c6c
parentFixes for installations on systems without mono already installed. See bug #7... (diff)
downloadgentoo-2-5084df17be3ed775b753a1d8e35d53e13e21b835.tar.gz
gentoo-2-5084df17be3ed775b753a1d8e35d53e13e21b835.tar.bz2
gentoo-2-5084df17be3ed775b753a1d8e35d53e13e21b835.zip
Fixing bug #74976
-rw-r--r--sci-chemistry/ghemical/ChangeLog8
-rw-r--r--sci-chemistry/ghemical/files/gcc3.4.patch34
-rw-r--r--sci-chemistry/ghemical/ghemical-1.00.ebuild12
3 files changed, 50 insertions, 4 deletions
diff --git a/sci-chemistry/ghemical/ChangeLog b/sci-chemistry/ghemical/ChangeLog
index daaaf817535a..cf550530934a 100644
--- a/sci-chemistry/ghemical/ChangeLog
+++ b/sci-chemistry/ghemical/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ghemical
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.2 2004/12/24 20:13:11 swegener Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.3 2005/01/04 16:02:11 phosphan Exp $
+
+ 04 Jan 2005; Patrick Kursawe <phosphan@gentoo.org> +files/gcc3.4.patch,
+ ghemical-1.00.ebuild:
+ Gets through gcc 3.4.3 now - solving bug #74976.
*ghemical-1.00 (24 Dec 2004)
diff --git a/sci-chemistry/ghemical/files/gcc3.4.patch b/sci-chemistry/ghemical/files/gcc3.4.patch
new file mode 100644
index 000000000000..f147e44a92de
--- /dev/null
+++ b/sci-chemistry/ghemical/files/gcc3.4.patch
@@ -0,0 +1,34 @@
+diff -ru src-old/graphics/objects.h src/graphics/objects.h
+--- src-old/graphics/objects.h 2005-01-04 16:21:49.000000000 +0100
++++ src/graphics/objects.h 2005-01-04 12:26:57.000000000 +0100
+@@ -177,7 +177,7 @@
+ {
+ protected:
+
+- friend obj_loc_data * dummy_object::GetLocDataRW(void) const;
++ friend class dummy_object;
+
+ obj_loc_data * data;
+
+diff -ru src-old/target3/t3views.cpp src/target3/t3views.cpp
+--- src-old/target3/t3views.cpp 2002-10-23 11:01:09.000000000 +0200
++++ src/target3/t3views.cpp 2005-01-04 16:22:26.000000000 +0100
+@@ -7,6 +7,7 @@
+
+ /*################################################################################################*/
+
++#include <libintl.h>
+ #include "t3views.h"
+
+ #include "t3main.h"
+diff -ru src-old/target3/t3main.cpp src/target3/t3main.cpp
+--- src-old/target3/t3main.cpp 2002-11-20 16:49:39.000000000 +0100
++++ src/target3/t3main.cpp 2005-01-04 16:46:44.762693881 +0100
+@@ -7,6 +7,7 @@
+
+ /*################################################################################################*/
+
++#include <libintl.h>
+ #include "t3main.h"
+
+ #include "t3errutil.h"
diff --git a/sci-chemistry/ghemical/ghemical-1.00.ebuild b/sci-chemistry/ghemical/ghemical-1.00.ebuild
index b3fc2360bd06..8f6c3b92535d 100644
--- a/sci-chemistry/ghemical/ghemical-1.00.ebuild
+++ b/sci-chemistry/ghemical/ghemical-1.00.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-1.00.ebuild,v 1.2 2004/12/24 16:50:58 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-1.00.ebuild,v 1.3 2005/01/04 16:02:11 phosphan Exp $
+
+inherit eutils
DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
@@ -19,6 +21,12 @@ DEPEND="gnome-base/gnome-libs
dev-libs/libxml
=gnome-base/libglade-0*"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc3.4.patch
+}
+
src_compile() {
./configure --prefix=/usr --enable-mpqc ||die
emake ||die