summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-24 15:16:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-24 15:16:41 +0000
commit51986e71c9a5c45c82ac9177c513339e65103f07 (patch)
treebd23fdd2e7c3e53e8e06e36ff518c9346ba71e39
parentMarking gdm-2.20.9-r1 ppc64 for bug 244468 (diff)
downloadgentoo-2-51986e71c9a5c45c82ac9177c513339e65103f07.tar.gz
gentoo-2-51986e71c9a5c45c82ac9177c513339e65103f07.tar.bz2
gentoo-2-51986e71c9a5c45c82ac9177c513339e65103f07.zip
Version bump ( bug 250767 ), changing maintainer
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--media-video/griffith/ChangeLog10
-rw-r--r--media-video/griffith/griffith-0.9.9.ebuild70
-rw-r--r--media-video/griffith/metadata.xml3
3 files changed, 80 insertions, 3 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 279f63319947..8c23d032bb24 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/griffith
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.27 2008/08/16 12:28:33 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.28 2009/02/24 15:16:41 hwoarang Exp $
+
+*griffith-0.9.9 (24 Feb 2009)
+
+ 24 Feb 2009; Markos Chandras <hwoarang@gentoo.org> metadata.xml,
+ +griffith-0.9.9.ebuild:
+ Version bump ( bug #250767 ), changing maintainer
*griffith-9999 (16 Aug 2008)
*griffith-0.9.7.1 (16 Aug 2008)
diff --git a/media-video/griffith/griffith-0.9.9.ebuild b/media-video/griffith/griffith-0.9.9.ebuild
new file mode 100644
index 000000000000..babe50b7187f
--- /dev/null
+++ b/media-video/griffith/griffith-0.9.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.9.ebuild,v 1.1 2009/02/24 15:16:41 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="mirror://berlios/griffith/${P/_/-}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/reportlab-1.19
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+
+ epatch \
+ "${FILESDIR}/0.9.6-moving_share_dir.patch" \
+ "${FILESDIR}/0.9.7.1-fix_spellcheck.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ python_version
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/griffith/metadata.xml b/media-video/griffith/metadata.xml
index 8f2600fdf9ee..7379930134bd 100644
--- a/media-video/griffith/metadata.xml
+++ b/media-video/griffith/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<herd>video</herd>
<maintainer>
- <email>dev-zero@gentoo.org</email>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
</maintainer>
<use>
<flag name="csv">Enable proper support for csv import (respectively auto-detection encoding of csv files)</flag>