summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-07-14 11:43:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-07-14 11:43:28 +0000
commit51d4da32053ba9ff45eaeec8479d360f113a405c (patch)
treea35a155f4045eab9475cd16153d9deeb035f13b7
parentarm stable, bug #422189 (diff)
downloadgentoo-2-51d4da32053ba9ff45eaeec8479d360f113a405c.tar.gz
gentoo-2-51d4da32053ba9ff45eaeec8479d360f113a405c.tar.bz2
gentoo-2-51d4da32053ba9ff45eaeec8479d360f113a405c.zip
Version bump
(Portage version: 2.1.11.5/cvs/Linux x86_64)
-rw-r--r--x11-libs/libfm/ChangeLog8
-rw-r--r--x11-libs/libfm/libfm-1.0_rc1.ebuild69
2 files changed, 75 insertions, 2 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index 4a6309a7eda9..0101053c7ab5 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.67 2012/06/18 19:28:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.68 2012/07/14 11:43:28 hwoarang Exp $
+
+*libfm-1.0_rc1 (14 Jul 2012)
+
+ 14 Jul 2012; Markos Chandras <hwoarang@gentoo.org> +libfm-1.0_rc1.ebuild:
+ Version bump
18 Jun 2012; Markos Chandras <hwoarang@gentoo.org> libfm-0.1.17.ebuild:
Backport automake-1.12 fix from bug #421101
@@ -267,4 +272,3 @@
22 Feb 2010; Ben de Groot <yngwin@gentoo.org> +libfm-0.1.ebuild,
+metadata.xml:
Initial import. Ebuild by me.
-
diff --git a/x11-libs/libfm/libfm-1.0_rc1.ebuild b/x11-libs/libfm/libfm-1.0_rc1.ebuild
new file mode 100644
index 000000000000..8ae1053923a1
--- /dev/null
+++ b/x11-libs/libfm/libfm-1.0_rc1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-1.0_rc1.ebuild,v 1.1 2012/07/14 11:43:28 hwoarang Exp $
+
+EAPI=4
+
+inherit autotools fdo-mime
+
+MY_PV=${PV/_/}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug examples udev"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ udev? ( dev-libs/dbus-glib )
+ >=lxde-base/menu-cache-0.3.2"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ udev? ( sys-fs/udisks:0 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -i -e '/^[[:space:]]*docs/d' -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
+ configure.ac || die "sed failed"
+ #Remove -Werror for automake-1.12. Bug #421101
+ sed -i "s:-Werror::" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc" \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable udev udisks) \
+ $(use_enable examples demo) \
+ $(use_enable debug) \
+ # Documentation fails to build at the moment
+ # $(use_enable doc gtk-doc) \
+ # $(use_enable doc gtk-doc-html) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}