summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-23 16:34:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-23 16:34:53 +0000
commit546d497d0f68030b623bdaa871f743dbfc418a34 (patch)
tree67b2ce6f3ee7a09127430eb12fe9f0484c040fe5
parentRemoving old ebuilds (diff)
downloadgentoo-2-546d497d0f68030b623bdaa871f743dbfc418a34.tar.gz
gentoo-2-546d497d0f68030b623bdaa871f743dbfc418a34.tar.bz2
gentoo-2-546d497d0f68030b623bdaa871f743dbfc418a34.zip
any mod support will do; clean old
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--games-board/pokerth/ChangeLog7
-rw-r--r--games-board/pokerth/pokerth-0.9.4.ebuild81
-rw-r--r--games-board/pokerth/pokerth-0.9.5.ebuild4
3 files changed, 7 insertions, 85 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 38bec718012d..3c8b40a41b93 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.40 2012/08/21 19:44:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.41 2012/08/23 16:34:53 mr_bones_ Exp $
+
+ 23 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> -pokerth-0.9.4.ebuild,
+ pokerth-0.9.5.ebuild:
+ any mod support will do; clean old
21 Aug 2012; Julian Ospald <hasufell@gentoo.org> pokerth-0.9.5.ebuild,
+files/pokerth-0.9.5-underlinking.patch:
@@ -155,4 +159,3 @@
03 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+pokerth-0.6.3.ebuild:
initial commit (bug #169238)
-
diff --git a/games-board/pokerth/pokerth-0.9.4.ebuild b/games-board/pokerth/pokerth-0.9.4.ebuild
deleted file mode 100644
index 9eaf8ef178f2..000000000000
--- a/games-board/pokerth/pokerth-0.9.4.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.4.ebuild,v 1.4 2012/06/13 09:31:30 johu Exp $
-
-EAPI=2
-inherit flag-o-matic eutils qt4-r2 games
-
-MY_P="PokerTH-${PV}-src"
-DESCRIPTION="Texas Hold'em poker game"
-HOMEPAGE="http://www.pokerth.net/"
-SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
-
-LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dedicated"
-
-RDEPEND="dev-db/sqlite:3
- >=dev-libs/boost-1.44
- dev-libs/libgcrypt
- dev-libs/tinyxml[stl]
- net-libs/libircclient
- >=net-misc/curl-7.16
- x11-libs/qt-core:4
- virtual/gsasl
- !dedicated? (
- media-libs/libsdl
- media-libs/sdl-mixer[mikmod,vorbis]
- x11-libs/qt-gui:4
- )"
-DEPEND="${RDEPEND}
- !dedicated? ( x11-libs/qt-sql:4 )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- if use dedicated ; then
- sed -i \
- -e 's/pokerth_game.pro//' \
- pokerth.pro \
- || die "sed failed"
- fi
-
- sed -i \
- -e '/no_dead_strip_inits_and_terms/d' \
- *pro \
- || die 'sed failed'
-
- local boost_ver=$(best_version ">=dev-libs/boost-1.41")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cppflags \
- -I/usr/include/boost-${boost_ver} -DBOOST_FILESYSTEM_VERSION=2
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
-
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-}
-
-src_configure() {
- eqmake4
-}
-
-src_install() {
- dogamesbin bin/pokerth_server || die
- if ! use dedicated ; then
- dogamesbin ${PN} || die
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data || die
- domenu ${PN}.desktop
- doicon ${PN}.png
- fi
- doman docs/pokerth.1
- dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
- prepgamesdirs
-}
diff --git a/games-board/pokerth/pokerth-0.9.5.ebuild b/games-board/pokerth/pokerth-0.9.5.ebuild
index bfc23f64c3a7..32e42469c27d 100644
--- a/games-board/pokerth/pokerth-0.9.5.ebuild
+++ b/games-board/pokerth/pokerth-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.4 2012/08/21 19:44:10 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.5 2012/08/23 16:34:53 mr_bones_ Exp $
EAPI=2
inherit flag-o-matic eutils qt4-r2 games
@@ -25,7 +25,7 @@ RDEPEND="dev-db/sqlite:3
virtual/gsasl
!dedicated? (
media-libs/libsdl
- media-libs/sdl-mixer[mikmod,vorbis]
+ media-libs/sdl-mixer[mod,vorbis]
x11-libs/qt-gui:4
)"
DEPEND="${RDEPEND}