summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-26 22:27:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-26 22:27:41 +0000
commit551261a5a225afa8fb3bcd43e99b6e8f30168115 (patch)
treec481da7276be2b02af2c9a3699788cc78a8d3af5
parentVersion bump, closes bug #209986 (diff)
downloadgentoo-2-551261a5a225afa8fb3bcd43e99b6e8f30168115.tar.gz
gentoo-2-551261a5a225afa8fb3bcd43e99b6e8f30168115.tar.bz2
gentoo-2-551261a5a225afa8fb3bcd43e99b6e8f30168115.zip
ndebug patch from Guenther Brunthaler via bug #211322
(Portage version: 2.1.4.4)
-rw-r--r--games-arcade/supertux/ChangeLog8
-rw-r--r--games-arcade/supertux/files/supertux-0.1.3-ndebug.patch16
-rw-r--r--games-arcade/supertux/supertux-0.1.3.ebuild8
3 files changed, 27 insertions, 5 deletions
diff --git a/games-arcade/supertux/ChangeLog b/games-arcade/supertux/ChangeLog
index f5236f3319b0..4d7f6efe7140 100644
--- a/games-arcade/supertux/ChangeLog
+++ b/games-arcade/supertux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/supertux
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/ChangeLog,v 1.29 2007/04/09 21:40:03 welp Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/ChangeLog,v 1.30 2008/02/26 22:27:40 mr_bones_ Exp $
+
+ 26 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/supertux-0.1.3-ndebug.patch, supertux-0.1.3.ebuild:
+ ndebug patch from Guenther Brunthaler via bug #211322
09 Apr 2007; Peter Weller <welp@gentoo.org> supertux-0.1.3.ebuild:
Keyworded ~x86-fbsd wrt bug 173405
diff --git a/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch b/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch
new file mode 100644
index 000000000000..3a302d5ecf5a
--- /dev/null
+++ b/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch
@@ -0,0 +1,16 @@
+Index: supertux-0.1.3/src/tile.cpp
+===================================================================
+--- supertux-0.1.3.orig/src/tile.cpp
++++ supertux-0.1.3/src/tile.cpp
+@@ -99,7 +99,11 @@ void TileManager::load_tileset(std::stri
+ tile->anim_speed = 25;
+
+ LispReader reader(lisp_cdr(element));
++ #ifdef NDEBUG
++ void(reader.read_int("id", &tile->id));
++ #else
+ assert(reader.read_int("id", &tile->id));
++ #endif
+ reader.read_bool("solid", &tile->solid);
+ reader.read_bool("brick", &tile->brick);
+ reader.read_bool("ice", &tile->ice);
diff --git a/games-arcade/supertux/supertux-0.1.3.ebuild b/games-arcade/supertux/supertux-0.1.3.ebuild
index 9d48f9234e4f..ae4ee58dcf40 100644
--- a/games-arcade/supertux/supertux-0.1.3.ebuild
+++ b/games-arcade/supertux/supertux-0.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.3.ebuild,v 1.10 2007/04/09 21:40:03 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.3.ebuild,v 1.11 2008/02/26 22:27:40 mr_bones_ Exp $
GAMES_USE_SDL="nojoystick" #bug #100372
inherit eutils games
@@ -28,7 +28,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-ndebug.patch
}
src_compile() {