summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-14 05:55:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-14 05:55:51 +0000
commit55ade1fcd218c1deaf2ba18fadaee0b18fd0fd31 (patch)
treee699fc5258e2954148a2039d95842f7eb9294aa6
parentThe proper digest (diff)
downloadgentoo-2-55ade1fcd218c1deaf2ba18fadaee0b18fd0fd31.tar.gz
gentoo-2-55ade1fcd218c1deaf2ba18fadaee0b18fd0fd31.tar.bz2
gentoo-2-55ade1fcd218c1deaf2ba18fadaee0b18fd0fd31.zip
Version bump
-rw-r--r--x11-misc/xplanet/ChangeLog7
-rw-r--r--x11-misc/xplanet/files/digest-xplanet-1.0.01
-rw-r--r--x11-misc/xplanet/xplanet-1.0.0.ebuild76
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 9253e229e22c..50d63764be2f 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xplanet
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.7 2003/02/12 09:33:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.8 2003/03/14 05:55:51 seemant Exp $
+
+*xplanet-1.0.0 (13 Mar 2003)
+
+ 13 Mar 2003; Seemant Kulleen <seemant@gentoo.org> xplanet-1.0.0.ebuild:
+ version bump
*xplanet-0.94-r1 (23 Aug 2002)
diff --git a/x11-misc/xplanet/files/digest-xplanet-1.0.0 b/x11-misc/xplanet/files/digest-xplanet-1.0.0
new file mode 100644
index 000000000000..a49f121af236
--- /dev/null
+++ b/x11-misc/xplanet/files/digest-xplanet-1.0.0
@@ -0,0 +1 @@
+MD5 6bbbee73ebf0a996933e9d1551132cd5 xplanet-1.0.0.tar.gz 950383
diff --git a/x11-misc/xplanet/xplanet-1.0.0.ebuild b/x11-misc/xplanet/xplanet-1.0.0.ebuild
new file mode 100644
index 000000000000..9b438f4a6c7a
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-1.0.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.0.0.ebuild,v 1.1 2003/03/14 05:55:51 seemant Exp $
+
+IUSE="gif jpeg X opengl truetype tiff png"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A program to render images of the earth into the X root window"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://xplanet.sourceforge.net/"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl
+ media-libs/glut )
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ truetype? ( =media-libs/freetype-2* )"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+src_unpack() {
+ unpack ${A}
+ # fix GCC3.2 include re-ordering bug.
+ D=${S}/ dosed 's,-I$prefix/include,,' configure
+}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="$myconf --with-x" \
+ || myconf="$myconf --with-x=no"
+
+ use opengl \
+ && myconf="--with-gl --with-glut --with-animation" \
+ || myconf="--with-gl=no --with-glut=no --with-animation=no"
+
+ use gif \
+ && myconf="$myconf --with-gif" \
+ || myconf="$myconf --with-gif=no"
+
+ use jpeg \
+ && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use tiff \
+ && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use png \
+ && myconf="${myconf} --with-png --with-pnm" \
+ || myconf="${myconf} --with-png=no --with-pnm=no"
+
+# Compilation fails with freetype enabled, checking upstream
+# use truetype \
+# && myconf="${myconf} --with-freetype" \
+# || myconf="${myconf} --with-freetype=no"
+ myconf="${myconf} --with-freetype=no"
+
+ econf ${myconf} || die
+
+ # xplanet doesn't like to build parallel
+ make || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc README COPYING CREDITS FAQ INSTALL
+}