summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-05-09 20:28:26 +0000
committerSven Vermeulen <swift@gentoo.org>2014-05-09 20:28:26 +0000
commit57427a6c6a2f6decc5d0e4fc1ff507f941389484 (patch)
treea7e0d4c4951e7fc7213e645eec705785c7766e6b
parentversion bump (diff)
downloadgentoo-2-57427a6c6a2f6decc5d0e4fc1ff507f941389484.tar.gz
gentoo-2-57427a6c6a2f6decc5d0e4fc1ff507f941389484.tar.bz2
gentoo-2-57427a6c6a2f6decc5d0e4fc1ff507f941389484.zip
Bump to 2.3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index daf831002974..8c834b016ea7 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.63 2014/04/28 19:38:15 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.64 2014/05/09 20:28:26 swift Exp $
+
+*libsepol-2.3 (09 May 2014)
+
+ 09 May 2014; Sven Vermeulen <swift@gentoo.org> +libsepol-2.3.ebuild:
+ Bump for 2.3 release
*libsepol-2.3_rc1 (28 Apr 2014)
diff --git a/sys-libs/libsepol/libsepol-2.3.ebuild b/sys-libs/libsepol/libsepol-2.3.ebuild
new file mode 100644
index 000000000000..ffa948e9cb45
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.3.ebuild,v 1.1 2014/05/09 20:28:26 swift Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+MY_P="${P//_/-}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20140506/${MY_P}.tar.gz"
+# http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+# EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+# EPATCH_SUFFIX="patch" \
+# EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+# EPATCH_FORCE="yes" \
+# epatch
+
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}