summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-27 19:36:52 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-27 19:36:52 +0000
commit5f1db7dc8ab0a667aaca0c454aaec0a5b5b3367e (patch)
treeeecd953ec8731e424a899dd462aad4c1665c9c39
parentVersion bump, addition of support for eselect-whois. (diff)
downloadgentoo-2-5f1db7dc8ab0a667aaca0c454aaec0a5b5b3367e.tar.gz
gentoo-2-5f1db7dc8ab0a667aaca0c454aaec0a5b5b3367e.tar.bz2
gentoo-2-5f1db7dc8ab0a667aaca0c454aaec0a5b5b3367e.zip
Fixing segfault. Bug #151991 and removing ppc-macos keyword
(Portage version: 2.1.1)
-rw-r--r--media-libs/libsdl/ChangeLog9
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.116
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.11-r13
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.11-audioConv.patch11
-rw-r--r--media-libs/libsdl/libsdl-1.2.11-r1.ebuild168
-rw-r--r--media-libs/libsdl/libsdl-1.2.11.ebuild4
6 files changed, 195 insertions, 6 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 42501c0ad28d..96a3747f5802 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.117 2006/10/03 20:07:39 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.118 2006/10/27 19:36:52 tupone Exp $
+
+*libsdl-1.2.11-r1 (27 Oct 2006)
+
+ 27 Oct 2006; <tupone@gentoo.org> +files/libsdl-1.2.11-audioConv.patch,
+ libsdl-1.2.11.ebuild, +libsdl-1.2.11-r1.ebuild:
+ Fixing segfault. Bug #151991 by me.
+ Removing ppc-macos keyword: no modular-X there
03 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> libsdl-1.2.11.ebuild:
Stable on Alpha.
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.11 b/media-libs/libsdl/files/digest-libsdl-1.2.11
index 7c37b8fdf059..0c18548c73c0 100644
--- a/media-libs/libsdl/files/digest-libsdl-1.2.11
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.11
@@ -1,3 +1,3 @@
-MD5 418b42956b7cd103bfab1b9077ccc149 SDL-1.2.11.tar.gz 2796407
-RMD160 91dc8877224415a4ba59e1de57c31861e550d644 SDL-1.2.11.tar.gz 2796407
-SHA256 6985823287b224b57390b1c1b6cbc54cc9a7d7757fbf9934ed20754b4cd23730 SDL-1.2.11.tar.gz 2796407
+MD5 dbe82ff408bccfd6992b4cf162538595 SDL-1.2.11.tar.gz 2796143
+RMD160 1ea73d45dcecde9df8e4b5c18e7cbcaedb1e4c59 SDL-1.2.11.tar.gz 2796143
+SHA256 c3f0e9b016368601697495dcdaed010ab0ee4b541d0052910f829ce318d90a2b SDL-1.2.11.tar.gz 2796143
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.11-r1 b/media-libs/libsdl/files/digest-libsdl-1.2.11-r1
new file mode 100644
index 000000000000..0c18548c73c0
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.11-r1
@@ -0,0 +1,3 @@
+MD5 dbe82ff408bccfd6992b4cf162538595 SDL-1.2.11.tar.gz 2796143
+RMD160 1ea73d45dcecde9df8e4b5c18e7cbcaedb1e4c59 SDL-1.2.11.tar.gz 2796143
+SHA256 c3f0e9b016368601697495dcdaed010ab0ee4b541d0052910f829ce318d90a2b SDL-1.2.11.tar.gz 2796143
diff --git a/media-libs/libsdl/files/libsdl-1.2.11-audioConv.patch b/media-libs/libsdl/files/libsdl-1.2.11-audioConv.patch
new file mode 100644
index 000000000000..cf0c265fe1be
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.11-audioConv.patch
@@ -0,0 +1,11 @@
+--- src/audio/SDL_audio.c.old 2006-10-19 08:16:18.000000000 +0200
++++ src/audio/SDL_audio.c 2006-10-19 08:18:08.000000000 +0200
+@@ -591,7 +591,7 @@
+ return(-1);
+ }
+ if ( audio->convert.needed ) {
+- audio->convert.len = desired->size;
++ audio->convert.len = desired->size / audio->convert.len_ratio;
+ audio->convert.buf =(Uint8 *)SDL_AllocAudioMem(
+ audio->convert.len*audio->convert.len_mult);
+ if ( audio->convert.buf == NULL ) {
diff --git a/media-libs/libsdl/libsdl-1.2.11-r1.ebuild b/media-libs/libsdl/libsdl-1.2.11-r1.ebuild
new file mode 100644
index 000000000000..3b8b89577619
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.11-r1.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.11-r1.ebuild,v 1.1 2006/10/27 19:36:52 tupone Exp $
+
+inherit flag-o-matic toolchain-funcs eutils libtool
+
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org/"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# WARNING:
+# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
+# in USE and something breaks, you pick up the pieces. Be prepared for
+# bug reports to be marked INVALID.
+IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick noflagstrip"
+RESTRICT="mirror" #147253
+
+RDEPEND="!noaudio? ( >=media-libs/audiofile-0.1.9 )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( >=media-sound/esound-0.2.19 )
+ arts? ( kde-base/arts )
+ nas? (
+ media-libs/nas
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libX11
+ )
+ X? (
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libX11
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.19 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ aalib? ( media-libs/aalib )
+ libcaca? ( >=media-libs/libcaca-0.9-r1 )
+ opengl? ( virtual/opengl virtual/glu )"
+DEPEND="${RDEPEND}
+ nas? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ x86? ( >=dev-lang/nasm-0.98.39-r3 )"
+
+S=${WORKDIR}/SDL-${PV}
+
+pkg_setup() {
+ if use noaudio || use novideo || use nojoystick ; then
+ ewarn "Since you've chosen to turn off some of libsdl's functionality,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the no* flags in USE. You need to know what"
+ ewarn "you're doing to selectively turn off parts of libsdl."
+ epause 30
+ fi
+ if use noflagstrip ; then
+ ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the noflagstrip use flag in USE."
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-libcaca-new-api.patch #40224
+ epatch "${FILESDIR}"/${P}-sdl-config.patch
+ epatch "${FILESDIR}"/${P}-xinerama-head-0.patch #145917
+ epatch "${FILESDIR}"/${P}-no-inline-BlitRGBtoRGBPixelAlphaMMX3DNOW.patch #148186
+ # Fix segfault when auto converting stream #151991
+ epatch "${FILESDIR}"/${P}-audioConv.patch
+
+ # add yasm-compatible defines to nasm code (hopefully we
+ # can get this killed soonish)
+ local f
+ for f in "${S}"/src/hermes/*.asm ; do
+ cat <<-EOF >> "${f}"
+ %ifidn __YASM_OBJFMT__,elf
+ section ".note.GNU-stack" noalloc noexec nowrite progbits
+ %endif
+ EOF
+ done
+
+ # yasm does not understand -i
+ # bug #147201
+ sed -i \
+ -e 's:NASMFLAGS -i:NASMFLAGS -I:' \
+ configure.in \
+ || die "sed failed"
+
+ ./autogen.sh || die "autogen failed"
+ elibtoolize
+}
+
+src_compile() {
+ local myconf=
+ if [[ $(tc-arch) != "x86" ]] ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} $(use_enable x86 nasm)"
+ fi
+ use noflagstrip || strip-flags
+ use noaudio && myconf="${myconf} --disable-audio"
+ use novideo \
+ && myconf="${myconf} --disable-video" \
+ || myconf="${myconf} --enable-video-dummy"
+ use nojoystick && myconf="${myconf} --disable-joystick"
+
+ local directfbconf="--disable-video-directfb"
+ if use directfb ; then
+ # since DirectFB can link against SDL and trigger a
+ # dependency loop, only link against DirectFB if it
+ # isn't broken #61592
+ echo 'int main(){}' > directfb-test.c
+ $(tc-getCC) directfb-test.c -ldirectfb 2>/dev/null \
+ && directfbconf="--enable-video-directfb" \
+ || ewarn "Disabling DirectFB since libdirectfb.so is broken"
+ fi
+
+ myconf="${myconf} ${directfbconf}"
+
+ econf \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --enable-events \
+ --enable-cdrom \
+ --enable-threads \
+ --enable-timers \
+ --enable-endian \
+ --enable-file \
+ --enable-cpuinfo \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable esd) \
+ $(use_enable arts) \
+ $(use_enable nas) \
+ $(use_enable X video-x11) \
+ $(use_enable dga) \
+ $(use_enable xv video-x11-xv) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable dga video-dga) \
+ $(use_enable fbcon video-fbcon) \
+ $(use_enable ggi video-ggi) \
+ $(use_enable svga video-svga) \
+ $(use_enable aalib video-aalib) \
+ $(use_enable libcaca video-caca) \
+ $(use_enable opengl video-opengl) \
+ $(use_with X x) \
+ --disable-video-x11-xme \
+ ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc BUGS CREDITS README README-SDL.txt README.CVS TODO WhatsNew
+ dohtml -r ./
+}
diff --git a/media-libs/libsdl/libsdl-1.2.11.ebuild b/media-libs/libsdl/libsdl-1.2.11.ebuild
index 402dccd4fe15..b73343d26965 100644
--- a/media-libs/libsdl/libsdl-1.2.11.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.11.ebuild,v 1.19 2006/10/26 00:22:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.11.ebuild,v 1.20 2006/10/27 19:36:52 tupone Exp $
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -10,7 +10,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86 ~x86-fbsd"
# WARNING:
# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
# in USE and something breaks, you pick up the pieces. Be prepared for