summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-26 15:31:01 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-26 15:31:01 +0000
commit60edde5e3376299b673558fea99f7cef1b6acb76 (patch)
tree6005a77a8a64ea8b332a943adb2256870038aa46
parentDepend on virtual/ffmpeg instead of media-video/ffmpeg. (diff)
downloadgentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.tar.gz
gentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.tar.bz2
gentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.zip
Version Bump, mainly prepared by rei4dan, #345093
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
-rw-r--r--sci-chemistry/openbabel/ChangeLog8
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.3.0-test_lib_path.patch12
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.0.ebuild64
3 files changed, 83 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
index b08286db2497..20e59ba3d356 100644
--- a/sci-chemistry/openbabel/ChangeLog
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.46 2011/03/02 17:48:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.47 2011/03/26 15:31:01 jlec Exp $
+
+*openbabel-2.3.0 (26 Mar 2011)
+
+ 26 Mar 2011; Justin Lecher <jlec@gentoo.org> +openbabel-2.3.0.ebuild,
+ +files/openbabel-2.3.0-test_lib_path.patch:
+ Version Bump, mainly prepared by rei4dan, #345093
02 Mar 2011; Justin Lecher <jlec@gentoo.org> openbabel-2.2.3.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-chemistry/openbabel/files/openbabel-2.3.0-test_lib_path.patch b/sci-chemistry/openbabel/files/openbabel-2.3.0-test_lib_path.patch
new file mode 100644
index 000000000000..014da6bcd585
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-2.3.0-test_lib_path.patch
@@ -0,0 +1,12 @@
+diff -ru old/openbabel-2.3.0/test/CMakeLists.txt new/openbabel-2.3.0/test/CMakeLists.txt
+--- old/openbabel-2.3.0/test/CMakeLists.txt 2010-10-26 17:39:01.000000000 +0300
++++ new/openbabel-2.3.0/test/CMakeLists.txt 2010-11-14 18:13:32.000000000 +0200
+@@ -2,7 +2,7 @@
+ add_definitions(-DTESTDATADIR="\\"${CMAKE_SOURCE_DIR}/test/files/\\"")
+
+ # define FORMATDIR for location of format plugin binaries
+-add_definitions(-DFORMATDIR="\\"${openbabel_BINARY_DIR}/lib/\\"")
++add_definitions(-DFORMATDIR="\\"${openbabel_BINARY_DIR}/lib${LIB_SUFFIX}/\\"")
+
+ ###########################################################
+ # new tests using obtest.h
diff --git a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
new file mode 100644
index 000000000000..993f96ed4d41
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.3.0.ebuild,v 1.1 2011/03/26 15:31:01 jlec Exp $
+
+EAPI="3"
+
+WX_GTK_VER="2.8"
+
+inherit cmake-utils eutils wxwidgets
+
+DESCRIPTION="Interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc wxwidgets"
+
+RDEPEND="
+ dev-cpp/eigen:2
+ dev-libs/libxml2:2
+ !sci-chemistry/babel
+ sci-libs/inchi
+ sys-libs/zlib
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test_lib_path.patch
+}
+
+src_configure() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use wxwidgets BUILD_GUI)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dohtml doc/{*.html,*.png} || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/API/html
+ doins doc/API/html/* || die
+ fi
+ cmake-utils_src_install
+}
+
+src_test() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use wxwidgets BUILD_GUI)
+ $(cmake-utils_use_enable test TESTS)"
+
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}