summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-06-24 16:18:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-06-24 16:18:25 +0000
commit6314a1d9aa55066b921d3a651c6635b7f28a018b (patch)
treedf8264a1a29164217eb66eeb7a54941423c04a4c
parentNow fixing bug introduced during cosmetic change. I hate cosmetic changes... (diff)
downloadgentoo-2-6314a1d9aa55066b921d3a651c6635b7f28a018b.tar.gz
gentoo-2-6314a1d9aa55066b921d3a651c6635b7f28a018b.tar.bz2
gentoo-2-6314a1d9aa55066b921d3a651c6635b7f28a018b.zip
Build with gcc-4.7 Bug #423105
(Portage version: 2.1.11.1/cvs/Linux i686)
-rw-r--r--games-emulation/xmess/ChangeLog5
-rw-r--r--games-emulation/xmess/xmess-0.106.ebuild17
2 files changed, 17 insertions, 5 deletions
diff --git a/games-emulation/xmess/ChangeLog b/games-emulation/xmess/ChangeLog
index 2f80b217ba5c..581c04d01092 100644
--- a/games-emulation/xmess/ChangeLog
+++ b/games-emulation/xmess/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmess
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.67 2012/03/18 13:14:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/ChangeLog,v 1.68 2012/06/24 16:18:25 tupone Exp $
+
+ 24 Jun 2012; Tupone Alfredo <tupone@gentoo.org> xmess-0.106.ebuild:
+ Build with gcc-4.7 Bug #423105 by Diego Elio Pettenò
18 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> xmess-0.106.ebuild:
Remove USE="esd" because media-sound/esound isn't in tree anymore.
diff --git a/games-emulation/xmess/xmess-0.106.ebuild b/games-emulation/xmess/xmess-0.106.ebuild
index ed4e2b6662ea..584e6d23622c 100644
--- a/games-emulation/xmess/xmess-0.106.ebuild
+++ b/games-emulation/xmess/xmess-0.106.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.14 2012/03/18 13:14:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.15 2012/06/24 16:18:25 tupone Exp $
EAPI=2
inherit flag-o-matic toolchain-funcs eutils games
@@ -146,11 +146,17 @@ EOF
src_compile() {
local disp=0
if use sdl ; then
- emake -j1 DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ emake -j1 DISPLAY_METHOD=SDL \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (SDL)"
disp=1
fi
if use svga ; then
- emake -j1 DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ emake -j1 DISPLAY_METHOD=svgalib \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (svgalib)"
disp=1
fi
if use ggi ; then
@@ -159,7 +165,10 @@ src_compile() {
ewarn "GGI support is currently (${PV}) broken :("
fi
if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
- emake -j1 DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ emake -j1 DISPLAY_METHOD=x11 \
+ CC=$(tc-getCC) \
+ LD=$(tc-getCC) \
+ || die "emake failed (x11)"
fi
}