summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-09 02:14:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-09 02:14:05 +0000
commit6350de2e44217f4f927259e6529616cbbe48952a (patch)
treea5abe119afecd5302bed33db691e8643d2610f97
parentBump to 3.0.9, fixing various bugs. Remove old, broken versions. (diff)
downloadgentoo-2-6350de2e44217f4f927259e6529616cbbe48952a.tar.gz
gentoo-2-6350de2e44217f4f927259e6529616cbbe48952a.tar.bz2
gentoo-2-6350de2e44217f4f927259e6529616cbbe48952a.zip
Version bump.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-rc6-00007-ged31348 x86_64)
-rw-r--r--app-shells/localshell/ChangeLog10
-rw-r--r--app-shells/localshell/localshell-1.3.1.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/app-shells/localshell/ChangeLog b/app-shells/localshell/ChangeLog
index bb420fa009b6..8fa04df701ba 100644
--- a/app-shells/localshell/ChangeLog
+++ b/app-shells/localshell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/localshell
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.8 2008/12/13 23:58:49 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.9 2009/01/09 02:14:05 robbat2 Exp $
+
+*localshell-1.3.1 (09 Jan 2009)
+
+ 09 Jan 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +localshell-1.3.1.ebuild:
+ Version bump.
13 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+files/localshell-1.2+gcc-4.3.patch, localshell-1.2.ebuild:
diff --git a/app-shells/localshell/localshell-1.3.1.ebuild b/app-shells/localshell/localshell-1.3.1.ebuild
new file mode 100644
index 000000000000..25d1edf21c87
--- /dev/null
+++ b/app-shells/localshell/localshell-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.3.1.ebuild,v 1.1 2009/01/09 02:14:05 robbat2 Exp $
+
+inherit base
+
+DESCRIPTION="Localshell allows per-user/group local control of shell execution."
+HOMEPAGE="http://oss.orbis-terrarum.net/localshell/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+#RDEPEND=""
+
+src_compile() {
+ # this is a shell, it needs to be in /bin
+ econf --bindir=/bin --sysconfdir=/etc || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}
+
+pkg_postinst() {
+ elog "Remember to add /bin/localshell to /etc/shells and create"
+ elog "/etc/localshell.conf based on the included configuration examples"
+}