summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-29 00:35:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-29 00:35:11 +0000
commit639d884e402e7c1888f9b5208abb3f63a12b737e (patch)
tree05581d777153cd8c2024c0bc25fc91e27544bbf1
parentchange cdinstall to nocd (diff)
downloadgentoo-2-639d884e402e7c1888f9b5208abb3f63a12b737e.tar.gz
gentoo-2-639d884e402e7c1888f9b5208abb3f63a12b737e.tar.bz2
gentoo-2-639d884e402e7c1888f9b5208abb3f63a12b737e.zip
change USE=cdinstall to USE=nocd
(Portage version: 2.0.51.22-r1)
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild23
-rw-r--r--games-fps/doom3/doom3-1.1.1286.ebuild14
-rw-r--r--games-fps/doom3/doom3-1.3.1302.ebuild14
3 files changed, 26 insertions, 25 deletions
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
index e4d7d05832df..f3a76fa789e5 100644
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.6 2005/01/09 10:48:13 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.7 2005/06/29 00:32:25 vapier Exp $
inherit flag-o-matic eutils games
@@ -8,16 +8,16 @@ DATAFILE="d2shar10"
DESCRIPTION="Descent 2"
HOMEPAGE="http://icculus.org/d2x/"
SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
- !cdinstall? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
+ !nocd? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="cdinstall debug opengl ggi svga"
+KEYWORDS="ppc x86"
+IUSE="nocd debug opengl ggi svga"
RDEPEND="media-libs/libsdl
media-libs/sdl-image
- cdinstall? ( app-arch/unarj )
+ nocd? ( app-arch/unarj )
opengl? ( virtual/opengl )
ggi? ( media-libs/libggi )
svga? ( media-libs/svgalib )"
@@ -25,9 +25,11 @@ DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
pkg_setup() {
- if use cdinstall ; then
- if ! [ -e ${DISTDIR}/descent2.sow ] ; then
- cdrom_get_cds d2data
+ games_pkg_setup
+
+ if use nocd ; then
+ if [[ ! -e ${DISTDIR}/descent2.sow ]] ; then
+ cdrom_get_cds d2data
if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
export CDROM_ROOT=${CDROM_ROOT}/d2data
einfo "Found the original Descent2 CD"
@@ -38,12 +40,11 @@ pkg_setup() {
fi
fi
fi
- games_pkg_setup
}
src_unpack() {
unpack ${A}
- if use cdinstall ; then
+ if use nocd ; then
cd ${WORKDIR}
mkdir SOW
cd SOW
@@ -88,7 +89,7 @@ src_install() {
make install DESTDIR=${D} || die
dogamesbin my-bins/*
dodir ${GAMES_DATADIR}/${PN}
- if use cdinstall ; then
+ if use nocd ; then
cp -r ${WORKDIR}/SOW/* ${D}/${GAMES_DATADIR}/${PN}/
else
cp -r ${WORKDIR}/${DATAFILE}/* ${D}/${GAMES_DATADIR}/${PN}/
diff --git a/games-fps/doom3/doom3-1.1.1286.ebuild b/games-fps/doom3/doom3-1.1.1286.ebuild
index d9e0b5d2df39..1381d4551bd0 100644
--- a/games-fps/doom3/doom3-1.1.1286.ebuild
+++ b/games-fps/doom3/doom3-1.1.1286.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1286.ebuild,v 1.3 2005/04/18 15:20:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.1.1286.ebuild,v 1.4 2005/06/29 00:35:11 vapier Exp $
inherit eutils games
@@ -13,12 +13,12 @@ SRC_URI="mirror://3dgamers/3dgamers/games/${PN}/${PN}-linux-${PV}.x86.run
LICENSE="DOOM3"
SLOT="0"
KEYWORDS="-* x86 amd64"
-IUSE="cdinstall alsa opengl dedicated"
+IUSE="nocd alsa opengl dedicated"
RESTRICT="nostrip"
DEPEND="app-arch/bzip2
app-arch/tar"
-RDEPEND="virtual/libc
+RDEPEND="sys-libs/glibc
opengl? ( virtual/opengl )
dedicated? ( app-misc/screen )
alsa? ( >=media-libs/alsa-lib-1.0.6 )"
@@ -30,7 +30,7 @@ Ddir=${D}/${dir}
pkg_setup() {
check_license
- use cdinstall && cdrom_get_cds Setup/Data/base/pak002.pk4 \
+ use nocd && cdrom_get_cds Setup/Data/base/pak002.pk4 \
Setup/Data/base/pak000.pk4 \
Setup/Data/base/pak003.pk4
games_pkg_setup
@@ -58,7 +58,7 @@ src_install() {
insinto ${dir}/base
doins base/* || die "doins base"
- if use cdinstall; then
+ if use nocd; then
einfo "Copying files from Disk 1..."
doins ${CDROM_ROOT}/Setup/Data/base/pak002.pk4 \
|| die "copying pak002"
@@ -75,7 +75,7 @@ src_install() {
games_make_wrapper doom3 ./doom.x86 ${dir}
games_make_wrapper doom3-ded ./doomded.x86 ${dir}
- use cdinstall && find ${Ddir} -exec touch '{}' \;
+ use nocd && find ${Ddir} -exec touch '{}' \;
insinto /usr/share/pixmaps
doins doom3.png
@@ -87,7 +87,7 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- if use cdinstall; then
+ if use nocd; then
einfo "To play the game run:"
einfo " doom3"
else
diff --git a/games-fps/doom3/doom3-1.3.1302.ebuild b/games-fps/doom3/doom3-1.3.1302.ebuild
index 338eb3635daf..26925eeec064 100644
--- a/games-fps/doom3/doom3-1.3.1302.ebuild
+++ b/games-fps/doom3/doom3-1.3.1302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.3.1302.ebuild,v 1.5 2005/05/27 15:51:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.3.1302.ebuild,v 1.6 2005/06/29 00:35:11 vapier Exp $
inherit eutils games
@@ -14,12 +14,12 @@ SRC_URI="mirror://3dgamers/3dgamers/games/${PN}/${PN}-linux-${PV}.x86.run
LICENSE="DOOM3"
SLOT="0"
KEYWORDS="-* ~x86 ~amd64"
-IUSE="cdinstall alsa opengl dedicated"
+IUSE="nocd alsa opengl dedicated"
RESTRICT="nostrip"
DEPEND="app-arch/bzip2
app-arch/tar"
-RDEPEND="virtual/libc
+RDEPEND="sys-libs/glibc
opengl? ( virtual/opengl )
dedicated? ( app-misc/screen )
alsa? ( >=media-libs/alsa-lib-1.0.6 )"
@@ -31,7 +31,7 @@ Ddir=${D}/${dir}
pkg_setup() {
check_license
- use cdinstall && cdrom_get_cds Setup/Data/base/pak002.pk4 \
+ use nocd && cdrom_get_cds Setup/Data/base/pak002.pk4 \
Setup/Data/base/pak000.pk4 \
Setup/Data/base/pak003.pk4
games_pkg_setup
@@ -63,7 +63,7 @@ src_install() {
doins d3xp/* || die "doins d3xp"
insinto ${dir}/base
doins base/* || die "doins base"
- if use cdinstall; then
+ if use nocd; then
einfo "Copying files from Disk 1..."
doins ${CDROM_ROOT}/Setup/Data/base/pak002.pk4 \
|| die "copying pak002"
@@ -80,7 +80,7 @@ src_install() {
games_make_wrapper doom3 ./doom.x86 ${dir}
games_make_wrapper doom3-ded ./doomded.x86 ${dir}
- use cdinstall && find ${Ddir} -exec touch '{}' \;
+ use nocd && find ${Ddir} -exec touch '{}' \;
doicon ${DISTDIR}/doom3.png || die "Copying icon"
@@ -91,7 +91,7 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- if use cdinstall; then
+ if use nocd; then
einfo "To play the game run:"
einfo " doom3"
else