summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-02 22:18:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-02 22:18:16 +0000
commit653182515b8a1e2748efc19c1eb58b37b0b62cf6 (patch)
tree20dd1d795c710a25c00e37cd34a65e64d9839aed
parentVersion bump. (diff)
downloadgentoo-2-653182515b8a1e2748efc19c1eb58b37b0b62cf6.tar.gz
gentoo-2-653182515b8a1e2748efc19c1eb58b37b0b62cf6.tar.bz2
gentoo-2-653182515b8a1e2748efc19c1eb58b37b0b62cf6.zip
Version bump.
(Portage version: 2.2.0_alpha30_p39/cvs/Linux x86_64)
-rw-r--r--dev-python/pyinotify/ChangeLog8
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.2.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pyinotify/ChangeLog b/dev-python/pyinotify/ChangeLog
index 4ca0908d7e85..44471a43a41f 100644
--- a/dev-python/pyinotify/ChangeLog
+++ b/dev-python/pyinotify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyinotify
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.37 2011/02/12 18:36:10 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.38 2011/05/02 22:18:16 arfrever Exp $
+
+*pyinotify-0.9.2 (02 May 2011)
+
+ 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyinotify-0.9.2.ebuild:
+ Version bump.
12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-pyinotify-0.9.0.ebuild:
diff --git a/dev-python/pyinotify/pyinotify-0.9.2.ebuild b/dev-python/pyinotify/pyinotify-0.9.2.ebuild
new file mode 100644
index 000000000000..74b0ad5a13c8
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.2.ebuild,v 1.1 2011/05/02 22:18:16 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 *-jython"
+
+inherit distutils
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="http://trac.dbzteam.org/pyinotify http://pypi.python.org/pypi/pyinotify"
+SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+PYTHON_MODNAME="pyinotify.py"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins python2/examples/* || die "Installation of examples failed"
+ fi
+}