summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2004-02-07 21:51:31 +0000
committerBrian Harring <ferringb@gentoo.org>2004-02-07 21:51:31 +0000
commit65e81ecb1e19dbc91d38b72edc226adc34f1e7ea (patch)
tree62a9d50b47da1fc5835f7c12fdd5af9894732045
parentFix empty VERSION and PACKAGE, bug #39576. (Manifest recommit) (diff)
downloadgentoo-2-65e81ecb1e19dbc91d38b72edc226adc34f1e7ea.tar.gz
gentoo-2-65e81ecb1e19dbc91d38b72edc226adc34f1e7ea.tar.bz2
gentoo-2-65e81ecb1e19dbc91d38b72edc226adc34f1e7ea.zip
closing out bug 39134, jack-audio-connection-kit causing pd-0.37 to bork in compilation. pd seems to be a rather cranky package... adding metadata.xml also.
-rw-r--r--media-sound/pd/ChangeLog10
-rw-r--r--media-sound/pd/Manifest5
-rw-r--r--media-sound/pd/files/pd-0.37.0-jack-fix.patch23
-rw-r--r--media-sound/pd/metadata.xml5
-rw-r--r--media-sound/pd/pd-0.37.0.ebuild12
5 files changed, 43 insertions, 12 deletions
diff --git a/media-sound/pd/ChangeLog b/media-sound/pd/ChangeLog
index e457134fa6e6..39e1f931aa6e 100644
--- a/media-sound/pd/ChangeLog
+++ b/media-sound/pd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pd
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/ChangeLog,v 1.7 2003/10/28 13:47:31 mholzer Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/ChangeLog,v 1.8 2004/02/07 21:51:31 ferringb Exp $
+
+ 07 Feb 2004; Brian Harring <ferringb@gentoo.org> metadata.xml,
+ pd-0.37.0.ebuild, files/pd-0.37.0-jack-fix.patch:
+ Added a fix for when jack-audio-connection-kit is installed on the system.
+ Need to add a configure option to control enabling/disabling jack. closes
+ #39134
*pd-0.37.0 (28 Oct 2003)
diff --git a/media-sound/pd/Manifest b/media-sound/pd/Manifest
index e9eab2e52ed6..549bf07374f8 100644
--- a/media-sound/pd/Manifest
+++ b/media-sound/pd/Manifest
@@ -1,8 +1,9 @@
MD5 0e520002b0038f134139f878df2d0c34 ChangeLog 1556
-MD5 3c2b697b45b4373689e5faf36ec70902 pd-0.37.0.ebuild 1091
MD5 70793c37e08c5cd232f432065d82a5b9 pd-0.35.0-r2.ebuild 1084
MD5 90f6f8100e0e515c82e89b54066ad40d pd-0.36.0.ebuild 1085
-MD5 5c8ff0fb8e8866f73fbb9cf3684131c2 files/digest-pd-0.37.0 66
+MD5 e9e29ca7e10557a4007a81af2b328af0 pd-0.37.0.ebuild 1100
MD5 b0c34eb92c54e626140ccfb8181a39c0 files/digest-pd-0.35.0-r2 68
MD5 8970298c2a2da83cb5d18dc858168e63 files/digest-pd-0.36.0 68
+MD5 5c8ff0fb8e8866f73fbb9cf3684131c2 files/digest-pd-0.37.0 66
MD5 ad45c004132cff28b26df08ed85a8dbb files/pd-0.35.0-r2.patch 3689
+MD5 76bf00a8a6cb89d34a3786f5bfe766cd files/pd-0.37-jack-fix.patch 721
diff --git a/media-sound/pd/files/pd-0.37.0-jack-fix.patch b/media-sound/pd/files/pd-0.37.0-jack-fix.patch
new file mode 100644
index 000000000000..18cd2385bbf8
--- /dev/null
+++ b/media-sound/pd/files/pd-0.37.0-jack-fix.patch
@@ -0,0 +1,23 @@
+diff -urN pd-0.37-0/src/s_audio_jack.c pd-0.37-0-fixed/src/s_audio_jack.c
+--- pd-0.37-0/src/s_audio_jack.c 2003-08-19 14:13:03.000000000 -0500
++++ pd-0.37-0-fixed/src/s_audio_jack.c 2004-02-03 08:14:56.000000000 -0600
+@@ -67,9 +67,8 @@
+ }
+
+ static int
+-srate (jack_nframes_t srate, void *arg)
++jack_srate (jack_nframes_t srate, void *arg)
+ {
+- printf ("jack: sample rate %ld/sec\n", srate);
+ sys_dacsr = srate;
+ return 0;
+ }
+@@ -248,7 +247,7 @@
+ the sample rate of the system changes.
+ */
+
+- jack_set_sample_rate_callback (jack_client, srate, 0);
++ jack_set_sample_rate_callback (jack_client, jack_srate, 0);
+
+
+ /* tell the JACK server to call `jack_shutdown()' if
diff --git a/media-sound/pd/metadata.xml b/media-sound/pd/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/pd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/pd/pd-0.37.0.ebuild b/media-sound/pd/pd-0.37.0.ebuild
index d059d9297efa..671dfa8180f4 100644
--- a/media-sound/pd/pd-0.37.0.ebuild
+++ b/media-sound/pd/pd-0.37.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.37.0.ebuild,v 1.1 2003/10/28 13:47:31 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.37.0.ebuild,v 1.2 2004/02/07 21:51:31 ferringb Exp $
# Miller Puckette uses nonstandard versioning scheme that we have to crunch
MY_P=`echo ${P} | sed 's/\.\([0-9]\+\)$/-\1/'`
@@ -22,12 +22,8 @@ DEPEND=">=dev-lang/tcl-8.3.3
src_unpack() {
unpack ${A}
-
-# cd ${S} || die
-# epatch ${FILESDIR}/${PF}.patch
-
-# cd src || die
-# autoconf || die
+ cd ${S}
+ epatch ${FILESDIR}/${P}-jack-fix.patch || die "Jack-audio-connection-kit fix failed"
}
src_compile() {