summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:25:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 13:25:08 +0000
commit66d8775b203a39000bc2da019e6ce6be2e487b87 (patch)
tree2e5b126493438afd9293524f0b6bde0f51fffa40
parentheader fix (Manifest recommit) (diff)
downloadgentoo-2-66d8775b203a39000bc2da019e6ce6be2e487b87.tar.gz
gentoo-2-66d8775b203a39000bc2da019e6ce6be2e487b87.tar.bz2
gentoo-2-66d8775b203a39000bc2da019e6ce6be2e487b87.zip
add cvs version of configure which doesn't check for gnome since that isn't supported anymore. Should address bug #44686; removed gnome USE support; use emake
-rw-r--r--games-roguelike/crossfire-client/ChangeLog8
-rw-r--r--games-roguelike/crossfire-client/Manifest6
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild35
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.11
4 files changed, 33 insertions, 17 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index c72ef6407a56..c055170be3ea 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,5 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+
+ 20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ crossfire-client-1.6.1.ebuild:
+ add cvs version of configure which doesn't check for gnome since that isn't
+ supported anymore. Should address bug #44686; removed gnome USE support; use
+ emake
*crossfire-client-1.6.1 (01 Feb 2004)
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
index 8db8ecb809fb..f4c6c717e99e 100644
--- a/games-roguelike/crossfire-client/Manifest
+++ b/games-roguelike/crossfire-client/Manifest
@@ -1,10 +1,10 @@
MD5 2b3e87d11b8f53c39be7e4d1bab2b143 ChangeLog 1291
MD5 f4546af23d4d20115f48a435cf2acdce crossfire-client-1.5.0.ebuild 1450
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 c19314c6cfa4704def33b434d4c8f10b crossfire-client-1.6.0.ebuild 1466
-MD5 6bafa5121d66fc97a7a8ea5d3943d08a crossfire-client-1.6.1.ebuild 1389
+MD5 bd42cc37d009612f5e581832aa98d0af crossfire-client-1.6.1.ebuild 1467
MD5 ad1e49c4a56222488166b9c4f4091a55 files/1.5.0-errno.patch 682
MD5 d8e0b6aeda4e4938606822e33edf7322 files/digest-crossfire-client-1.5.0 74
MD5 ad1e49c4a56222488166b9c4f4091a55 files/1.6.0-errno.patch 682
MD5 76ba2e058af4f5a870fb752796c99203 files/digest-crossfire-client-1.6.0 74
-MD5 19649d121e2b04fae3ebbec5abe17e28 files/digest-crossfire-client-1.6.1 74
+MD5 28ec33590a7f24478841e039ce87f81c files/digest-crossfire-client-1.6.1 153
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
index 0cf8b5a507f6..592b598772af 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild
@@ -1,26 +1,36 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild,v 1.2 2004/02/20 06:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.1.ebuild,v 1.3 2004/03/20 13:25:08 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="Client for the nethack-style but more in the line of UO"
HOMEPAGE="http://crossfire.real-time.com/"
-SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz
+ mirror://gentoo/${P}.configure.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE="sdl gnome gtk alsa"
+IUSE="sdl gtk alsa"
DEPEND="virtual/x11
sdl? ( media-libs/libsdl
media-libs/sdl-image )
- gnome? ( gnome-base/gnome-libs
- media-libs/gdk-pixbuf )
- gtk? ( =x11-libs/gtk+-1* )
+ gtk? ( =x11-libs/gtk+-1.2*
+ dev-libs/glib
+ )
alsa? ( media-libs/alsa-lib )
- media-libs/libpng"
+ media-libs/libpng
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack ${P}.configure.gz
+ mv ${P}.configure configure
+ chmod a+x configure
+}
src_compile() {
# bugs in configure script so we cant use `use_enable`
@@ -28,16 +38,15 @@ src_compile() {
use gtk || myconf="${myconf} --disable-gtk"
use sdl || myconf="${myconf} --disable-sdl"
use alsa || myconf="${myconf} --disable-alsa"
- has_version '>=media-libs/alsa-lib-0.9' && myconf="${myconf} --disable-alsa --disable-sound"
-# use gnome || myconf="${myconf} --disable-gnome"
+ has_version '>=media-libs/alsa-lib-0.9' \
+ && myconf="${myconf} --disable-alsa --disable-sound"
egamesconf ${myconf} || die
- make || die
+ emake || die "emake failed"
}
src_install() {
- egamesinstall mandir=${T} || die
+ egamesinstall mandir="${T}" || die
use gtk && newman gtk/gcfclient.man gcfclient.6
- use gnome && newman gnome/gnome-cfclient.man gnome-cfclient.6
newman x11/cfclient.man cfclient.6
dodoc CHANGES NOTES README TODO
prepgamesdirs
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1
index 6e4c68cc48f8..77a766079ea5 100644
--- a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.1
@@ -1 +1,2 @@
MD5 609a44e079803bc48c966b1766a02863 crossfire-client-1.6.1.tar.gz 512603
+MD5 eace4167725f0aeed77190e0efcd5ee0 crossfire-client-1.6.1.configure.gz 53151