summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-14 10:05:52 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-14 10:05:52 +0000
commit670d93060332c6bf21cf8f28271d14cb2952a0f4 (patch)
tree6557d84a6b9757cf869dd577a5b7f6b2d14cea3c
parentVersion bumped. (diff)
downloadgentoo-2-670d93060332c6bf21cf8f28271d14cb2952a0f4.tar.gz
gentoo-2-670d93060332c6bf21cf8f28271d14cb2952a0f4.tar.bz2
gentoo-2-670d93060332c6bf21cf8f28271d14cb2952a0f4.zip
Version bump (#271453).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--net-analyzer/ntop/ChangeLog9
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch122
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch58
-rw-r--r--net-analyzer/ntop/ntop-3.3.10.ebuild121
4 files changed, 309 insertions, 1 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index ed8d2a9c0cf1..1972031776ba 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.79 2009/05/09 09:31:02 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.80 2009/06/14 10:05:51 mrness Exp $
+
+*ntop-3.3.10 (14 Jun 2009)
+
+ 14 Jun 2009; Alin Năstac <mrness@gentoo.org>
+ +files/ntop-3.3.10-external-geoip.patch, +files/ntop-3.3.10-gentoo.patch,
+ +ntop-3.3.10.ebuild:
+ Version bump (#271453).
09 May 2009; Alin Năstac <mrness@gentoo.org> metadata.xml,
ntop-3.3.9-r2.ebuild:
diff --git a/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch b/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch
new file mode 100644
index 000000000000..c8ad557a10b6
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.10-external-geoip.patch
@@ -0,0 +1,122 @@
+diff -Nru ntop-3.3.10.orig/configure.in ntop-3.3.10/configure.in
+--- ntop-3.3.10.orig/configure.in 2009-06-14 09:49:59.000000000 +0000
++++ ntop-3.3.10/configure.in 2009-06-14 10:01:27.000000000 +0000
+@@ -1959,39 +1959,7 @@
+ fi
+
+ dnl> GeoIP (http://www.maxmind.com/)
+-if test -f "GeoIP.tar.gz"; then
+- echo "GeoIP already present on this machine"
+-else
+- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
+-fi
+-tar xvfz GeoIP.tar.gz
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-cd $GEO_DIR; ./configure --prefix=${prefix}; make; cd ..
+-# OSX Fix
+-GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+-if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
+-fi
+-
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+-if test -f "GeoIPASNum.dat"; then
+- echo "GeoIPASNum.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
+- gunzip GeoIPASNum.dat.gz
+-fi
+-
+-
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-GEO_IP="$GEO_DIR/libGeoIP/"
+-CFLAGS="$CFLAGS -I$GEO_IP"
+-LDFLAGS="-L$GEO_IP.libs/ -lGeoIP $LDFLAGS"
++LDFLAGS="$LDFLAGS -lGeoIP"
+
+ dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
+
+@@ -2157,7 +2125,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+ AC_SUBST(GETOPT_H)
+ AC_SUBST(GETOPT_C)
+
+diff -Nru ntop-3.3.10.orig/globals-core.c ntop-3.3.10/globals-core.c
+--- ntop-3.3.10.orig/globals-core.c 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/globals-core.c 2009-06-14 11:50:53.000000000 +0000
+@@ -503,19 +503,18 @@
+ struct stat statbuf;
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+ }
+@@ -525,19 +524,18 @@
+
+ /* *************************** */
+
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+ }
+diff -Nru ntop-3.3.10.orig/Makefile.am ntop-3.3.10/Makefile.am
+--- ntop-3.3.10.orig/Makefile.am 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/Makefile.am 2009-06-14 09:50:14.000000000 +0000
+@@ -76,9 +76,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -270,8 +268,6 @@
+
+ install: install-recursive
+
+- cd @GEO_DIR@; make install
+-
+ @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
+
+ @echo ""
diff --git a/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch
new file mode 100644
index 000000000000..a4fe7ab3f732
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.10-gentoo.patch
@@ -0,0 +1,58 @@
+diff -Nru ntop-3.3.10.orig/Makefile.am ntop-3.3.10/Makefile.am
+--- ntop-3.3.10.orig/Makefile.am 2009-06-14 10:05:37.000000000 +0000
++++ ntop-3.3.10/Makefile.am 2009-06-14 10:13:28.000000000 +0000
+@@ -45,7 +45,6 @@
+
+ #AM_CFLAGS =
+ #AM_LDFLAGS=
+-ACLOCAL_AMFLAGS=-l m4
+
+ DISTCLEANFILES = trivialcompilemessage *.db #* *~ *.log
+ CLEANFILES = $(DISTCLEANFILES) stamp-h1
+diff -Nru ntop-3.3.10.orig/configure.in ntop-3.3.10/configure.in
+--- ntop-3.3.10.orig/configure.in 2009-05-06 14:55:22.000000000 +0000
++++ ntop-3.3.10/configure.in 2009-06-14 09:48:54.000000000 +0000
+@@ -57,6 +57,7 @@
+ dnl>
+ umask 002
+ AM_CONFIG_HEADER(config.h)
++AM_MAINTAINER_MODE
+
+ HAS_ERROR=
+ HAS_WARNING=
+@@ -507,11 +508,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/ /opt/local
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+diff -Nru ntop-3.3.10.orig/globals-core.c ntop-3.3.10/globals-core.c
+--- ntop-3.3.10.orig/globals-core.c 2009-04-17 20:27:57.000000000 +0000
++++ ntop-3.3.10/globals-core.c 2009-06-14 09:47:43.000000000 +0000
+@@ -386,7 +386,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+diff -Nru ntop-3.3.10.orig/report.c ntop-3.3.10/report.c
+--- ntop-3.3.10.orig/report.c 2009-05-21 21:55:11.000000000 +0000
++++ ntop-3.3.10/report.c 2009-06-14 09:47:43.000000000 +0000
+@@ -2305,7 +2305,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+
diff --git a/net-analyzer/ntop/ntop-3.3.10.ebuild b/net-analyzer/ntop/ntop-3.3.10.ebuild
new file mode 100644
index 000000000000..079cc41c0f56
--- /dev/null
+++ b/net-analyzer/ntop/ntop-3.3.10.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.10.ebuild,v 1.1 2009/06/14 10:05:51 mrness Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 ssl tcpd"
+#snmp support is disabled
+
+#snmp? ( net-analyzer/net-snmp )
+COMMON_DEPEND="sys-apps/gawk
+ dev-lang/perl
+ sys-libs/gdbm
+ dev-libs/libevent
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ sys-libs/zlib
+ >=dev-libs/geoip-1.4.5"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.4"
+
+# Needed by xmldumpPlugin - couldn't get it to work
+# dev-libs/gdome2
+# >=dev-libs/glib-2"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz
+ net-misc/wget
+ app-arch/gzip"
+
+pkg_setup() {
+ # snmp doesn't compile in this release, disabled for now
+ #if use snmp ; then
+ # ewarn "snmp plugin is under development and upstream does not recommend"
+ # ewarn "it for usage in production environment."
+ # if ! use ipv6 ; then
+ # echo
+ # eerror "snmp plugin has compilation problems without ipv6 support."
+ # eerror "For additional information see bug #121497."
+ # die "snmp without ipv6 is broken"
+ # else
+ # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ # echo
+ # eerror "You have both ipv6 and snmp enabled."
+ # eerror "This require ipv6 support in net-analyzer/net-snmp."
+ # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
+ # die "net-analyzer/net-snmp was build without ipv6."
+ # fi
+ # fi
+ #fi
+
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-external-geoip.patch
+ cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_configure() {
+ # force disable xmldumpPlugin
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with ssl) $(use_enable ssl sslwatchdog) \
+ $(use_with tcpd tcpwrap) \
+ --with-rrd-home=/usr/lib \
+ --disable-snmp \
+ || die "configure problem"
+ # $(use_enable snmp)
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop ||
+ die "failed to prepare /var/lib/ntop dir"
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following commands before starting ntop service:"
+ elog " ntop --set-admin-password"
+ elog " /etc/cron.monthly/ntop-update-geoip-db"
+}