summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-20 21:53:31 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-20 21:53:31 +0000
commit676fef30e5f59f4f890daecbf3f18ae8d1e7076f (patch)
tree08a2800b36a5ac27483e07803e27f9caddef23d9
parentmake openoffice-bin (diff)
downloadgentoo-2-676fef30e5f59f4f890daecbf3f18ae8d1e7076f.tar.gz
gentoo-2-676fef30e5f59f4f890daecbf3f18ae8d1e7076f.tar.bz2
gentoo-2-676fef30e5f59f4f890daecbf3f18ae8d1e7076f.zip
major cleanup - this is a working version :-)
-rw-r--r--sys-apps/cronbase/cronbase-0.01.ebuild10
-rw-r--r--sys-apps/cronbase/files/README20
-rw-r--r--sys-apps/cronbase/files/crontab25
-rw-r--r--sys-apps/cronbase/files/run-crons1
4 files changed, 22 insertions, 34 deletions
diff --git a/sys-apps/cronbase/cronbase-0.01.ebuild b/sys-apps/cronbase/cronbase-0.01.ebuild
index 78ad97b885ef..875b30f21e54 100644
--- a/sys-apps/cronbase/cronbase-0.01.ebuild
+++ b/sys-apps/cronbase/cronbase-0.01.ebuild
@@ -17,19 +17,15 @@ keepdir() {
src_install () {
- dodir /usr/sbin
+ exeinto /usr/sbin
doexe ${FILESDIR}/run-crons
- insinto /etc
- doins ${FILESDIR}/crontab
-
diropts -m0750; keepdir /etc/cron.hourly
diropts -m0750; keepdir /etc/cron.daily
diropts -m0750; keepdir /etc/cron.weekly
- diropts -m0750; keepdir /etc/cron.montly
+ diropts -m0750; keepdir /etc/cron.monthly
- diropts -m0770 -o root -g cron; keepdir /var/spool/cron
- diropts -m0770 -o root -g cron; keepdir /var/spool/cron/crontabs
+ diropts -m0750 -o root -g cron; keepdir /var/spool/cron
diropts -m0750; keepdir /var/spool/cron/lastrun
diff --git a/sys-apps/cronbase/files/README b/sys-apps/cronbase/files/README
index 693cedc05020..5132c25e8c21 100644
--- a/sys-apps/cronbase/files/README
+++ b/sys-apps/cronbase/files/README
@@ -1,8 +1,24 @@
+
+$ Header: $
+
+20 Apr 2oo2; Thilo Bangert <bangert@gentoo.org>
+
+initial release
+
+
+
The Gentoo Linux Cron README
============================
+
+ - To be able to use cron a user must be part of the cron group.
+
+ - Crontabs are placed in /var/spool/cron/crontabs
+ - Each cron takes care of running /etc/cron.{hourly|daily|weekly|montly}. Vixie
+ Cron does this via the system crontab /etc/crontab - the others must have a
+ root crontab that takes care of this.
- This document describes the way crons that are placed in portage are supposed to behave. This is to ensure that all crons behave similar and adhere to the same security standards.
+ - Only one cron per system.
+ - dcron is "default"
- \ No newline at end of file
diff --git a/sys-apps/cronbase/files/crontab b/sys-apps/cronbase/files/crontab
deleted file mode 100644
index 06fb20ebafeb..000000000000
--- a/sys-apps/cronbase/files/crontab
+++ /dev/null
@@ -1,25 +0,0 @@
-
-# /etc/crontab
-# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
-
-
-# fcron || dcron:
-# This is not the system crontab! to get this working with fcron or dcron do
-# crontab /etc/crontab
-# as root.
-# NOTE: This will REPLACE root's current crontab!!
-
-# vcron:
-# ignore this file. do NOT update to this file, as it does not work with vcron
-#
-
-# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
-
-*/15 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
-0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
-0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
-0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
-0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
-
-
-
diff --git a/sys-apps/cronbase/files/run-crons b/sys-apps/cronbase/files/run-crons
index e62797aa8133..45c34210aa8d 100644
--- a/sys-apps/cronbase/files/run-crons
+++ b/sys-apps/cronbase/files/run-crons
@@ -1,5 +1,6 @@
#!/bin/sh
#
+# $ Header: $
#
# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> run-crons:
#