summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-08-02 19:19:17 +0000
committerPeter Gavin <pete@gentoo.org>2001-08-02 19:19:17 +0000
commit688cc92d42a2c4165e4c4ccd43d0a38285b91127 (patch)
tree3322c7fc401d04d44e18b780b52489a5cfd33456
parentadded sawfish and gdm (diff)
downloadgentoo-2-688cc92d42a2c4165e4c4ccd43d0a38285b91127.tar.gz
gentoo-2-688cc92d42a2c4165e4c4ccd43d0a38285b91127.tar.bz2
gentoo-2-688cc92d42a2c4165e4c4ccd43d0a38285b91127.zip
fixed grub-install issue
-rw-r--r--sys-apps/grub/files/grub-0.5.96.1-r3-gentoo.diff15
-rw-r--r--sys-apps/grub/grub-0.5.96.1-r3.ebuild42
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/grub/files/grub-0.5.96.1-r3-gentoo.diff b/sys-apps/grub/files/grub-0.5.96.1-r3-gentoo.diff
new file mode 100644
index 000000000000..d6ab35101f80
--- /dev/null
+++ b/sys-apps/grub/files/grub-0.5.96.1-r3-gentoo.diff
@@ -0,0 +1,15 @@
+diff -ur grub-0.5.96.1.orig/util/grub-install.in grub-0.5.96.1/util/grub-install.in
+--- grub-0.5.96.1.orig/util/grub-install.in Mon Oct 16 14:42:36 2000
++++ grub-0.5.96.1/util/grub-install.in Wed Aug 1 13:41:03 2001
+@@ -76,9 +76,9 @@
+ # Break the device name into the disk part and the partition part.
+ case "$host_os" in
+ linux*)
+- tmp_disk=`echo "$1" | sed -e 's%\([sh]d[a-z]\)[0-9]*$%\1%'
++ tmp_disk=`echo "$1" | sed -e 's%\([sh]d[a-z]\)[0-9]*$%\1%' \
+ -e 's%/part[0-9]*$%/disc%'`
+- tmp_part=`echo "$1" | sed -e 's%.*/[sh]d[a-z]\([0-9]*\)$%\1%'
++ tmp_part=`echo "$1" | sed -e 's%.*/[sh]d[a-z]\([0-9]*\)$%\1%' \
+ -e 's%.*/\(disc\|part\([0-9]*\)\)$%\2%'`
+ ;;
+ gnu*)
diff --git a/sys-apps/grub/grub-0.5.96.1-r3.ebuild b/sys-apps/grub/grub-0.5.96.1-r3.ebuild
new file mode 100644
index 000000000000..571b6928d691
--- /dev/null
+++ b/sys-apps/grub/grub-0.5.96.1-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# /home/cvsroot/gentoo-x86/sys-apps/grub/grub-0.5.96.1-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU GRUB boot loader"
+SRC_URI="ftp://alpha.gnu.org/gnu/grub/${A}"
+HOMEPAGE="http://www.gnu.org/software/grub"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr \
+ --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
+
+ try make ${MAKEOPTS} -e CPPFLAGS=\"-Wall -Wmissing-prototypes -Wunused -Wshadow -malign-jumps=1 -malign-loops=1 -malign-functions=1 -Wundef\"
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+
+ dodir /boot/boot/grub
+ cd ${D}/usr/share/grub/i386-pc
+ cp stage1 stage2 *stage1_5 ${D}/boot/boot/grub
+
+ cd ${S}
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+}
+
+
+