summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-13 22:32:26 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-13 22:32:26 +0000
commit69763e1f6d08a8a88a37181b2a9aeda77a82a426 (patch)
tree57b96fd9dba0b04b9131d4ebefbd27c85d49b60f
parentfix docs again (diff)
downloadgentoo-2-69763e1f6d08a8a88a37181b2a9aeda77a82a426.tar.gz
gentoo-2-69763e1f6d08a8a88a37181b2a9aeda77a82a426.tar.bz2
gentoo-2-69763e1f6d08a8a88a37181b2a9aeda77a82a426.zip
version bump to close #79208
(Portage version: 2.0.51.22-r1)
-rw-r--r--x11-misc/idesk/ChangeLog7
-rw-r--r--x11-misc/idesk/Manifest4
-rw-r--r--x11-misc/idesk/files/digest-idesk-0.7.21
-rw-r--r--x11-misc/idesk/idesk-0.7.2.ebuild46
4 files changed, 56 insertions, 2 deletions
diff --git a/x11-misc/idesk/ChangeLog b/x11-misc/idesk/ChangeLog
index caf22bfbe10d..feedc399d8cf 100644
--- a/x11-misc/idesk/ChangeLog
+++ b/x11-misc/idesk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/idesk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/ChangeLog,v 1.24 2005/05/24 01:06:17 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/ChangeLog,v 1.25 2005/06/13 22:32:26 smithj Exp $
+
+*idesk-0.7.2 (13 Jun 2005)
+
+ 13 Jun 2005; Jonathan Smith <smithj@gentoo.org> +idesk-0.7.2.ebuild:
+ Major version bump to close #79208
24 May 2005; Jason Wever <weeve@gentoo.org> idesk-0.5.6.ebuild:
Stable on SPARC wrt bug #93341.
diff --git a/x11-misc/idesk/Manifest b/x11-misc/idesk/Manifest
index 1c7fee4b864a..b7e1e138d87c 100644
--- a/x11-misc/idesk/Manifest
+++ b/x11-misc/idesk/Manifest
@@ -1,9 +1,11 @@
+MD5 e2a43fc834f1da49322e1ad610cf99c8 ChangeLog 3814
MD5 19d12b9efd8bc0bf17339d45c21502b0 idesk-0.5.6.ebuild 1169
-MD5 1d9a33212dc2d2f032b99c1cb5c58b8a ChangeLog 3677
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
+MD5 b8327262983321bd1a97b855bec6b867 idesk-0.7.2.ebuild 1065
MD5 5e31e5eb7d0cfc2bc90454a7f4354605 files/digest-idesk-0.5.6 62
MD5 8b29339fdf933c6dfac6f605f3b306e4 files/idesk-0.3.5-clickbox-and-singleclick.patch 6762
MD5 936075c618affeca8533c3ecab323871 files/idesk.1 2485
MD5 681d0e14514c589e16568398b9eeecd0 files/idesk05.1 4844
MD5 7391b893cc28213bef73f7f929155698 files/ideskrc.5 2329
MD5 d6f779298131bfbc97f59b71dea6e5ce files/ideskrc05.5 7091
+MD5 7023bf0d2caddb6cacf5d836ceb28645 files/digest-idesk-0.7.2 63
diff --git a/x11-misc/idesk/files/digest-idesk-0.7.2 b/x11-misc/idesk/files/digest-idesk-0.7.2
new file mode 100644
index 000000000000..ea388363cfe5
--- /dev/null
+++ b/x11-misc/idesk/files/digest-idesk-0.7.2
@@ -0,0 +1 @@
+MD5 2c914b50e4c7762f3f6113202622c398 idesk-0.7.2.tar.gz 207021
diff --git a/x11-misc/idesk/idesk-0.7.2.ebuild b/x11-misc/idesk/idesk-0.7.2.ebuild
new file mode 100644
index 000000000000..544782f80d78
--- /dev/null
+++ b/x11-misc/idesk/idesk-0.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/idesk-0.7.2.ebuild,v 1.1 2005/06/13 22:32:26 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="http://idesk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE=""
+
+DEPEND=">=media-libs/imlib2-1.1.2.20040912
+ virtual/x11
+ media-libs/freetype
+ >=dev-util/pkgconfig-0.12.0
+ dev-libs/libxml2
+ =dev-libs/glib-2*
+ gnome-extra/libgsf
+ =x11-libs/pango-1*
+ =x11-libs/gtk+-2*
+ media-libs/libart_lgpl
+ x11-libs/startup-notification"
+
+src_compile() {
+ econf --enable-libsn || die "configuration failed"
+ emake || die "compilation failed"
+}
+
+src_install() {
+ # this nastyness is to prevent sandboxing problems due to a _really_ crappy
+ # makefile
+ dodir /usr/share/idesk
+ cp examples/dot.ideskrc ${D}/usr/share/idesk/
+ exeinto /usr/bin
+ doexe src/idesk
+ dodoc README AUTHORS COPYING INSTALL NEWS TODO
+}
+
+pkg_postinst() {
+ einfo "Please refer to ${HOMEPAGE} for info on configuring ${PN}"
+}