summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-12-03 17:23:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-12-03 17:23:08 +0000
commit6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5 (patch)
treeecc499a33d6d40c459efa2320071049ba350edfa
parentFixed pre-stripping of binaries; bug #137822. (diff)
downloadgentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.tar.gz
gentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.tar.bz2
gentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.zip
Version bumped.
(Portage version: 2.1.1-r2)
-rw-r--r--media-video/vmaid/ChangeLog9
-rw-r--r--media-video/vmaid/files/digest-vmaid-1.8.152
-rw-r--r--media-video/vmaid/files/digest-vmaid-2.0.63
-rw-r--r--media-video/vmaid/vmaid-2.0.6.ebuild46
4 files changed, 58 insertions, 2 deletions
diff --git a/media-video/vmaid/ChangeLog b/media-video/vmaid/ChangeLog
index 5e0358161311..cc847a47ea43 100644
--- a/media-video/vmaid/ChangeLog
+++ b/media-video/vmaid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vmaid
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/ChangeLog,v 1.3 2004/10/18 12:25:45 dholm Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/ChangeLog,v 1.4 2006/12/03 17:23:08 matsuu Exp $
+
+*vmaid-2.0.6 (03 Dec 2006)
+
+ 03 Dec 2006; MATSUU Takuto <matsuu@gentoo.org> +vmaid-2.0.6.ebuild:
+ Version bumped.
18 Oct 2004; David Holm <dholm@gentoo.org> vmaid-1.8.15.ebuild:
Added to ~ppc.
diff --git a/media-video/vmaid/files/digest-vmaid-1.8.15 b/media-video/vmaid/files/digest-vmaid-1.8.15
index 4c5001cc6bcb..8d574681a234 100644
--- a/media-video/vmaid/files/digest-vmaid-1.8.15
+++ b/media-video/vmaid/files/digest-vmaid-1.8.15
@@ -1 +1,3 @@
MD5 fc34f2f8cf777120db38e72ce962dfa3 vmaid-1.8.15.tar.gz 548362
+RMD160 8ac0842b3f7714a448550b55f79705a26499b9cc vmaid-1.8.15.tar.gz 548362
+SHA256 262c2e26a2bda3a1a8754a40f5ec3b843de95e1d92c38594fde3f3cce052c3e1 vmaid-1.8.15.tar.gz 548362
diff --git a/media-video/vmaid/files/digest-vmaid-2.0.6 b/media-video/vmaid/files/digest-vmaid-2.0.6
new file mode 100644
index 000000000000..d12c86582d4f
--- /dev/null
+++ b/media-video/vmaid/files/digest-vmaid-2.0.6
@@ -0,0 +1,3 @@
+MD5 0f4a10c60e9a275c83edfa421d8584b9 vmaid-2.0.6.tar.gz 989277
+RMD160 aacc257949c2dfe46e05bd063f6ca33d730baab0 vmaid-2.0.6.tar.gz 989277
+SHA256 a49b8482931eed300c927e954018c791e325b24717f1db9f730b64f7cec74331 vmaid-2.0.6.tar.gz 989277
diff --git a/media-video/vmaid/vmaid-2.0.6.ebuild b/media-video/vmaid/vmaid-2.0.6.ebuild
new file mode 100644
index 000000000000..2e6b89a62276
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/vmaid-2.0.6.ebuild,v 1.1 2006/12/03 17:23:08 matsuu Exp $
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/22932/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime win32codecs"
+
+RDEPEND=">=x11-libs/gtk+-2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ win32codecs? ( media-libs/win32codecs )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+#MAKEOPTS="-j1"
+
+src_compile() {
+ local myconf
+
+ if use ao ; then
+ myconf="${myconf} --with-ao=yes"
+ elif use alsa ; then
+ myconf="${myconf} --with-alsa=yes"
+ fi
+
+ econf \
+ $(use_enable mime) \
+ $(use_with win32codecs w32) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}