summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-12-31 18:09:51 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-12-31 18:09:51 +0000
commit6a65cb624f9b47a9e567d4fb8f1fe90b83e2ee37 (patch)
tree2035164bcad195ea2430cda582ced78d9bb81344
parentKeyword ~x64-freebsd (diff)
downloadgentoo-2-6a65cb624f9b47a9e567d4fb8f1fe90b83e2ee37.tar.gz
gentoo-2-6a65cb624f9b47a9e567d4fb8f1fe90b83e2ee37.tar.bz2
gentoo-2-6a65cb624f9b47a9e567d4fb8f1fe90b83e2ee37.zip
version bump; better utf8 support, various fixes plus upstream systemd support
(Portage version: 2.1.11.36/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
-rw-r--r--x11-misc/slim/ChangeLog9
-rw-r--r--x11-misc/slim/files/slim-1.3.5-arm.patch11
-rw-r--r--x11-misc/slim/slim-1.3.5.ebuild109
3 files changed, 128 insertions, 1 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index fef121f3f14a..4eb61b7b33d6 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.92 2012/12/29 19:01:30 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.93 2012/12/31 18:09:51 axs Exp $
+
+*slim-1.3.5 (31 Dec 2012)
+
+ 31 Dec 2012; Ian Stakenvicius <axs@gentoo.org> +slim-1.3.5.ebuild,
+ +files/slim-1.3.5-arm.patch:
+ version bump; better utf8 support, various fixes plus upstream systemd
+ support
*slim-1.3.4-r2 (29 Dec 2012)
diff --git a/x11-misc/slim/files/slim-1.3.5-arm.patch b/x11-misc/slim/files/slim-1.3.5-arm.patch
new file mode 100644
index 000000000000..9438ce4a1caf
--- /dev/null
+++ b/x11-misc/slim/files/slim-1.3.5-arm.patch
@@ -0,0 +1,11 @@
+--- a/Ck.cpp 2012-06-26 04:20:14.000000000 -0400
++++ b/Ck.cpp 2012-10-05 13:25:29.000000000 -0400
+@@ -91,7 +91,7 @@
+
+ vt = *((long *)return_value);
+
+- std::snprintf(device, 32, "/dev/tty%ld", vt);
++ std::sprintf(device, "/dev/tty%ld", vt);
+
+ if(return_value)
+ XFree(return_value);
diff --git a/x11-misc/slim/slim-1.3.5.ebuild b/x11-misc/slim/slim-1.3.5.ebuild
new file mode 100644
index 000000000000..23cefcf678eb
--- /dev/null
+++ b/x11-misc/slim/slim-1.3.5.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.5.ebuild,v 1.1 2012/12/31 18:09:51 axs Exp $
+
+EAPI=4
+
+CMAKE_MIN_VERSION="2.8.8"
+inherit cmake-utils pam eutils systemd versionator
+
+DESCRIPTION="Simple Login Manager"
+HOMEPAGE="http://slim.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="branding pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft
+ media-libs/libpng
+ virtual/jpeg
+ x11-apps/sessreg
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+PDEPEND="branding? ( >=x11-themes/slim-themes-1.2.3a-r3 )"
+
+src_prepare() {
+ # Our Gentoo-specific config changes
+ epatch "${FILESDIR}"/${PN}-1.3.4-config.diff
+ epatch "${FILESDIR}"/${P}-arm.patch
+
+ if use elibc_FreeBSD; then
+ sed -i -e 's/"-DHAVE_SHADOW"/"-DNEEDS_BASENAME"/' CMakeLists.txt \
+ || die
+ fi
+
+ if use branding; then
+ sed -i -e 's/ default/ slim-gentoo-simple/' slim.conf || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use pam USE_PAM)
+ $(cmake-utils_use consolekit USE_CONSOLEKIT)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use pam ; then
+ pamd_mimic system-local-login slim auth account session
+ fi
+
+ insinto /usr/share/slim
+ newins "${FILESDIR}/Xsession-r3" Xsession
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/slim.logrotate" slim
+
+ dodoc xinitrc.sample ChangeLog README TODO THEMES
+}
+
+pkg_postinst() {
+ # note, $REPLACING_VERSIONS will always contain 0 or 1 PV's for slim
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "The configuration file is located at /etc/slim.conf."
+ elog
+ elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
+ elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
+ fi
+ if ! version_is_at_least "1.3.2-r7" "${REPLACING_VERSIONS:-1.0}" ; then
+ elog
+ elog "By default, ${PN} is set up to do proper X session selection, including ~/.xsession"
+ elog "support, as well as selection between sessions available in"
+ elog "/etc/X11/Sessions/ at login by pressing [F1]."
+ elog
+ elog "The XSESSION environment variable is still supported as a default"
+ elog "if no session has been specified by the user."
+ elog
+ elog "If you want to use .xinitrc in the user's home directory for session"
+ elog "management instead, see README and xinitrc.sample in"
+ elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
+ elog "accordingly."
+ elog
+ ewarn "Please note that slim supports consolekit directly. Please do not use any "
+ ewarn "old work-arounds (including calls to 'ck-launch-session' in xinitrc scripts)"
+ ewarn "and enable USE=\"consolekit\" instead."
+ ewarn
+ fi
+ if ! use pam; then
+ elog "You have merged ${PN} without USE=\"pam\", this will cause ${PN} to fall back to"
+ elog "the console when restarting your window manager. If this is not desired, then"
+ elog "please remerge ${PN} with USE=\"pam\""
+ elog
+ fi
+}