summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-12-01 00:50:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-12-01 00:50:36 +0000
commit6b42db0ee8f35123c94164970050d26fafdda601 (patch)
tree5675a2911ceec08d32c8f84e3d3ab1fab7ea8d02
parentVersion bumped. (diff)
downloadgentoo-2-6b42db0ee8f35123c94164970050d26fafdda601.tar.gz
gentoo-2-6b42db0ee8f35123c94164970050d26fafdda601.tar.bz2
gentoo-2-6b42db0ee8f35123c94164970050d26fafdda601.zip
Version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.7 i686)
-rw-r--r--games-emulation/yabause/ChangeLog7
-rw-r--r--games-emulation/yabause/yabause-0.9.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/games-emulation/yabause/ChangeLog b/games-emulation/yabause/ChangeLog
index 3fac670d69c0..7f4ed204c3a1 100644
--- a/games-emulation/yabause/ChangeLog
+++ b/games-emulation/yabause/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/yabause
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.27 2008/08/31 22:03:26 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/ChangeLog,v 1.28 2008/12/01 00:50:36 nyhm Exp $
+
+*yabause-0.9.8 (01 Dec 2008)
+
+ 01 Dec 2008; Tristan Heaven <nyhm@gentoo.org> +yabause-0.9.8.ebuild:
+ Version bump
*yabause-0.9.7 (31 Aug 2008)
diff --git a/games-emulation/yabause/yabause-0.9.8.ebuild b/games-emulation/yabause/yabause-0.9.8.ebuild
new file mode 100644
index 000000000000..38b3fd8f633c
--- /dev/null
+++ b/games-emulation/yabause/yabause-0.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.9.8.ebuild,v 1.1 2008/12/01 00:50:36 nyhm Exp $
+
+EAPI=1
+inherit games
+
+DESCRIPTION="A Sega Saturn emulator"
+HOMEPAGE="http://yabause.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/gtkglext
+ virtual/opengl
+ virtual/glu
+ virtual/glut
+ media-libs/libsdl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ egamesconf \
+ --datadir=/usr/share \
+ --with-port=gtk \
+ || die
+ emake -C src/c68k gen68k || die "emake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog GOALS README README.LIN TODO
+ prepgamesdirs
+}