summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-02 08:57:50 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-02 08:57:50 +0000
commit6cd7ee41e1b9936b192fda6df39c692fd16fffbd (patch)
tree817221f6277eb225bf3d23b7151193f9f96c94c8
parentsci-biology/rebase: Version BUmp; clean old (diff)
downloadgentoo-2-6cd7ee41e1b9936b192fda6df39c692fd16fffbd.tar.gz
gentoo-2-6cd7ee41e1b9936b192fda6df39c692fd16fffbd.tar.bz2
gentoo-2-6cd7ee41e1b9936b192fda6df39c692fd16fffbd.zip
sys-kernel/aufs-sources: Bump to latest aufs3, genpatches and linux release
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sys-kernel/aufs-sources/ChangeLog8
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.10.41.ebuild82
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild4
-rw-r--r--sys-kernel/aufs-sources/files/README.gentoo20
4 files changed, 112 insertions, 2 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index 5c23946ee3e8..24ad9491f18b 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.117 2014/05/24 09:41:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.118 2014/06/02 08:57:49 jlec Exp $
+
+*aufs-sources-3.10.41 (02 Jun 2014)
+
+ 02 Jun 2014; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.10.41.ebuild,
+ aufs-sources-3.12.20.ebuild, +files/README.gentoo:
+ Bump to latest aufs3, genpatches and linux release
24 May 2014; Markos Chandras <hwoarang@gentoo.org>
aufs-sources-3.12.20.ebuild:
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.10.41.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.10.41.ebuild
new file mode 100644
index 000000000000..cae9cf2b4ff8
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.10.41.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.10.41.ebuild,v 1.1 2014/06/02 08:57:49 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+UNIPATCH_STRICTORDER=1
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.10.x_p20140602
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ einfo "Using aufs3 version: ${AUFS_VERSION}"
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+src_install() {
+ kernel-2_src_install
+ dodoc "${WORKDIR}"/{aufs3-loopback,vfs-ino,tmpfs-ibitmap}.patch
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util || \
+ elog "In order to use aufs FS you need to install sys-fs/aufs-util"
+
+ readme.gentoo_pkg_postinst
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild
index 6cfb5c2251cd..5b1922586384 100644
--- a/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild
+++ b/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild,v 1.2 2014/05/24 09:41:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.20.ebuild,v 1.3 2014/06/02 08:57:49 jlec Exp $
EAPI=5
@@ -48,6 +48,8 @@ src_unpack() {
unpack ${AUFS_TARBALL}
+ einfo "Using aufs3 version: ${AUFS_VERSION}"
+
kernel-2_src_unpack
}
diff --git a/sys-kernel/aufs-sources/files/README.gentoo b/sys-kernel/aufs-sources/files/README.gentoo
new file mode 100644
index 000000000000..c203912926fe
--- /dev/null
+++ b/sys-kernel/aufs-sources/files/README.gentoo
@@ -0,0 +1,20 @@
+There several other patches in aufs3. They are all
+optional. When you meet some problems, they will help you. You can find them
+in the documentation directory.
+
+ - aufs3-loopback.patch
+ Supports a nested loopback mount in a branch-fs. This patch is
+ unnecessary until aufs produces a message such like "you may want to try
+ another patch for loopback file".
+
+ - vfs-ino.patch
+ Modifies a system global kernel internal function get_next_ino() in
+ order to stop assigning 0 for an inode-number. Not directly related to
+ aufs, but recommended generally.
+
+ - tmpfs-ibitmap.patch
+ Keeps the tmpfs inode number as the lowest value. Effective to reduce
+ the size of aufs XINO files for tmpfs branch. Also it prevents the
+ duplication of inode number, which is important for backup
+ tools, aubrsync or other utilities. When you find aufs XINO files for
+ tmpfs branch growing too much, try this patch.