summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-06-03 04:21:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-06-03 04:21:13 +0000
commit6e68ec4341df7371087db9042498da178daa9bf2 (patch)
treef8de4588475bceeb6d2cefcb10d2570a2e2d4b47
parentcleanup old ebuilds and fix for get_PV to detect RC versions of wireshark pro... (diff)
downloadgentoo-2-6e68ec4341df7371087db9042498da178daa9bf2.tar.gz
gentoo-2-6e68ec4341df7371087db9042498da178daa9bf2.tar.bz2
gentoo-2-6e68ec4341df7371087db9042498da178daa9bf2.zip
Version bump (bug #471824), fix tests to run for all python versions. Note: python 3.x support is still alpha and tests fail.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
-rw-r--r--dev-python/south/ChangeLog8
-rw-r--r--dev-python/south/south-0.8.1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/south/ChangeLog b/dev-python/south/ChangeLog
index d4cba2113ae6..a75fe3c2f228 100644
--- a/dev-python/south/ChangeLog
+++ b/dev-python/south/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/south
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.9 2013/05/18 08:26:04 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/ChangeLog,v 1.10 2013/06/03 04:21:13 dev-zero Exp $
+
+*south-0.8.1 (03 Jun 2013)
+
+ 03 Jun 2013; Tiziano Müller <dev-zero@gentoo.org> +south-0.8.1.ebuild:
+ Version bump (bug #471824), fix tests to run for all python versions. Note:
+ python 3.x support is still alpha and tests fail.
*south-0.7.5-r1 (18 May 2013)
*south-0.7.6 (18 May 2013)
diff --git a/dev-python/south/south-0.8.1.ebuild b/dev-python/south/south-0.8.1.ebuild
new file mode 100644
index 000000000000..d57d12ef36ca
--- /dev/null
+++ b/dev-python/south/south-0.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/south/south-0.8.1.ebuild,v 1.1 2013/06/03 04:21:13 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Intelligent schema migrations for Django apps."
+HOMEPAGE="http://south.aeracode.org/"
+SRC_URI="https://bitbucket.org/andrewgodwin/south/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx dev-python/jinja )
+ test? ( dev-python/django[sqlite] )"
+
+# we are setting up the tests, but they fail
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ if use test; then
+ cd "${BUILD_DIR}"
+ django-admin.py startproject southtest || die "setting up test env failed"
+ cd southtest
+ sed -i \
+ -e "/^INSTALLED_APPS/a\ 'south'," \
+ -e 's/\(django.db.backends.\)/\1sqlite3/' \
+ -e "s/\(NAME': '\)/\1test.db/" \
+ southtest/settings.py || die "sed failed"
+ echo "SKIP_SOUTH_TESTS=False" >> southtest/settings.py
+ fi
+}
+
+python_test() {
+ # http://south.aeracode.org/ticket/1256
+ cd "${BUILD_DIR}/southtest"
+ "${EPYTHON}" manage.py test south || die "tests failed for ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "In order to use the south schema migrations for your Django project,"
+ elog "just add 'south' to your INSTALLED_APPS in the settings.py file."
+ elog "manage.py will now automagically offer the new functions."
+}