summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 12:03:18 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 12:03:18 +0000
commit6ea566d7cb3b8565527a2f8f2c9e15251f6b0099 (patch)
tree2f9238af25edbc0fca046a8eef48a48dfbec4533
parentBump system-filepath to 0.4.8 (diff)
downloadgentoo-2-6ea566d7cb3b8565527a2f8f2c9e15251f6b0099.tar.gz
gentoo-2-6ea566d7cb3b8565527a2f8f2c9e15251f6b0099.tar.bz2
gentoo-2-6ea566d7cb3b8565527a2f8f2c9e15251f6b0099.zip
Bump tasty to 0.3.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/tasty/ChangeLog7
-rw-r--r--dev-haskell/tasty/tasty-0.3.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-haskell/tasty/ChangeLog b/dev-haskell/tasty/ChangeLog
index 641752a1d972..cc573fb3e502 100644
--- a/dev-haskell/tasty/ChangeLog
+++ b/dev-haskell/tasty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/tasty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/ChangeLog,v 1.1 2013/09/13 10:04:58 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/ChangeLog,v 1.2 2013/10/19 12:03:18 gienah Exp $
+
+*tasty-0.3.1 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +tasty-0.3.1.ebuild:
+ Bump tasty to 0.3.1
*tasty-0.2 (13 Sep 2013)
diff --git a/dev-haskell/tasty/tasty-0.3.1.ebuild b/dev-haskell/tasty/tasty-0.3.1.ebuild
new file mode 100644
index 000000000000..726d1ec3e182
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/tasty-0.3.1.ebuild,v 1.1 2013/10/19 12:03:18 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://hackage.haskell.org/package/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+colors"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ dev-haskell/regex-posix:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ colors? ( dev-haskell/ansi-terminal:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}