summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-08 21:43:07 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-08 21:43:07 +0000
commit705416ca3e9fd4c52ab0af196f02f451e8188a9f (patch)
treefd7dd31defd06ea88f29a6f773f6f1099a3ba00a
parentTry again.. (diff)
downloadgentoo-2-705416ca3e9fd4c52ab0af196f02f451e8188a9f.tar.gz
gentoo-2-705416ca3e9fd4c52ab0af196f02f451e8188a9f.tar.bz2
gentoo-2-705416ca3e9fd4c52ab0af196f02f451e8188a9f.zip
Dont ignore errors in the shlib subdir #216952 by Markus Ullmann.
(Portage version: 2.2_pre5)
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/readline-5.2-no-ignore-shlib-errors.patch24
-rw-r--r--sys-libs/readline/readline-5.2_p12-r1.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index d62b929b3c3a..baae1b817aa2 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.115 2008/02/26 23:06:13 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.116 2008/04/08 21:43:06 vapier Exp $
+
+ 08 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/readline-5.2-no-ignore-shlib-errors.patch,
+ readline-5.2_p12-r1.ebuild:
+ Dont ignore errors in the shlib subdir #216952 by Markus Ullmann.
26 Feb 2008; Santiago M. Mola <coldwind@gentoo.org>
readline-5.2_p12-r1.ebuild:
diff --git a/sys-libs/readline/files/readline-5.2-no-ignore-shlib-errors.patch b/sys-libs/readline/files/readline-5.2-no-ignore-shlib-errors.patch
new file mode 100644
index 000000000000..fc6349113167
--- /dev/null
+++ b/sys-libs/readline/files/readline-5.2-no-ignore-shlib-errors.patch
@@ -0,0 +1,24 @@
+dont ignore errors in the shlib subdir
+
+http://bugs.gentoo.org/216952
+
+--- Makefile.in
++++ Makefile.in
+@@ -194,7 +194,7 @@
+
+ shared: force
+ -test -d shlib || mkdir shlib
+- -( cd shlib ; ${MAKE} ${MFLAGS} all )
++ ( cd shlib ; ${MAKE} ${MFLAGS} all )
+
+ documentation: force
+ -test -d doc || mkdir doc
+@@ -238,7 +238,7 @@
+ -( cd shlib; ${MAKE} ${MFLAGS} DESTDIR=${DESTDIR} uninstall )
+
+ install-shared: installdirs install-headers shared install-doc
+- -( cd shlib ; ${MAKE} ${MFLAGS} DESTDIR=${DESTDIR} install )
++ ( cd shlib ; ${MAKE} ${MFLAGS} DESTDIR=${DESTDIR} install )
+
+ uninstall-shared: maybe-uninstall-headers
+ -( cd shlib; ${MAKE} ${MFLAGS} DESTDIR=${DESTDIR} uninstall )
diff --git a/sys-libs/readline/readline-5.2_p12-r1.ebuild b/sys-libs/readline/readline-5.2_p12-r1.ebuild
index 9439e5e7b488..4bf6f35fa494 100644
--- a/sys-libs/readline/readline-5.2_p12-r1.ebuild
+++ b/sys-libs/readline/readline-5.2_p12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2_p12-r1.ebuild,v 1.7 2008/02/26 23:06:13 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2_p12-r1.ebuild,v 1.8 2008/04/08 21:43:06 vapier Exp $
inherit eutils multilib toolchain-funcs flag-o-matic
@@ -45,6 +45,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
epatch "${FILESDIR}"/${PN}-5.2-rlfe-build.patch #151174
epatch "${FILESDIR}"/${PN}-5.1-rlfe-uclibc.patch
+ epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
ln -s ../.. examples/rlfe/readline