summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-04 01:19:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-04 01:19:13 +0000
commit70e47e91cbbbf69136d5b8757496cb22160c8ac8 (patch)
treeeb16a843f14d05263366356cbf9d609b4ef2398a
parentia64/x86 stable (Manifest recommit) (diff)
downloadgentoo-2-70e47e91cbbbf69136d5b8757496cb22160c8ac8.tar.gz
gentoo-2-70e47e91cbbbf69136d5b8757496cb22160c8ac8.tar.bz2
gentoo-2-70e47e91cbbbf69136d5b8757496cb22160c8ac8.zip
Version bump.
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.251
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.25.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 86c76e8dd6d1..67e575833aa1 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.14 2004/10/08 14:00:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.15 2004/12/04 01:19:13 vapier Exp $
+
+*xfsdump-2.2.25 (03 Dec 2004)
+
+ 03 Dec 2004; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.25.ebuild:
+ Version bump.
*xfsdump-2.2.24 (08 Oct 2004)
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.25 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.25
new file mode 100644
index 000000000000..18fd3cf55c3d
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.25
@@ -0,0 +1 @@
+MD5 62480f8575cad381eed542237c7f0ba3 xfsdump-2.2.25.src.tar.gz 589851
diff --git a/sys-fs/xfsdump/xfsdump-2.2.25.ebuild b/sys-fs/xfsdump/xfsdump-2.2.25.ebuild
new file mode 100644
index 000000000000..eae4298c219a
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.25.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.25.ebuild,v 1.1 2004/12/04 01:19:13 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE="debug static"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ sys-apps/attr"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ if use debug; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ unset PLATFORM
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT=${D} install || die
+ dosym /sbin/xfsrestore /usr/bin/xfsrestore
+ dosym /sbin/xfsdump /usr/bin/xfsdump
+}