summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-08-09 11:56:23 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-08-09 11:56:23 +0000
commit729ba9fbdd3bdcd8d5be0d14a86a2392c5506559 (patch)
tree3cba91d21d3b929e1c157b81a42e9b8c2633d69d
parentalpha stable (diff)
downloadgentoo-2-729ba9fbdd3bdcd8d5be0d14a86a2392c5506559.tar.gz
gentoo-2-729ba9fbdd3bdcd8d5be0d14a86a2392c5506559.tar.bz2
gentoo-2-729ba9fbdd3bdcd8d5be0d14a86a2392c5506559.zip
version bump
(Portage version: 2.1.2.7)
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.3.ebuild53
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.33
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index d2fcf365667a..f399bbddfcb7 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.12 2007/06/24 20:11:22 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.13 2007/08/09 11:56:23 caleb Exp $
+
+*PyQt4-4.3 (09 Aug 2007)
+
+ 09 Aug 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.ebuild:
+ Version bump
24 Jun 2007; Tiziano Müller <dev-zero@gentoo.org> PyQt4-4.2.ebuild:
Fixed $ROOT abuse (bug #167271) and some cleanup
diff --git a/dev-python/PyQt4/PyQt4-4.3.ebuild b/dev-python/PyQt4/PyQt4-4.3.ebuild
new file mode 100644
index 000000000000..aa751bd8d6ee
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.3.ebuild,v 1.1 2007/08/09 11:56:23 caleb Exp $
+
+inherit distutils
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.7"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages/PyQt4 \
+ -b /usr/bin \
+ -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.3 b/dev-python/PyQt4/files/digest-PyQt4-4.3
new file mode 100644
index 000000000000..64e090e48e96
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.3
@@ -0,0 +1,3 @@
+MD5 3bb0c0064dc6b8b80413f87a14e5553c PyQt-x11-gpl-4.3.tar.gz 6036193
+RMD160 26efc917243400a9925684e1d36f1478f7fcfb92 PyQt-x11-gpl-4.3.tar.gz 6036193
+SHA256 c184c3df596c13e9ed610aa8fa0504881976c4d972ccab1b739738a95f4ab0e5 PyQt-x11-gpl-4.3.tar.gz 6036193