summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-04-14 08:43:24 +0000
committerMark Wright <gienah@gentoo.org>2012-04-14 08:43:24 +0000
commit74786feae2e8b84065537c847c1051c59bb30460 (patch)
tree08c0c4ea2678c6918b9a2b3af0e8f311609b1480
parentVersion bump to development release. (diff)
downloadgentoo-2-74786feae2e8b84065537c847c1051c59bb30460.tar.gz
gentoo-2-74786feae2e8b84065537c847c1051c59bb30460.tar.bz2
gentoo-2-74786feae2e8b84065537c847c1051c59bb30460.zip
Bump test-framework to 0.6
(Portage version: 2.1.10.56/cvs/Linux x86_64)
-rw-r--r--dev-haskell/test-framework/ChangeLog8
-rw-r--r--dev-haskell/test-framework/metadata.xml13
-rw-r--r--dev-haskell/test-framework/test-framework-0.6.ebuild30
3 files changed, 46 insertions, 5 deletions
diff --git a/dev-haskell/test-framework/ChangeLog b/dev-haskell/test-framework/ChangeLog
index 780a8b376b55..9d88bd34ce7a 100644
--- a/dev-haskell/test-framework/ChangeLog
+++ b/dev-haskell/test-framework/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/test-framework
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/ChangeLog,v 1.12 2012/03/18 13:18:58 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/ChangeLog,v 1.13 2012/04/14 08:43:24 gienah Exp $
+
+*test-framework-0.6 (14 Apr 2012)
+
+ 14 Apr 2012; Mark Wright <gienah@gentoo.org> +test-framework-0.6.ebuild,
+ metadata.xml:
+ Bump test-framework to 0.6
18 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> test-framework-0.5.ebuild:
~alpha/~ia64/~ppc/~sparc/~x86-fbsd rekeyworded
diff --git a/dev-haskell/test-framework/metadata.xml b/dev-haskell/test-framework/metadata.xml
index 8c66906af531..4bfd2b53673c 100644
--- a/dev-haskell/test-framework/metadata.xml
+++ b/dev-haskell/test-framework/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>haskell</herd>
-<maintainer>
- <email>haskell@gentoo.org</email>
-</maintainer>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Allows tests such as QuickCheck properties and HUnit test cases to be assembled into test groups, run in
+ parallel (but reported in deterministic order, to aid diff interpretation) and filtered and controlled by
+ command line options. All of this comes with colored test output, progress reporting and test statistics output.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/test-framework/test-framework-0.6.ebuild b/dev-haskell/test-framework/test-framework-0.6.ebuild
new file mode 100644
index 000000000000..cce9e1c47c63
--- /dev/null
+++ b/dev-haskell/test-framework/test-framework-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/test-framework/test-framework-0.6.ebuild,v 1.1 2012/04/14 08:43:24 gienah Exp $
+
+# ebuild generated by hackport 0.2.17
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Framework for running and organising tests, with HUnit and QuickCheck support"
+HOMEPAGE="http://batterseapower.github.com/test-framework/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.5.1[profile?]
+ >=dev-haskell/hostname-1.0[profile?]
+ >=dev-haskell/random-1.0[profile?]
+ >=dev-haskell/regex-posix-0.72[profile?]
+ >=dev-haskell/time-1.1.2[profile?]
+ >=dev-haskell/xml-1.3.5[profile?]
+ >=dev-lang/ghc-6.10.4"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"