summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-01 08:05:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-01 08:05:34 +0000
commit74a3f0201435ad184d7d29fc8a6e253386f7b073 (patch)
treed13cac2303dc2f2796e97dad8a887438bac3920a
parentCleanup (diff)
downloadgentoo-2-74a3f0201435ad184d7d29fc8a6e253386f7b073.tar.gz
gentoo-2-74a3f0201435ad184d7d29fc8a6e253386f7b073.tar.bz2
gentoo-2-74a3f0201435ad184d7d29fc8a6e253386f7b073.zip
add patch merged upstream fo fix build with latest ffmpeg
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 x86_64)
-rw-r--r--media-sound/sox/ChangeLog6
-rw-r--r--media-sound/sox/files/sox-14.1.0-lavc.patch16
-rw-r--r--media-sound/sox/sox-14.1.0.ebuild8
3 files changed, 28 insertions, 2 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 6b5b68a38b5a..cb3eacf79105 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.89 2008/08/05 11:14:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.90 2008/10/01 08:05:33 aballier Exp $
+
+ 01 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/sox-14.1.0-lavc.patch, sox-14.1.0.ebuild:
+ add patch merged upstream fo fix build with latest ffmpeg
*sox-14.1.0 (05 Aug 2008)
diff --git a/media-sound/sox/files/sox-14.1.0-lavc.patch b/media-sound/sox/files/sox-14.1.0-lavc.patch
new file mode 100644
index 000000000000..e9359fc11860
--- /dev/null
+++ b/media-sound/sox/files/sox-14.1.0-lavc.patch
@@ -0,0 +1,16 @@
+Index: sox-14.1.0/src/ffmpeg.c
+===================================================================
+--- sox-14.1.0.orig/src/ffmpeg.c
++++ sox-14.1.0/src/ffmpeg.c
+@@ -86,7 +86,11 @@ static int stream_component_open(priv_t
+
+ codec = avcodec_find_decoder(enc->codec_id);
+ enc->workaround_bugs = 1;
++#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
+ enc->error_resilience = 1;
++#else
++ enc->error_recognition = 1;
++#endif
+ if (!codec || avcodec_open(enc, codec) < 0)
+ return -1;
+ if (enc->codec_type != CODEC_TYPE_AUDIO) {
diff --git a/media-sound/sox/sox-14.1.0.ebuild b/media-sound/sox/sox-14.1.0.ebuild
index 94e5112297ce..2a4e8eb75304 100644
--- a/media-sound/sox/sox-14.1.0.ebuild
+++ b/media-sound/sox/sox-14.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.1.0.ebuild,v 1.1 2008/08/05 11:14:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.1.0.ebuild,v 1.2 2008/10/01 08:05:33 aballier Exp $
inherit flag-o-matic eutils
@@ -30,6 +30,12 @@ DEPEND="alsa? ( media-libs/alsa-lib )
png? ( media-libs/libpng )
wavpack? ( media-sound/wavpack )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-lavc.patch"
+}
+
src_compile () {
# Fixes wav segfaults. See Bug #35745.
append-flags -fsigned-char