summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:41:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-19 11:41:44 +0000
commit752b2eab39f4c2756799b8dab9d1554c291b2e9b (patch)
tree76ddf7139aa34b4a6207d2d07ac01738168a9498
parentFix tests and fix elementtree dependency. bug #242340. (diff)
downloadgentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.tar.gz
gentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.tar.bz2
gentoo-2-752b2eab39f4c2756799b8dab9d1554c291b2e9b.zip
New version for GNOME 2.24. New APIs have been wrapped (notably GIO) and codegen is now part of pygobject.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
-rw-r--r--dev-python/pygobject/ChangeLog10
-rw-r--r--dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch50
-rw-r--r--dev-python/pygobject/pygobject-2.15.4.ebuild (renamed from dev-python/pygobject/pygobject-2.12.3.ebuild)44
3 files changed, 85 insertions, 19 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index ffcc30e1932b..59e672d8f4a3 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.48 2008/09/25 14:01:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.49 2008/10/19 11:41:44 eva Exp $
+
+*pygobject-2.15.4 (19 Oct 2008)
+
+ 19 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pygobject-2.15.4-fix-codegen-location.patch,
+ -pygobject-2.12.3.ebuild, +pygobject-2.15.4.ebuild:
+ New version for GNOME 2.24. New APIs have been wrapped (notably GIO)
+ and codegen is now part of pygobject.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> pygobject-2.14.2.ebuild:
Stable for HPPA (bug #236971).
diff --git a/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch b/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch
new file mode 100644
index 000000000000..8882cd079071
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.15.4-fix-codegen-location.patch
@@ -0,0 +1,50 @@
+---
+ Fix FHS compliance of codegen
+
+ codegen/Makefile.am | 2 +-
+ codegen/pygtk-codegen-2.0.in | 3 ++-
+ pygtk-2.0.pc.in | 2 +-
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+--- a/codegen/Makefile.am 2007-11-01 12:20:22.000000000 -0400
++++ b/codegen/Makefile.am 2008-05-28 22:21:04.000000000 -0400
+@@ -2,7 +2,7 @@ PLATFORM_VERSION = 2.0
+
+ bin_SCRIPTS = pygobject-codegen-$(PLATFORM_VERSION)
+
+-codegendir = $(pkgdatadir)/$(PLATFORM_VERSION)/codegen
++codegendir = $(pyexecdir)/gtk-2.0/codegen
+
+ codegen_PYTHON = \
+ __init__.py \
+--- a/codegen/pygobject-codegen-2.0.in 2007-11-01 12:20:22.000000000 -0400
++++ b/codegen/pygobject-codegen-2.0.in 2008-05-28 22:24:38.000000000 -0400
+@@ -1,9 +1,10 @@
+ #!/bin/sh
+
+ prefix=@prefix@
++exec_prefix=@exec_prefix@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
+-codegendir=${datadir}/pygobject/2.0/codegen
++codegendir=@pyexecdir@/gtk-2.0/codegen
+
+ PYTHONPATH=$codegendir
+ export PYTHONPATH
+--- a/pygobject-2.0.pc.in 2007-11-01 12:20:22.000000000 -0400
++++ b/pygobject-2.0.pc.in 2008-05-28 22:21:04.000000000 -0400
+@@ -4,6 +4,7 @@
+ datarootdir=@datarootdir@
+ datadir=@datadir@
+ libdir=@libdir@
++pyexecdir=@pyexecdir@
+
+ # you can use the --variable=pygtkincludedir argument to
+ # pkg-config to get this value. You might want to use this to
+@@ -12,5 +12,5 @@
+ defsdir=${datadir}/pygobject/2.0/defs
+-codegendir=${datadir}/pygobject/2.0/codegen
++codegendir=${pyexecdir}/gtk-2.0/codegen
+
+ Name: PyGObject
+ Description: Python bindings for GObject
diff --git a/dev-python/pygobject/pygobject-2.12.3.ebuild b/dev-python/pygobject/pygobject-2.15.4.ebuild
index 296ef5eab676..461bff150ff1 100644
--- a/dev-python/pygobject/pygobject-2.12.3.ebuild
+++ b/dev-python/pygobject/pygobject-2.15.4.ebuild
@@ -1,51 +1,59 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.12.3.ebuild,v 1.18 2008/05/29 16:26:20 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.15.4.ebuild,v 1.1 2008/10/19 11:41:44 eva Exp $
-WANT_AUTOCONF=latest
-WANT_AUTOMAKE=1.8
-inherit gnome2 python eutils autotools
+inherit autotools gnome2 python virtualx
DESCRIPTION="GLib's GObject library bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples libffi"
-RDEPEND=">=dev-lang/python-2.3.5
- >=dev-libs/glib-2.8
- !<dev-python/pygtk-2.9"
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.16
+ !<dev-python/pygtk-2.13"
DEPEND="${RDEPEND}
doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
>=dev-util/pkgconfig-0.12.0"
-DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+DOCS="AUTHORS ChangeLog NEWS README"
pkg_setup() {
- G2CONF="$(use_enable doc docs)"
+ if use libffi && ! built_with_use sys-devel/gcc libffi; then
+ eerror "libffi support not found in sys-devel/gcc." && die
+ fi
+
+ G2CONF="${G2CONF} $(use_enable doc docs) $(use_with libffi)"
}
src_unpack() {
gnome2_src_unpack
- # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
- # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
- # patches (for tmpfs amongst other things). Upstreams hit by this should
- # move to newer automake versions ideally.
- eautomake
+ # Fix FHS compliance, see upstream bug #535524
+ epatch "${FILESDIR}/${P}-fix-codegen-location.patch"
+
+ eautoreconf
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile
}
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "tests failed"
+}
+
src_install() {
gnome2_src_install
- insinto /usr/share/doc/${P}
- doins -r examples
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
python_version
mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \