summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-24 13:56:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-24 13:56:22 +0000
commit7908ed8cdf3e83fd6c938f0d6ff8ba036166acd8 (patch)
treedf26789ce9fd84f6275d635d5147168c879f3463
parentdont depend on cdparanoia if cdio is enabled, we wont use it; patch by Andrew... (diff)
downloadgentoo-2-7908ed8cdf3e83fd6c938f0d6ff8ba036166acd8.tar.gz
gentoo-2-7908ed8cdf3e83fd6c938f0d6ff8ba036166acd8.tar.bz2
gentoo-2-7908ed8cdf3e83fd6c938f0d6ff8ba036166acd8.zip
Build and install html documentation into the correct location, based on the LINGUAS variable, from on a patch by Andrew Savchenko in bug #299405
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild22
2 files changed, 25 insertions, 3 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 36b786d15526..1038ea4eb95a 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.728 2010/04/24 13:30:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.729 2010/04/24 13:56:22 aballier Exp $
+
+ 24 Apr 2010; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
+ Build and install html documentation into the correct location, based on
+ the LINGUAS variable, from on a patch by Andrew Savchenko in bug #299405
24 Apr 2010; Alexis Ballier <aballier@gentoo.org> mplayer-9999.ebuild:
dont depend on cdparanoia if cdio is enabled, we wont use it; patch by
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index c4b708cb6135..1a24ad9b6000 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.45 2010/04/24 13:30:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.46 2010/04/24 13:56:22 aballier Exp $
EAPI="2"
@@ -641,7 +641,24 @@ src_configure() {
src_compile() {
base_src_compile
emake || die "Failed to build MPlayer!"
- use doc && make -C DOCS/xml html-chunked
+ # Build only user-requested docs if they're available.
+ if use doc ; then
+ # select available languages from $LINGUAS
+ LINGUAS=${LINGUAS/zh/zh_CN}
+ local ALLOWED_LINGUAS="cs de en es fr hu it pl ru zh_CN"
+ local BUILT_DOCS=""
+ for i in ${LINGUAS} ; do
+ hasq $i ${ALLOWED_LINGUAS} && BUILT_DOCS+=" $i"
+ done
+ if [[ -z $BUILT_DOCS ]]
+ then
+ emake -j1 -C DOCS/xml html-chunked || die "Failed to generate html docs"
+ else
+ for i in ${BUILT_DOCS} ; do
+ emake -j1 -C DOCS/xml html-chunked-$i || die "Failed to generate html docs for $i"
+ done
+ fi
+ fi
}
src_install() {
@@ -672,6 +689,7 @@ src_install() {
dodoc DOCS/tech/mirrors/* || die
if use doc; then
+ docinto html/
dohtml -r "${S}"/DOCS/HTML/* || die
fi