summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2010-08-17 16:19:05 +0000
committerJoe Peterson <lavajoe@gentoo.org>2010-08-17 16:19:05 +0000
commit79ac3f30e2233d36d083b30732184924cf49b7ca (patch)
treecd03ac0a60f5fec2a8f1ec40da21de1129da38ed
parentAdding blocker on sys-libs/tdb when <net-fs/samba-3.3 . Thanks to Tony Vroon ... (diff)
downloadgentoo-2-79ac3f30e2233d36d083b30732184924cf49b7ca.tar.gz
gentoo-2-79ac3f30e2233d36d083b30732184924cf49b7ca.tar.bz2
gentoo-2-79ac3f30e2233d36d083b30732184924cf49b7ca.zip
Patch 0.19 to bring up to version in RedHat (includes "-D" option in btrfsctl (bug #331121))
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--sys-fs/btrfs-progs/ChangeLog9
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-0.19-r1.ebuild96
2 files changed, 104 insertions, 1 deletions
diff --git a/sys-fs/btrfs-progs/ChangeLog b/sys-fs/btrfs-progs/ChangeLog
index 91a480156476..66f0ae0342ee 100644
--- a/sys-fs/btrfs-progs/ChangeLog
+++ b/sys-fs/btrfs-progs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/btrfs-progs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/ChangeLog,v 1.29 2010/08/11 14:04:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/ChangeLog,v 1.30 2010/08/17 16:19:05 lavajoe Exp $
+
+*btrfs-progs-0.19-r1 (17 Aug 2010)
+
+ 17 Aug 2010; Joe Peterson <lavajoe@gentoo.org>
+ +btrfs-progs-0.19-r1.ebuild:
+ Patch 0.19 to bring up to version in RedHat (includes "-D" option in
+ btrfsctl (bug #331121))
11 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
btrfs-progs-0.19.ebuild, +files/btrfs-progs-0.19-glibc212.patch:
diff --git a/sys-fs/btrfs-progs/btrfs-progs-0.19-r1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-0.19-r1.ebuild
new file mode 100644
index 000000000000..07e319b17708
--- /dev/null
+++ b/sys-fs/btrfs-progs/btrfs-progs-0.19-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-0.19-r1.ebuild,v 1.1 2010/08/17 16:19:05 lavajoe Exp $
+
+inherit eutils
+
+DESCRIPTION="Btrfs filesystem utilities"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2
+ mirror://gentoo/${P}-redhat.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl debug-utils"
+
+DEPEND="debug-utils? ( dev-python/matplotlib )
+ acl? (
+ sys-apps/acl
+ sys-fs/e2fsprogs
+ )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply patch from Josef Bacik (btrfs developer at RedHat)
+ # that brings version 0.19 up to the version used in RedHat/Fedora.
+ # Includes the previous convert-remove-used-space-update patch.
+ # Also includes the "-D" option in btrfsctl (bug #331121).
+ epatch "${WORKDIR}"/${P}-redhat.patch
+
+ epatch "${FILESDIR}"/${P}-glibc212.patch
+
+ # Fix hardcoded "gcc" and "make"
+ sed -i -e 's:gcc $(CFLAGS):$(CC) $(CFLAGS):' Makefile
+ sed -i -e 's:make:$(MAKE):' Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ all || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ btrfstune btrfs-image || die
+ if use acl; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ convert || die
+ fi
+}
+
+src_install() {
+ into /
+ dosbin btrfs-show
+ dosbin btrfs-vol
+ dosbin btrfsctl
+ dosbin btrfsck
+ dosbin btrfstune
+ dosbin btrfs-image
+ # fsck will segfault if invoked at boot, so do not make this link
+ #dosym btrfsck /sbin/fsck.btrfs
+ newsbin mkfs.btrfs mkbtrfs
+ dosym mkbtrfs /sbin/mkfs.btrfs
+ if use acl; then
+ dosbin btrfs-convert
+ else
+ ewarn "Note: btrfs-convert not built/installed (requires acl USE flag)"
+ fi
+
+ if use debug-utils; then
+ dobin btrfs-debug-tree
+ else
+ ewarn "Note: btrfs-debug-tree not installed (requires debug-utils USE flag)"
+ fi
+
+ into /usr
+ newbin bcp btrfs-bcp
+
+ if use debug-utils; then
+ newbin show-blocks btrfs-show-blocks
+ else
+ ewarn "Note: btrfs-show-blocks not installed (requires debug-utils USE flag)"
+ fi
+
+ dodoc INSTALL
+ emake prefix="${D}/usr/share" install-man
+}
+
+pkg_postinst() {
+ ewarn "WARNING: This version of btrfs-progs corresponds to and should only"
+ ewarn " be used with the version of btrfs included in the"
+ ewarn " Linux kernel (2.6.31 and above)."
+ ewarn ""
+ ewarn " This version should NOT be used with earlier versions"
+ ewarn " of the standalone btrfs module!"
+}