summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-18 08:06:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-18 08:06:37 +0000
commit7a56bb964de68d52c1a545f57a7c6d4340b001e3 (patch)
tree0d9b7392aefce5a0f691c3ee34453233ded5a15d
parentthis is the qt-copy-3.0.3 packaged with kde3.0. it includes 3 fixes over qt-3... (diff)
downloadgentoo-2-7a56bb964de68d52c1a545f57a7c6d4340b001e3.tar.gz
gentoo-2-7a56bb964de68d52c1a545f57a7c6d4340b001e3.tar.bz2
gentoo-2-7a56bb964de68d52c1a545f57a7c6d4340b001e3.zip
GNUMP3d (new ebuild). Resolves bug #833
-rw-r--r--media-sound/gnump3d/ChangeLog13
-rw-r--r--media-sound/gnump3d/files/digest-gnump3d-0.9.9.41
-rw-r--r--media-sound/gnump3d/files/doc-Makefile-gentoo.patch15
-rw-r--r--media-sound/gnump3d/files/gnump3d.rc619
-rw-r--r--media-sound/gnump3d/files/mp3d.conf-gentoo.patch22
-rw-r--r--media-sound/gnump3d/gnump3d-0.9.9.4.ebuild44
6 files changed, 114 insertions, 0 deletions
diff --git a/media-sound/gnump3d/ChangeLog b/media-sound/gnump3d/ChangeLog
new file mode 100644
index 000000000000..40bc2c91754d
--- /dev/null
+++ b/media-sound/gnump3d/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-sound/gnump3d
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.1 2002/04/18 08:06:37 mkennedy Exp $
+
+*gnump3d-0.9.9.4 (18 Apr 2002)
+
+ 18 Apr 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ gnump3d-0.9.9.4.ebuild, files/digest-gnump3d-0.9.9.4,
+ files/gnump3d.rc6, files/doc-Makefile-gentoo.patch,
+ files/mp3d.conf-gentoo.patch :
+
+ New portage item: GNUMP3d (A streaming server for MP3, OGG vorbis
+ and other streamable files)
diff --git a/media-sound/gnump3d/files/digest-gnump3d-0.9.9.4 b/media-sound/gnump3d/files/digest-gnump3d-0.9.9.4
new file mode 100644
index 000000000000..cf2381475d08
--- /dev/null
+++ b/media-sound/gnump3d/files/digest-gnump3d-0.9.9.4
@@ -0,0 +1 @@
+MD5 cb2255c0f4629620f65532c75a6fb06f gnump3d-0.9.9.4.tar.gz 124368
diff --git a/media-sound/gnump3d/files/doc-Makefile-gentoo.patch b/media-sound/gnump3d/files/doc-Makefile-gentoo.patch
new file mode 100644
index 000000000000..d349bc436f93
--- /dev/null
+++ b/media-sound/gnump3d/files/doc-Makefile-gentoo.patch
@@ -0,0 +1,15 @@
+--- gnump3d-0.9.9.4.original/doc/Makefile 2002-04-14 06:36:32.000000000 -0500
++++ gnump3d-0.9.9.4/doc/Makefile 2002-04-18 02:31:32.000000000 -0500
+@@ -19,9 +19,9 @@
+ #
+ install: $(PROG)
+ install -d $(MANDIR)
+- install mp3d.1 $(MANDIR)
+- install mp3d.conf.1 $(MANDIR)
+- install mp3d-top.1 $(MANDIR)
++ install -m0644 mp3d.1 $(MANDIR)
++ install -m0644 mp3d.conf.1 $(MANDIR)
++ install -m0644 mp3d-top.1 $(MANDIR)
+
+ #
+ # Remove the software
diff --git a/media-sound/gnump3d/files/gnump3d.rc6 b/media-sound/gnump3d/files/gnump3d.rc6
new file mode 100644
index 000000000000..3a77ff7cb236
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d.rc6
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting gnump3d"
+ start-stop-daemon --start --quiet --exec /usr/bin/mp3d -- --quiet &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --exec /usr/bin/mp3d
+ eend $?
+}
diff --git a/media-sound/gnump3d/files/mp3d.conf-gentoo.patch b/media-sound/gnump3d/files/mp3d.conf-gentoo.patch
new file mode 100644
index 000000000000..257cf1297ab1
--- /dev/null
+++ b/media-sound/gnump3d/files/mp3d.conf-gentoo.patch
@@ -0,0 +1,22 @@
+--- gnump3d-0.9.9.4.original/mp3d.conf 2002-04-14 06:36:32.000000000 -0500
++++ gnump3d-0.9.9.4/mp3d.conf 2002-04-18 01:57:36.000000000 -0500
+@@ -76,7 +76,7 @@
+ # the directory containing the MP3, OGG, or other media files that
+ # you wish to share.
+ #
+-root = /home/mp3
++# root = /home/mp3
+
+
+ #
+@@ -251,8 +251,8 @@
+ # This allows the appearance to be tweaked without hacking
+ # the code of the server.
+ #
+-header_file = /etc/mp3d/header.html
+-footer_file = /etc/mp3d/footer.html
++header_file = /usr/share/gnump3d/header.html
++footer_file = /usr/share/gnump3d/footer.html
+
+
+ #
diff --git a/media-sound/gnump3d/gnump3d-0.9.9.4.ebuild b/media-sound/gnump3d/gnump3d-0.9.9.4.ebuild
new file mode 100644
index 000000000000..2feedb8e188d
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-0.9.9.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Tim Hobbs <rectrix@rectrix.cx>
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-0.9.9.4.ebuild,v 1.1 2002/04/18 08:06:37 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+SRC_URI="http://prdownloads.sourceforge.net/gnump3d/${P}.tar.gz"
+HOMEPAGE="http://gnump3d.sourceforge.net/"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ >=sys-devel/perl-5.6.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/mp3d.conf-gentoo.patch || die
+ patch -p1 <${FILESDIR}/doc-Makefile-gentoo.patch || die
+}
+
+src_compile() {
+ make PREFIX=/usr \
+ CONFIGDIR=/etc/${PN} \
+ TEMPLATEDIR=/usr/share/${PN} \
+ DEFAULT_CFLAGS="-I. ${CXXFLAGS}" \
+ linux || die
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ make PREFIX=${D}/usr \
+ CONFIGDIR=${D}/etc/${PN} \
+ TEMPLATEDIR=${D}/usr/share/${PN} \
+ MANDIR=${D}/usr/share/man/man1 \
+ DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS CHANGELOG COPYING README* TODO
+ docinto templates; dodoc templates/README*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gnump3d.rc6 gnump3d
+}