summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-09-02 07:55:46 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-09-02 07:55:46 +0000
commit7cee6e20bb33e68352f4f4503608641f7267dfcc (patch)
tree3091b00de6c7cc8fa78dceca623434910232ca7d
parentCloses #6949. (diff)
downloadgentoo-2-7cee6e20bb33e68352f4f4503608641f7267dfcc.tar.gz
gentoo-2-7cee6e20bb33e68352f4f4503608641f7267dfcc.tar.bz2
gentoo-2-7cee6e20bb33e68352f4f4503608641f7267dfcc.zip
added a new version, still development and still masked but now it installs, problems with gnumeric_datadir gnumeric_icondir and others containing expanded paths from configure --datadir= .. instead of containing the variable 'datadir' as a reference
-rw-r--r--app-office/gnumeric/ChangeLog8
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.1.81
-rw-r--r--app-office/gnumeric/gnumeric-1.1.8.ebuild96
3 files changed, 104 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 51f025c9477b..b664273bea73 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.15 2002/08/06 01:04:04 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.16 2002/09/02 07:55:46 spider Exp $
+
+*gnumeric-1.1.8 (02 Sep 2002)
+ 02 Sep 2002; Spider <spider@gentoo.org> gnumeric-1.1.8.ebuild :
+ hadto change the make install / einstall to make this build work with sandbox again. problems with configure / Makefile doing variable expansion when we dont want it to do so.
+
+
*gnumeric-1.1.6 (06 Aug 2002)
06 Aug 2002 ; Gabriele Giorgetti <stroke@gentoo.org> gnumeric-1.1.6.ebuild ChangeLog:
New version, updated deps, added new dep to gnome-extra/libgsf.
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.1.8 b/app-office/gnumeric/files/digest-gnumeric-1.1.8
new file mode 100644
index 000000000000..be5d1387e358
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.1.8
@@ -0,0 +1 @@
+MD5 059b1e2a2d30549cc5cc619d6da00a13 gnumeric-1.1.8.tar.bz2 6702897
diff --git a/app-office/gnumeric/gnumeric-1.1.8.ebuild b/app-office/gnumeric/gnumeric-1.1.8.ebuild
new file mode 100644
index 000000000000..6851836a84fe
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.1.8.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.8.ebuild,v 1.1 2002/09/02 07:55:46 spider Exp $
+
+#provide Xmake and Xemake
+inherit virtualx libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+SRC_URI="ftp://ftp.gnome.org/pub/gnome/unstable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND="=x11-libs/gtk+-2.0*
+ =dev-libs/glib-2.0*
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/libgnomeui-2.0.1
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnomeprint-1.115.0
+ >=gnome-base/libgnomeprintui-1.115.0
+ >=gnome-extra/gal2-0.0.3
+ >=gnome-extra/libgsf-1.3.0
+ >=gnome-base/libglade-2.0.0
+ dev-libs/libxml2
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( >=gnome-extra/libgda-0.2.91
+ >=gnome-base/bonobo-1.0.17 )
+ evo? ( >=net-mail/evolution-1.0.8 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix the relink bug, and invalid paths in .ls files.
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ use gb \
+ && myconf="${myconf} --with-gb" \
+ || myconf="${myconf} --without-gb"
+
+ use guile \
+ && myconf="${myconf} --with-guile" \
+ || myconf="${myconf} --without-guile"
+
+ use perl \
+ && myconf="${myconf} --with-perl" \
+ || myconf="${myconf} --without-perl"
+
+ use python \
+ && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+
+ econf ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ # addwrite "${HOME}/.gnome"
+
+ #the build process have to be able to connect to X
+ Xemake || Xmake || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ make DESTDIR=${D} install || die "install failed"
+
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+
+pkg_postinst() {
+ export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
+ echo ">>> updating GConf2 (modemlights)"
+ for SCHEMA in gnumeric-dialogs.schemas gnumeric-general.schemas ; do
+ echo $SCHEMA
+ /usr/bin/gconftool-2 --makefile-install-rule \
+ /etc/gconf/schemas/${SCHEMA}
+ done
+}