summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2008-05-20 23:20:02 +0000
committerMichael Marineau <marineam@gentoo.org>2008-05-20 23:20:02 +0000
commit7e80456b1c4abafc94bbba9d7b184a8986b491e1 (patch)
tree6bac9e2854025d90a96278256fb4d1bbe9c32fc0
parentCorrect previous addition of es_LA. (diff)
downloadgentoo-2-7e80456b1c4abafc94bbba9d7b184a8986b491e1.tar.gz
gentoo-2-7e80456b1c4abafc94bbba9d7b184a8986b491e1.tar.bz2
gentoo-2-7e80456b1c4abafc94bbba9d7b184a8986b491e1.zip
Bump ampache to 3.4
(Portage version: 2.1.4.4)
-rw-r--r--www-apps/ampache/ChangeLog7
-rw-r--r--www-apps/ampache/ampache-3.4.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/www-apps/ampache/ChangeLog b/www-apps/ampache/ChangeLog
index 26514bdce060..bd9e7e5ca877 100644
--- a/www-apps/ampache/ChangeLog
+++ b/www-apps/ampache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/ampache
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.35 2008/02/22 15:40:39 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ChangeLog,v 1.36 2008/05/20 23:20:02 marineam Exp $
+
+*ampache-3.4 (20 May 2008)
+
+ 20 May 2008; Michael Marineau <marineam@gentoo.org> +ampache-3.4.ebuild:
+ Version bump to make vollmer happy.
22 Feb 2008; Benedikt Böhm <hollow@gentoo.org> ampache-3.3.3.5.ebuild:
add need_httpd_cgi wrt #208584
diff --git a/www-apps/ampache/ampache-3.4.ebuild b/www-apps/ampache/ampache-3.4.ebuild
new file mode 100644
index 000000000000..439712c19b58
--- /dev/null
+++ b/www-apps/ampache/ampache-3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.4.ebuild,v 1.1 2008/05/20 23:20:02 marineam Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}