summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-11-22 20:56:03 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-11-22 20:56:03 +0000
commit7e98ca690ec857e948b16b582979bbff5a06d389 (patch)
tree81ea211644c2594e7216c28763164dbdc3ae626d
parentunmask ipw3945 and ipw4965 firmwares (diff)
downloadgentoo-2-7e98ca690ec857e948b16b582979bbff5a06d389.tar.gz
gentoo-2-7e98ca690ec857e948b16b582979bbff5a06d389.tar.bz2
gentoo-2-7e98ca690ec857e948b16b582979bbff5a06d389.zip
Version bump. Thanks to people in bug #184101.
(Portage version: 2.1.3.19)
-rw-r--r--net-p2p/azureus/ChangeLog16
-rw-r--r--net-p2p/azureus/azureus-3.0.3.4.ebuild154
-rw-r--r--net-p2p/azureus/files/digest-azureus-3.0.3.43
-rw-r--r--net-p2p/azureus/files/patches-3.0.3.4/01_all_remove-osx-and-win32-AzureusRestarterImpl.patch210
-rw-r--r--net-p2p/azureus/files/patches-3.0.3.4/02_all_remove-win32-TorrentListViewsUtils.patch28
-rw-r--r--net-p2p/azureus/files/patches-3.0.3.4/03_all_remove-win32-PlatformManagerPluginDelegate.patch22
-rw-r--r--net-p2p/azureus/files/patches-3.0.3.4/04_all_remove-osx-and-win32-PlatformManagerFactory.patch26
-rw-r--r--net-p2p/azureus/files/patches-3.0.3.4/azureus_all_modify-for-use-with-bcprov.patch20
8 files changed, 478 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 05cb8f788f19..657bec7d5c68 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.52 2007/11/16 13:52:24 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.53 2007/11/22 20:56:02 betelgeuse Exp $
+
+*azureus-3.0.3.4 (22 Nov 2007)
+
+ 22 Nov 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/patches-3.0.3.4/01_all_remove-osx-and-win32-AzureusRestarterImpl.pa
+ tch,
+ +files/patches-3.0.3.4/02_all_remove-win32-TorrentListViewsUtils.patch,
+ +files/patches-3.0.3.4/03_all_remove-win32-PlatformManagerPluginDelegate.p
+ atch,
+ +files/patches-3.0.3.4/04_all_remove-osx-and-win32-PlatformManagerFactory.
+ patch,
+ +files/patches-3.0.3.4/azureus_all_modify-for-use-with-bcprov.patch,
+ +azureus-3.0.3.4.ebuild:
+ Version bump. Thanks to people in bug #184101.
16 Nov 2007; Petteri Räty <betelgeuse@gentoo.org>
azureus-2.5.0.4-r1.ebuild:
diff --git a/net-p2p/azureus/azureus-3.0.3.4.ebuild b/net-p2p/azureus/azureus-3.0.3.4.ebuild
new file mode 100644
index 000000000000..ce2ac0111628
--- /dev/null
+++ b/net-p2p/azureus/azureus-3.0.3.4.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-3.0.3.4.ebuild,v 1.1 2007/11/22 20:56:02 betelgeuse Exp $
+
+###
+### @Todo The new Azureus gui requires swt built with embedded mozilla support,
+### or azureus will hang at startup. However, you can still start
+### the old GUI which doesn't require it, by using file/restart (which
+### is kind of bug, and maybe I should put that patch, that removes
+### restart from menu, back). It probably could be invoked also by using
+### a different Main class (look for them there are plenty :) so we could
+### have some old-gui flag which would run that one and remove
+### the mozilla dep. Best would be some per-user setting and startup
+### script check for swt mozilla support and die...
+###
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="BitTorrent client in Java"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=dev-java/bcprov-1.35
+ >=dev-java/commons-cli-1.0
+ >=dev-java/log4j-1.2.8
+ >=dev-java/swt-3.3_pre3
+ !net-p2p/azureus-bin
+ >=virtual/jre-1.4"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/desktop-file-utils
+ >=virtual/jdk-1.4"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ if ! built_with_use --missing false -o dev-java/swt firefox seamonkey xulrunner; then
+ eerror
+ eerror "dev-java/swt must be compiled with the firefox, seamonkey or xulrunner USE flag"
+ eerror "(support may vary per swt version) or azureus will hang at startup!"
+ eerror
+ die "recompile dev-java/swt with embedded browser"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+
+ ### Patches Azureus to use bcprov,
+ EPATCH_SUFFIX="patch" epatch "${FILESDIR}/patches-${PV}"
+
+ ### Remove an unit test we never run
+ rm -v ./org/gudy/azureus2/ui/console/multiuser/TestUserManager.java || die
+
+ ### Removes OS X files and entries.
+ rm -rv "org/gudy/azureus2/platform/macosx" \
+ "org/gudy/azureus2/ui/swt/osx" || die
+
+ ### Removes Windows files.
+ rm -rv "com/aelitis/azureus/util/win32" \
+ "org/gudy/azureus2/platform/win32" \
+ "org/gudy/azureus2/ui/swt/win32" || die
+
+ ### Removes test files.
+ rm -rv "org/gudy/azureus2/ui/swt/test" || die
+
+ ### Removes bouncycastle (we use our own bcprov).
+ rm -rv "org/bouncycastle" || die
+}
+
+src_compile() {
+ local mem
+ use amd64 && mem="256"
+ use x86 && mem="128"
+ use ppc && mem="192"
+ ejavac -J-Xmx${mem}m -encoding latin1 \
+ -classpath $(java-pkg_getjars swt-3,commons-cli-1,log4j,bcprov) \
+ $(find . -name "*.java")
+ jar cf azureus.jar $(find . -type f -a ! -name "*.java")
+}
+
+src_install() {
+
+ java-pkg_dojar "azureus.jar" || die "dojar failed"
+
+ java-pkg_dolauncher "${PN}" \
+ --main "org.gudy.azureus2.ui.common.Main" \
+ -pre "${FILESDIR}/${PN}-2.5.0.0-pre" \
+ --java_args '-Dazureus.install.path=${HOME}/.azureus/ ${JAVA_OPTIONS}' \
+ --pkg_args '--ui=${UI}'
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+
+ use source && java-pkg_dosrc "${S}"/{com,edu,org}
+}
+
+pkg_postinst() {
+ ###
+ ### @Todo We should probably deactivate auto-update it by default,
+ ### or even remove the option.
+ ###
+ elog
+ elog "It is not recommended to use the Azureus auto-update feature,"
+ elog "and it might not even work. You should disable auto-update,"
+ elog "in \"Tools\" -> \"Options...\" -> \"Interface\" -> \"Start\"."
+ elog
+
+ elog
+ elog "After running azureus for the first time, configuration"
+ elog "options will be placed in \"~/.azureus/gentoo.config\"."
+ elog "If you need to change some startup options, you should"
+ elog "modify this file, rather than the startup script."
+ elog
+ elog "Using this config file you can start the console UI."
+ elog
+
+ ewarn
+ ewarn "If you are upgrading, and the menu in Azureus has entries"
+ ewarn "like \"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "\"MessageBundle.properties\" file, and you may safely"
+ ewarn "delete \"~/.azureus/MessagesBundle.properties\"."
+ ewarn
+
+ ewarn
+ ewarn "Before azureus-2.5.0.0-r3, the Azureus plugin directory was"
+ ewarn "set to \"~/plugins\", instead of \"~/.azureus/plugins\"."
+ ewarn "If needed, you should move the plugins, to the new location."
+ ewarn
+
+ elog
+ elog "If you have problems starting Azureus, try starting it"
+ elog "from the command line to look at debugging output."
+ elog
+
+ ewarn
+ ewarn "Running Azureus as root is not supported."
+ ewarn
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/digest-azureus-3.0.3.4 b/net-p2p/azureus/files/digest-azureus-3.0.3.4
new file mode 100644
index 000000000000..a1212d858eb0
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-3.0.3.4
@@ -0,0 +1,3 @@
+MD5 1dd3f6cbf77ce90c1eb2f80d01c7e912 Azureus_3.0.3.4_source.zip 6988737
+RMD160 18ec3bbbaa1776f242e5b5e39f5c6abece59f29e Azureus_3.0.3.4_source.zip 6988737
+SHA256 e413ce9908ba940345b26024e2daedb2dbf3274aeba3996b7ed7a9b287072f8d Azureus_3.0.3.4_source.zip 6988737
diff --git a/net-p2p/azureus/files/patches-3.0.3.4/01_all_remove-osx-and-win32-AzureusRestarterImpl.patch b/net-p2p/azureus/files/patches-3.0.3.4/01_all_remove-osx-and-win32-AzureusRestarterImpl.patch
new file mode 100644
index 000000000000..e731b7bb0a43
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.3.4/01_all_remove-osx-and-win32-AzureusRestarterImpl.patch
@@ -0,0 +1,210 @@
+--- Azureus_3.0.3.4_source.orig/com/aelitis/azureus/core/update/impl/AzureusRestarterImpl.java 2007-07-30 14:13:28.000000000 +0200
++++ Azureus_3.0.3.4_source/com/aelitis/azureus/core/update/impl/AzureusRestarterImpl.java 2007-11-02 16:46:56.000000000 +0100
+@@ -30,8 +30,6 @@
+ import org.gudy.azureus2.platform.PlatformManager;
+ import org.gudy.azureus2.platform.PlatformManagerFactory;
+ import org.gudy.azureus2.platform.unix.ScriptAfterShutdown;
+-import org.gudy.azureus2.platform.win32.access.AEWin32Access;
+-import org.gudy.azureus2.platform.win32.access.AEWin32Manager;
+ import org.gudy.azureus2.update.UpdaterUtils;
+
+ import com.aelitis.azureus.core.AzureusCore;
+@@ -297,140 +295,6 @@
+ return null;
+ }
+
+- private boolean restartViaEXE(PrintWriter log,
+- String exeUpdater,
+- String[] properties,
+- String[] parameters,
+- String backupJavaRunString,
+- boolean update_only)
+- {
+- String azRunner = null;
+- File fileRestart = null;
+- if (!update_only) {
+- try {
+- azRunner = PlatformManagerFactory.getPlatformManager().getApplicationCommandLine();
+- } catch (PlatformManagerException e) {
+- // TODO Auto-generated catch block
+- e.printStackTrace();
+- }
+- }
+-
+- try {
+- int result;
+- AEWin32Access accessor = AEWin32Manager.getAccessor(true);
+- if (accessor == null) {
+- result = -123;
+- } else {
+- if (azRunner != null) {
+- // create a batch file to run the updater, then to restart azureus
+- // bceause the updater would restart azureus as administrator user
+- // and confuse the user
+- fileRestart = FileUtil.getUserFile("restart.bat");
+- String s = "title Azureus Updater Runner\r\n";
+- s += exeUpdater + " \"updateonly\"";
+- for (int i = 1; i < parameters.length; i++) {
+- s += " \"" + parameters[i].replaceAll("\\\"", "") + "\"";
+- }
+- s += "\r\n";
+- s += "start \"\" \"" + azRunner + "\"";
+- FileUtil.writeBytesAsFile(fileRestart.getAbsolutePath(), s.getBytes());
+-
+- result = accessor.shellExecute(null, fileRestart.getAbsolutePath(),
+- null, SystemProperties.getApplicationPath(),
+- AEWin32Access.SW_SHOWMINIMIZED);
+- } else {
+- String execEXE = "\"-J" + getClassPath().replaceAll("\\\"", "")
+- + "\" ";
+-
+- for (int i = 0; i < properties.length; i++) {
+- execEXE += "\"-J" + properties[i].replaceAll("\\\"", "") + "\" ";
+- }
+-
+- for (int i = 0; i < parameters.length; i++) {
+- execEXE += " \"" + parameters[i].replaceAll("\\\"", "") + "\"";
+- }
+-
+- log.println("Launch via " + exeUpdater + " params " + execEXE);
+- result = accessor.shellExecute(null, exeUpdater, execEXE,
+- SystemProperties.getApplicationPath(), AEWin32Access.SW_NORMAL);
+- }
+- }
+-
+- /*
+- * Some results:
+- * 0: OOM
+- * 2: FNF
+- * 3: Path Not Foud
+- * 5: Access Denied (User clicked cancel on admin access dialog)
+- * 8: OOM
+- * 11: Bad Format
+- * 26: Sharing Violation
+- * 27: Association incomplete
+- * 28: DDE Timeout
+- * 29: DDE Fail
+- * 30: DDE Busy
+- * 31: No Association
+- * 32: DLL Not found
+- * >32: OK!
+- */
+- log.println(" -> " + result);
+-
+- if (result <= 32) {
+- String sErrorReason = "";
+- String key = null;
+-
+- switch (result) {
+- case 0:
+- case 8:
+- key = "oom";
+- break;
+-
+- case 2:
+- key = "fnf";
+- break;
+-
+- case 3:
+- key = "pnf";
+- break;
+-
+- case 5:
+- key = "denied";
+- break;
+-
+- case 11:
+- key = "bad";
+- break;
+-
+- case -123:
+- key = "nowin32";
+- break;
+-
+- default:
+- sErrorReason = "" + result;
+- break;
+- }
+- if (key != null) {
+- sErrorReason = MessageText.getString("restart.error." + key,
+- new String[] {
+- exeUpdater,
+- SystemProperties.getApplicationPath(),
+- });
+- }
+- Logger.log(new LogAlert(false, LogAlert.AT_ERROR,
+- MessageText.getString("restart.error", new String[] {
+- sErrorReason
+- })));
+- return false;
+- }
+- } catch (Throwable f) {
+-
+- f.printStackTrace(log);
+-
+- return javaSpawn(log, backupJavaRunString);
+- }
+-
+- return true;
+- }
+
+
+ // ****************** This code is copied into Restarter / Updater so make changes there too !!!
+@@ -446,57 +310,9 @@
+ String[] parameters,
+ boolean update_only)
+ {
+- if(Constants.isOSX){
+-
+- restartAzureus_OSX(log,mainClass,properties,parameters);
+-
+- }else if( Constants.isUnix ){
+-
+ restartAzureus_Unix(log,mainClass,properties,parameters);
+-
+- }else{
+-
+- restartAzureus_win32(log,mainClass,properties,parameters,update_only);
+- }
+ }
+
+- private void
+- restartAzureus_win32(
+- PrintWriter log,
+- String mainClass,
+- String[] properties,
+- String[] parameters,
+- boolean update_only)
+- {
+- String exeUpdater = getExeUpdater(log); // Not for Updater.java
+-
+- String exec;
+-
+- //Classic restart way using Runtime.exec directly on java(w)
+- exec = "\"" + JAVA_EXEC_DIR + "javaw\" " + getClassPath() + getLibraryPath();
+-
+- for (int i = 0; i < properties.length; i++) {
+- exec += properties[i] + " ";
+- }
+-
+- exec += mainClass;
+-
+- for (int i = 0; i < parameters.length; i++) {
+- exec += " \"" + parameters[i] + "\"";
+- }
+-
+- if (exeUpdater != null) {
+- restartViaEXE(log, exeUpdater, properties, parameters, exec, update_only);
+- } else {
+- if (log != null) {
+- log.println(" " + exec);
+- }
+-
+- if (!win32NativeRestart(log, exec)) {
+- javaSpawn(log, exec);
+- }
+- }
+- }
+
+
+ private boolean
diff --git a/net-p2p/azureus/files/patches-3.0.3.4/02_all_remove-win32-TorrentListViewsUtils.patch b/net-p2p/azureus/files/patches-3.0.3.4/02_all_remove-win32-TorrentListViewsUtils.patch
new file mode 100644
index 000000000000..fc23c0cefbf8
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.3.4/02_all_remove-win32-TorrentListViewsUtils.patch
@@ -0,0 +1,28 @@
+--- Azureus_3.0.3.4_source.orig/com/aelitis/azureus/ui/swt/views/skin/TorrentListViewsUtils.java 2007-10-01 14:48:00.000000000 +0200
++++ Azureus_3.0.3.4_source/com/aelitis/azureus/ui/swt/views/skin/TorrentListViewsUtils.java 2007-11-02 16:37:00.000000000 +0100
+@@ -64,7 +64,6 @@
+ import com.aelitis.azureus.ui.swt.views.TorrentListViewListener;
+ import com.aelitis.azureus.util.AdManager;
+ import com.aelitis.azureus.util.Constants;
+-import com.aelitis.azureus.util.win32.Win32Utils;
+
+ import org.gudy.azureus2.plugins.PluginInterface;
+ import org.gudy.azureus2.plugins.PluginManager;
+@@ -602,17 +601,6 @@
+ * @param string
+ */
+ private static boolean runInMediaPlayer(String mediaFile) {
+- if (Constants.isWindows) {
+- String wmpEXE = Win32Utils.getWMP();
+- if (new File(wmpEXE).exists()) {
+- try {
+- Runtime.getRuntime().exec(wmpEXE + " \"" + mediaFile + "\"");
+- return true;
+- } catch (IOException e) {
+- Debug.out("error playing " + mediaFile + " via WMP " + mediaFile, e);
+- }
+- }
+- }
+ return false;
+ }
+
diff --git a/net-p2p/azureus/files/patches-3.0.3.4/03_all_remove-win32-PlatformManagerPluginDelegate.patch b/net-p2p/azureus/files/patches-3.0.3.4/03_all_remove-win32-PlatformManagerPluginDelegate.patch
new file mode 100644
index 000000000000..ebabaf7f7107
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.3.4/03_all_remove-win32-PlatformManagerPluginDelegate.patch
@@ -0,0 +1,22 @@
+--- Azureus_3.0.3.4_source.orig/org/gudy/azureus2/platform/PlatformManagerPluginDelegate.java 2007-07-25 13:02:00.000000000 +0200
++++ Azureus_3.0.3.4_source/org/gudy/azureus2/platform/PlatformManagerPluginDelegate.java 2007-11-02 17:04:31.000000000 +0100
+@@ -23,7 +23,6 @@
+ import java.util.Properties;
+
+ import org.gudy.azureus2.platform.unix.PlatformManagerUnixPlugin;
+-import org.gudy.azureus2.platform.win32.PlatformManagerUpdateChecker;
+
+ import org.gudy.azureus2.plugins.Plugin;
+ import org.gudy.azureus2.plugins.PluginException;
+@@ -45,10 +44,7 @@
+ PlatformManager platform = PlatformManagerFactory.getPlatformManager();
+
+ int platformType = platform.getPlatformType();
+- if (platformType == PlatformManager.PT_WINDOWS) {
+- PlatformManagerUpdateChecker plugin = new PlatformManagerUpdateChecker();
+- plugin.initialize(pluginInterface);
+- } else if (platformType == PlatformManager.PT_UNIX) {
++ if (platformType == PlatformManager.PT_UNIX) {
+ PlatformManagerUnixPlugin plugin = new PlatformManagerUnixPlugin();
+ plugin.initialize(pluginInterface);
+ } else {
diff --git a/net-p2p/azureus/files/patches-3.0.3.4/04_all_remove-osx-and-win32-PlatformManagerFactory.patch b/net-p2p/azureus/files/patches-3.0.3.4/04_all_remove-osx-and-win32-PlatformManagerFactory.patch
new file mode 100644
index 000000000000..99ea20a237fa
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.3.4/04_all_remove-osx-and-win32-PlatformManagerFactory.patch
@@ -0,0 +1,26 @@
+--- Azureus_3.0.3.4_source.orig/org/gudy/azureus2/platform/PlatformManagerFactory.java 2007-01-12 13:39:24.000000000 +0100
++++ Azureus_3.0.3.4_source/org/gudy/azureus2/platform/PlatformManagerFactory.java 2007-11-02 16:51:05.000000000 +0100
+@@ -46,23 +46,7 @@
+ if ( platform_manager == null ){
+
+ try{
+- if ( getPlatformType() == PlatformManager.PT_WINDOWS ){
+-
+- platform_manager = org.gudy.azureus2.platform.win32.PlatformManagerImpl.getSingleton();
+-
+- }else if( getPlatformType() == PlatformManager.PT_MACOSX ){
+-
+- platform_manager = org.gudy.azureus2.platform.macosx.PlatformManagerImpl.getSingleton();
+-
+- }else if( getPlatformType() == PlatformManager.PT_UNIX ){
+-
+ platform_manager = org.gudy.azureus2.platform.unix.PlatformManagerImpl.getSingleton();
+-
+- }
+- }catch( PlatformManagerException e ){
+-
+- // exception will already have been logged
+-
+ }catch( Throwable e ){
+
+ Debug.printStackTrace(e);
diff --git a/net-p2p/azureus/files/patches-3.0.3.4/azureus_all_modify-for-use-with-bcprov.patch b/net-p2p/azureus/files/patches-3.0.3.4/azureus_all_modify-for-use-with-bcprov.patch
new file mode 100644
index 000000000000..b5f129cdbe08
--- /dev/null
+++ b/net-p2p/azureus/files/patches-3.0.3.4/azureus_all_modify-for-use-with-bcprov.patch
@@ -0,0 +1,20 @@
+--- Azureus_3.0.3.4_source.orig/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java 2006-09-28 08:02:36.000000000 +0200
++++ Azureus_3.0.3.4_source/com/aelitis/azureus/core/clientmessageservice/secure/impl/SecureMessageServiceClientHelper.java 2007-11-02 17:14:25.000000000 +0100
+@@ -36,7 +36,7 @@
+ import org.bouncycastle.crypto.encodings.PKCS1Encoding;
+ import org.bouncycastle.crypto.engines.RSAEngine;
+ import org.bouncycastle.crypto.params.ParametersWithRandom;
+-import org.bouncycastle.jce.provider.RSAUtil;
++import org.bouncycastle.jce.provider.DSAUtil;
+ import org.gudy.azureus2.core3.util.Debug;
+ import org.gudy.azureus2.plugins.utils.StaticUtilities;
+
+@@ -97,7 +97,7 @@
+
+ PKCS1Encoding padded_eng = new PKCS1Encoding( eng );
+
+- CipherParameters param = RSAUtil.generatePublicKeyParameter(public_key);
++ CipherParameters param = DSAUtil.generatePublicKeyParameter(public_key);
+
+ param = new ParametersWithRandom(param, new SecureRandom());
+