summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 19:47:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 19:47:38 +0000
commit7ea162ba54a0065ad3be6a38d6ee7809a0774198 (patch)
tree5ff9703eee8543446c79a400dd5c5b45d8908b77
parentMy bad. #47063. (diff)
downloadgentoo-2-7ea162ba54a0065ad3be6a38d6ee7809a0774198.tar.gz
gentoo-2-7ea162ba54a0065ad3be6a38d6ee7809a0774198.tar.bz2
gentoo-2-7ea162ba54a0065ad3be6a38d6ee7809a0774198.zip
add inherit eutils
-rw-r--r--app-sci/gwave/gwave-20030804.ebuild12
-rw-r--r--app-sci/molden/molden-3.9.ebuild16
2 files changed, 15 insertions, 13 deletions
diff --git a/app-sci/gwave/gwave-20030804.ebuild b/app-sci/gwave/gwave-20030804.ebuild
index f4d70af11b85..0f65c860fc9d 100644
--- a/app-sci/gwave/gwave-20030804.ebuild
+++ b/app-sci/gwave/gwave-20030804.ebuild
@@ -1,32 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/gwave/gwave-20030804.ebuild,v 1.2 2004/02/01 17:52:59 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gwave/gwave-20030804.ebuild,v 1.3 2004/04/07 19:44:50 vapier Exp $
+
+inherit eutils
DESCRIPTION="A waveform viewer analog data, such as SPICE simulations."
HOMEPAGE="http://www.geda.seul.org/tools/gwave/"
SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~x86"
SLOT="0"
+KEYWORDS="~x86"
DEPEND=">=x11-libs/gtk+-1.2
>=dev-util/guile-1.6
>=x11-libs/guile-gtk-1.2.0.31"
src_compile() {
-
- epatch ${FILESDIR}/gwave-${PV}.gcc33.patch.bz2 || die
+ epatch ${FILESDIR}/gwave-${PV}.gcc33.patch.bz2
econf || die
make || die
-
}
src_install() {
-
make DESTDIR=${D} install || die
rm -f doc/Makefile* *.1
dodoc AUTHORS INSTALL NEWS README TODO doc/*
-
}
diff --git a/app-sci/molden/molden-3.9.ebuild b/app-sci/molden/molden-3.9.ebuild
index a508d2640bfe..71098f10b1a8 100644
--- a/app-sci/molden/molden-3.9.ebuild
+++ b/app-sci/molden/molden-3.9.ebuild
@@ -1,19 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/molden/molden-3.9.ebuild,v 1.3 2004/04/05 03:09:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/molden/molden-3.9.ebuild,v 1.4 2004/04/07 19:47:38 vapier Exp $
+
+inherit eutils
MY_P="${PN}${PV}"
DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.Z"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ia64"
IUSE="opengl"
+
DEPEND=""
RDEPEND="virtual/x11
opengl? ( media-libs/glut )"
-S="${WORKDIR}/${MY_P}"
+
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
@@ -21,7 +26,7 @@ src_unpack() {
epatch ${FILESDIR}/${PF}-fixMakefile.patch
# Respect $CC
- sed -i -e "s:^CC = cc:CC = ${CC}:g" ${S}/makefile
+ sed -i -e "s:^CC = cc:CC = $(gcc-getCC):g" ${S}/makefile
# Respect $CFLAGS
sed -i -e "s:^CFLAGS = :CFLAGS = ${CFLAGS} :g" ${S}/makefile
# Respect $FC if set
@@ -46,9 +51,8 @@ src_compile() {
src_install() {
dobin molden
- use opengl && \
- dobin moldenogl
- dodoc CopyRight HISTORY README REGISTER
+ use opengl && dobin moldenogl
+ dodoc HISTORY README REGISTER
cd doc
uncompress *
dodoc *