summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-01-10 17:25:04 +0000
committerMichał Górny <mgorny@gentoo.org>2014-01-10 17:25:04 +0000
commit7f2674d9cd3c94ffcba8c9bdcfa5e2edc8ea6eb4 (patch)
tree3f31702d988cc35db5a0fbe054e63f4d9e22e50f
parentStable for HPPA (bug #492784). (diff)
downloadgentoo-2-7f2674d9cd3c94ffcba8c9bdcfa5e2edc8ea6eb4.tar.gz
gentoo-2-7f2674d9cd3c94ffcba8c9bdcfa5e2edc8ea6eb4.tar.bz2
gentoo-2-7f2674d9cd3c94ffcba8c9bdcfa5e2edc8ea6eb4.zip
Re-add missing runtime gcc detection patch, bug #497704.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-3.4.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 5e44d68a2e98..b2bab98f87ce 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.169 2014/01/08 21:42:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.170 2014/01/10 17:25:04 mgorny Exp $
+
+ 10 Jan 2014; Michał Górny <mgorny@gentoo.org> llvm-3.4.ebuild:
+ Re-add missing runtime gcc detection patch, bug #497704.
08 Jan 2014; Michał Górny <mgorny@gentoo.org> llvm-3.4.ebuild,
llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-3.4.ebuild b/sys-devel/llvm/llvm-3.4.ebuild
index 7e8635ae9d41..fe6c64b8bfef 100644
--- a/sys-devel/llvm/llvm-3.4.ebuild
+++ b/sys-devel/llvm/llvm-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.ebuild,v 1.3 2014/01/08 21:42:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.ebuild,v 1.4 2014/01/10 17:25:04 mgorny Exp $
EAPI=5
@@ -161,10 +161,16 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
- use clang && epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
# Hack cmake search path for Gentoo, bug #496480
epatch "${FILESDIR}"/${PN}-3.3-cmake-modulepath.patch
+ if use clang; then
+ # Automatically select active system GCC's libraries, bugs #406163 and #417913
+ epatch "${FILESDIR}"/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+
+ epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
+ fi
+
local sub_files=(
Makefile.config.in
Makefile.rules