summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-23 05:55:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-23 05:55:50 +0000
commit7ffac99e056af8080743f87b5e9fb2e07ec41eba (patch)
treee371a60acd4b3716c94a994c95abdecd3a74ce0c
parentVersion bump, security bug #466822. (diff)
downloadgentoo-2-7ffac99e056af8080743f87b5e9fb2e07ec41eba.tar.gz
gentoo-2-7ffac99e056af8080743f87b5e9fb2e07ec41eba.tar.bz2
gentoo-2-7ffac99e056af8080743f87b5e9fb2e07ec41eba.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--app-benchmarks/siege/ChangeLog7
-rw-r--r--app-benchmarks/siege/siege-3.0.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 12c1b331f7c9..6c17546e5f6f 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/siege
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.57 2013/05/10 05:37:04 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.58 2013/05/23 05:55:50 patrick Exp $
+
+*siege-3.0.1 (23 May 2013)
+
+ 23 May 2013; Patrick Lauer <patrick@gentoo.org> +siege-3.0.1.ebuild:
+ Bump
10 May 2013; Patrick Lauer <patrick@gentoo.org> siege-3.0.0.ebuild:
Whitespace
diff --git a/app-benchmarks/siege/siege-3.0.1.ebuild b/app-benchmarks/siege/siege-3.0.1.ebuild
new file mode 100644
index 000000000000..a371b2acd548
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-3.0.1.ebuild,v 1.1 2013/05/23 05:55:50 patrick Exp $
+
+EAPI=4
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "/usr/share/doc/${PF}/"
+}