summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-03 19:31:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-03 19:31:42 +0000
commit84696a51d41875d611103b4773d8166770b0431c (patch)
tree504c490d5f20d183fe1cb7a58f4fd3743df68e7a
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-84696a51d41875d611103b4773d8166770b0431c.tar.gz
gentoo-2-84696a51d41875d611103b4773d8166770b0431c.tar.bz2
gentoo-2-84696a51d41875d611103b4773d8166770b0431c.zip
Add opencore-amr support, switch to GPL-3
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999-r1.ebuild20
-rw-r--r--media-video/ffmpeg/metadata.xml2
3 files changed, 18 insertions, 10 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 8f477ee28dce..57917a431876 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.295 2009/06/30 13:57:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.296 2009/07/03 19:31:42 aballier Exp $
+
+ 03 Jul 2009; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999-r1.ebuild,
+ metadata.xml:
+ Add opencore-amr support, switch to GPL-3
30 Jun 2009; Raúl Porcel <armin76@gentoo.org> ffmpeg-0.5-r1.ebuild:
arm/ia64/sparc stable
diff --git a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
index 073e8545c9e1..55295d0de926 100644
--- a/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.4 2009/06/10 09:08:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999-r1.ebuild,v 1.5 2009/07/03 19:31:42 aballier Exp $
EAPI=2
@@ -12,13 +12,14 @@ DESCRIPTION="Complete solution to record, convert and stream audio and video.
Includes libavcodec. live svn"
HOMEPAGE="http://ffmpeg.org/"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="+3dnow +3dnowext alsa altivec amr cpudetection custom-cflags debug dirac
doc ieee1394 +encode faac faad gsm ipv6 jack +mmx +mmxext vorbis test
- theora threads x264 xvid network zlib sdl X mp3 oss schroedinger
- +hardcoded-tables bindist v4l v4l2 speex +ssse3 jpeg2k"
+ theora threads x264 xvid network zlib sdl X mp3 opencore-amrnb
+ opencore-amrwb oss schroedinger +hardcoded-tables bindist v4l v4l2
+ speex +ssse3 jpeg2k"
RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
alsa? ( media-libs/alsa-lib )
@@ -36,6 +37,8 @@ RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
dirac? ( media-video/dirac )
gsm? ( >=media-sound/gsm-1.0.12-r1 )
jpeg2k? ( >=media-libs/openjpeg-1.3-r2 )
+ opencore-amrnb? ( media-libs/opencore-amr )
+ opencore-amrwb? ( media-libs/opencore-amr )
schroedinger? ( media-libs/schroedinger )
speex? ( >=media-libs/speex-1.2_beta3 )
jack? ( media-sound/jack-audio-connection-kit )
@@ -95,10 +98,9 @@ src_configure() {
use threads && myconf="${myconf} --enable-pthreads"
# Decoders
- use faad && myconf="${myconf} --enable-libfaad"
- use dirac && myconf="${myconf} --enable-libdirac"
- use schroedinger && myconf="${myconf} --enable-libschroedinger"
- use speex && myconf="${myconf} --enable-libspeex"
+ for i in faad dirac schroedinger speex opencore-amrnb opencore-amrwb ; do
+ use $i && myconf="${myconf} --enable-lib$i"
+ done
use jpeg2k && myconf="${myconf} --enable-libopenjpeg"
if use gsm; then
myconf="${myconf} --enable-libgsm"
@@ -141,7 +143,7 @@ src_configure() {
done
# Mandatory configuration
- myconf="${myconf} --enable-gpl --enable-postproc \
+ myconf="${myconf} --enable-gpl --enable-version3 --enable-postproc \
--enable-avfilter --enable-avfilter-lavf \
--disable-stripping"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index c15d1c6da5c7..d400ab284121 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -19,6 +19,8 @@
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="network">Enables network streaming support</flag>
+ <flag name="opencore-amrnb">Enables Adaptive Multi-Rate Narrowband support vie opencore-amr.</flag>
+ <flag name="opencore-amrwb">Enables Adaptive Multi-Rate Wideband support vie opencore-amr.</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="ssse3">faster floating point optimization for SSSE3 capable chips (Intel Core 2 and later chips)</flag>
<flag name="vhook">Enables video hooking support.</flag>