summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 21:54:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-24 21:54:05 +0000
commit846a0f959cb22853bf12cc2e364cc5fbbe3012a3 (patch)
tree6a676533c9b815875fe12eb6d66356205ca1423b
parentInitial addition. (diff)
downloadgentoo-2-846a0f959cb22853bf12cc2e364cc5fbbe3012a3.tar.gz
gentoo-2-846a0f959cb22853bf12cc2e364cc5fbbe3012a3.tar.bz2
gentoo-2-846a0f959cb22853bf12cc2e364cc5fbbe3012a3.zip
Initial addition.
(Portage version: 14724-svn/cvs/Linux x86_64)
-rw-r--r--net-zope/zope-configuration/ChangeLog10
-rw-r--r--net-zope/zope-configuration/metadata.xml6
-rw-r--r--net-zope/zope-configuration/zope-configuration-3.6.0.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/net-zope/zope-configuration/ChangeLog b/net-zope/zope-configuration/ChangeLog
new file mode 100644
index 000000000000..3b50b9e71c9f
--- /dev/null
+++ b/net-zope/zope-configuration/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-configuration
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-configuration/ChangeLog,v 1.1 2009/10/24 21:54:05 arfrever Exp $
+
+*zope-configuration-3.6.0 (24 Oct 2009)
+
+ 24 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-configuration-3.6.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-configuration/metadata.xml b/net-zope/zope-configuration/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-configuration/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-configuration/zope-configuration-3.6.0.ebuild b/net-zope/zope-configuration/zope-configuration-3.6.0.ebuild
new file mode 100644
index 000000000000..a6ddc957cade
--- /dev/null
+++ b/net-zope/zope-configuration/zope-configuration-3.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-configuration/zope-configuration-3.6.0.ebuild,v 1.1 2009/10/24 21:54:05 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Configuration Markup Language (ZCML)"
+HOMEPAGE="http://pypi.python.org/pypi/zope.configuration"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"