summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-08-26 10:03:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-08-26 10:03:38 +0000
commit88345e44530de90cadd5ea73a407fa9a0b1116e3 (patch)
treee461a11c2ba57840951d83f3d07bd0e4d8ca4489
parentVersion bump (diff)
downloadgentoo-2-88345e44530de90cadd5ea73a407fa9a0b1116e3.tar.gz
gentoo-2-88345e44530de90cadd5ea73a407fa9a0b1116e3.tar.bz2
gentoo-2-88345e44530de90cadd5ea73a407fa9a0b1116e3.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 i686)
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.1.3.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-1.1.1.ebuild)10
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.2.0_beta4.ebuild49
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-1.1.2.ebuild)10
4 files changed, 27 insertions, 52 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 10871cf35947..12ac241a8911 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.43 2008/08/25 14:45:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.44 2008/08/26 10:03:38 armin76 Exp $
+
+*qbittorrent-1.2.0_beta5 (26 Aug 2008)
+*qbittorrent-1.1.3 (26 Aug 2008)
+
+ 26 Aug 2008; Raúl Porcel <armin76@gentoo.org> -qbittorrent-1.1.1.ebuild,
+ -qbittorrent-1.1.2.ebuild, +qbittorrent-1.1.3.ebuild,
+ -qbittorrent-1.2.0_beta4.ebuild, +qbittorrent-1.2.0_beta5.ebuild:
+ Version bump
*qbittorrent-1.2.0_beta4 (25 Aug 2008)
*qbittorrent-1.1.2 (25 Aug 2008)
diff --git a/net-p2p/qbittorrent/qbittorrent-1.1.1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.1.3.ebuild
index c624b4f62865..5890e6324642 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.1.1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.1.ebuild,v 1.1 2008/08/01 17:32:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.3.ebuild,v 1.1 2008/08/26 10:03:38 armin76 Exp $
EAPI="1"
@@ -34,6 +34,14 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+}
+
src_compile() {
# econf fails, since this uses qconf
./configure --prefix=/usr --qtdir=/usr \
diff --git a/net-p2p/qbittorrent/qbittorrent-1.2.0_beta4.ebuild b/net-p2p/qbittorrent/qbittorrent-1.2.0_beta4.ebuild
deleted file mode 100644
index a5f9e46a9c6c..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-1.2.0_beta4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.0_beta4.ebuild,v 1.1 2008/08/25 14:45:22 armin76 Exp $
-
-EAPI="1"
-
-inherit eutils qt4 multilib
-
-MY_P="${P/_/}"
-
-DESCRIPTION="BitTorrent client in C++ and Qt."
-HOMEPAGE="http://www.qbittorrent.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="|| ( x11-libs/qt-gui:4 =x11-libs/qt-4.3*:4 )
- >=net-libs/rb_libtorrent-0.13.1
- dev-libs/boost
- net-misc/curl
- dev-cpp/commoncpp2"
-RDEPEND="${DEPEND}
- >=dev-lang/python-2.3"
-
-pkg_setup() {
- # We need boost built with threads
- if ! built_with_use --missing true "dev-libs/boost" threads; then
- eerror "${PN} needs dev-libs/boost built with threads USE flag"
- die "dev-libs/boost is built without threads USE flag"
- fi
-}
-
-src_compile() {
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-libtorrent-inc=/usr/include \
- --with-libtorrent-lib=/usr/$(get_libdir) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog NEWS README TODO
-}
diff --git a/net-p2p/qbittorrent/qbittorrent-1.1.2.ebuild b/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild
index 3bcc4cafabd5..9d4d42ffabb8 100644
--- a/net-p2p/qbittorrent/qbittorrent-1.1.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.1.2.ebuild,v 1.1 2008/08/25 14:45:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.2.0_beta5.ebuild,v 1.1 2008/08/26 10:03:38 armin76 Exp $
EAPI="1"
@@ -34,6 +34,14 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+}
+
src_compile() {
# econf fails, since this uses qconf
./configure --prefix=/usr --qtdir=/usr \