summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2011-08-26 09:32:07 +0000
committerAlex Legler <a3li@gentoo.org>2011-08-26 09:32:07 +0000
commit88a29867db412a5ee010cced11c05f1b7d117da3 (patch)
treeddc23e6f74fb08dd51d9664c79d077612ab62131
parentRemove old. (diff)
downloadgentoo-2-88a29867db412a5ee010cced11c05f1b7d117da3.tar.gz
gentoo-2-88a29867db412a5ee010cced11c05f1b7d117da3.tar.bz2
gentoo-2-88a29867db412a5ee010cced11c05f1b7d117da3.zip
Version bump for security bug 380601.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-3.4.4.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index f9bc08c92e6c..9c43962072f0 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.439 2011/08/11 19:23:11 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.440 2011/08/26 09:32:07 a3li Exp $
+
+*phpmyadmin-3.4.4 (26 Aug 2011)
+
+ 26 Aug 2011; Alex Legler <a3li@gentoo.org> +phpmyadmin-3.4.4.ebuild:
+ Version bump for security bug 380601.
11 Aug 2011; Alex Legler <a3li@gentoo.org> -phpmyadmin-3.4.3.1.ebuild:
Removing vulnerable versions
diff --git a/dev-db/phpmyadmin/phpmyadmin-3.4.4.ebuild b/dev-db/phpmyadmin/phpmyadmin-3.4.4.ebuild
new file mode 100644
index 000000000000..4f4417fe8fdf
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-3.4.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-3.4.4.ebuild,v 1.1 2011/08/26 09:32:07 a3li Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P="phpMyAdmin-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+setup"
+
+RDEPEND="
+ dev-lang/php[crypt,ctype,filter,json,session,unicode]
+ || (
+ <dev-lang/php-5.3[spl,pcre]
+ >=dev-lang/php-5.3
+ )
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog || die
+ rm -f LICENSE CREDITS INSTALL README* RELEASE-DATE-${MY_PV} TODO
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpmyadmin setup utility has been removed."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}