summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-07-25 10:13:48 +0000
committerChristoph Mende <angelos@gentoo.org>2011-07-25 10:13:48 +0000
commit89085fbdb8da7d9a4e8d4ce5529f93ebc93b9b49 (patch)
treeeb11bf195df879b2d5dae1e4f6414213d9053272
parentversion bump, live ebuild update, switched to git-2 (diff)
downloadgentoo-2-89085fbdb8da7d9a4e8d4ce5529f93ebc93b9b49.tar.gz
gentoo-2-89085fbdb8da7d9a4e8d4ce5529f93ebc93b9b49.tar.bz2
gentoo-2-89085fbdb8da7d9a4e8d4ce5529f93ebc93b9b49.zip
Fix compilation against curl-7.21.7 (bug #376089)
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/files/octave-3.2.4-curl-headers.patch12
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-curl-headers.patch12
-rw-r--r--sci-mathematics/octave/octave-3.2.4-r1.ebuild13
-rw-r--r--sci-mathematics/octave/octave-3.2.4-r3.ebuild27
-rw-r--r--sci-mathematics/octave/octave-3.4.0-r2.ebuild5
6 files changed, 54 insertions, 22 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index fd163c90b232..6ae94b4d7e9a 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.105 2011/07/12 20:52:00 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.106 2011/07/25 10:13:48 angelos Exp $
+
+ 25 Jul 2011; Christoph Mende <angelos@gentoo.org> octave-3.2.4-r1.ebuild,
+ octave-3.2.4-r3.ebuild, +files/octave-3.2.4-curl-headers.patch,
+ octave-3.4.0-r2.ebuild, +files/octave-3.4.0-curl-headers.patch:
+ Fix compilation against curl-7.21.7 (bug #376089)
*octave-3.4.0-r2 (12 Jul 2011)
diff --git a/sci-mathematics/octave/files/octave-3.2.4-curl-headers.patch b/sci-mathematics/octave/files/octave-3.2.4-curl-headers.patch
new file mode 100644
index 000000000000..aa4ca54537ca
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.4-curl-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/src/DLD-FUNCTIONS/urlwrite.cc b/src/DLD-FUNCTIONS/urlwrite.cc
+index 4f9aeac..d8a63da 100644
+--- a/src/DLD-FUNCTIONS/urlwrite.cc
++++ b/src/DLD-FUNCTIONS/urlwrite.cc
+@@ -46,7 +46,6 @@ along with Octave; see the file COPYING. If not, see
+ #if defined (HAVE_CURL)
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ // Write callback function for curl.
diff --git a/sci-mathematics/octave/files/octave-3.4.0-curl-headers.patch b/sci-mathematics/octave/files/octave-3.4.0-curl-headers.patch
new file mode 100644
index 000000000000..b9e0ae6b51b7
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-curl-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/src/DLD-FUNCTIONS/urlwrite.cc b/src/DLD-FUNCTIONS/urlwrite.cc
+index 83927b1..8c41d38 100644
+--- a/src/DLD-FUNCTIONS/urlwrite.cc
++++ b/src/DLD-FUNCTIONS/urlwrite.cc
+@@ -52,7 +52,6 @@ along with Octave; see the file COPYING. If not, see
+
+ #include <curl/curl.h>
+ #include <curl/curlver.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ static int
diff --git a/sci-mathematics/octave/octave-3.2.4-r1.ebuild b/sci-mathematics/octave/octave-3.2.4-r1.ebuild
index 642b2136379c..0ec6fcd2ca7d 100644
--- a/sci-mathematics/octave/octave-3.2.4-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r1.ebuild,v 1.10 2011/03/20 20:01:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r1.ebuild,v 1.11 2011/07/25 10:13:48 angelos Exp $
EAPI="2"
inherit flag-o-matic xemacs-elisp-common autotools
@@ -47,11 +47,12 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
- epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-imread.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-ldflags.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-fltk-magic.patch
+ epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch \
+ "${FILESDIR}"/${PN}-3.2.0_as_needed.patch \
+ "${FILESDIR}"/${PN}-3.2.4-imread.patch \
+ "${FILESDIR}"/${PN}-3.2.4-ldflags.patch \
+ "${FILESDIR}"/${PN}-3.2.4-fltk-magic.patch \
+ "${FILESDIR}"/${P}-curl-headers.patch
eautoreconf
}
diff --git a/sci-mathematics/octave/octave-3.2.4-r3.ebuild b/sci-mathematics/octave/octave-3.2.4-r3.ebuild
index 3fcdd0b8a554..fb929b388b49 100644
--- a/sci-mathematics/octave/octave-3.2.4-r3.ebuild
+++ b/sci-mathematics/octave/octave-3.2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r3.ebuild,v 1.4 2011/03/20 20:01:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r3.ebuild,v 1.5 2011/07/25 10:13:48 angelos Exp $
EAPI="2"
inherit flag-o-matic xemacs-elisp-common autotools
@@ -48,18 +48,19 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
- epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-imread.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-ldflags.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-fltk-magic.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-dlmread-speedup.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-addpath.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-filter-empty-vector.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-imshow.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-interp2.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-no-helvetica.patch
- epatch "${FILESDIR}"/${PN}-3.2.4-normal-marker-size.patch
+ epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch \
+ "${FILESDIR}"/${PN}-3.2.0_as_needed.patch \
+ "${FILESDIR}"/${PN}-3.2.4-imread.patch \
+ "${FILESDIR}"/${PN}-3.2.4-ldflags.patch \
+ "${FILESDIR}"/${PN}-3.2.4-fltk-magic.patch \
+ "${FILESDIR}"/${PN}-3.2.4-dlmread-speedup.patch \
+ "${FILESDIR}"/${PN}-3.2.4-addpath.patch \
+ "${FILESDIR}"/${PN}-3.2.4-filter-empty-vector.patch \
+ "${FILESDIR}"/${PN}-3.2.4-imshow.patch \
+ "${FILESDIR}"/${PN}-3.2.4-interp2.patch \
+ "${FILESDIR}"/${PN}-3.2.4-no-helvetica.patch \
+ "${FILESDIR}"/${PN}-3.2.4-normal-marker-size.patch \
+ "${FILESDIR}"/${P}-curl-headers.patch
has_version ">=x11-libs/fltk-1.3_rc1" && \
epatch "${FILESDIR}"/${PN}-3.2.4-fltk-1.3.patch
eautoreconf
diff --git a/sci-mathematics/octave/octave-3.4.0-r2.ebuild b/sci-mathematics/octave/octave-3.4.0-r2.ebuild
index 686a22da1240..17f5caaab66a 100644
--- a/sci-mathematics/octave/octave-3.4.0-r2.ebuild
+++ b/sci-mathematics/octave/octave-3.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.0-r2.ebuild,v 1.1 2011/07/12 20:52:00 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.0-r2.ebuild,v 1.2 2011/07/25 10:13:48 angelos Exp $
EAPI=4
inherit eutils base autotools
@@ -47,7 +47,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gcc46,pkgbuilddir,fltk,help,fftshift}.patch
+ epatch "${FILESDIR}"/${P}-{gcc46,pkgbuilddir,fltk,help,fftshift}.patch \
+ "${FILESDIR}"/${P}-curl-headers.patch
eautoreconf
}